Post Reply 
 
Thread Rating:
  • 2 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Attention: Intel Integrated Graphics Owners on Windows. Read This.
08-25-2013, 08:52 AM (This post was last modified: 08-25-2013 09:06 AM by solarmystic.)
Post: #16
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
(08-25-2013 08:40 AM)aki21 Wrote:  is'nt it need as minimum is opengl 2.0 and not.2.1,gma x3100 have opengl 2.0 and it work right,but it not change the fact that my driver is the main factor right now,not to mention there's no new info about direct x version(except 360 port using direct x renderer)

no other choice than wait direct x,not sure about performance,but it will surely help people with "window has stopped working problem",some may resolve it by updating driver and some may not...intel make no sense.

You're right, I just confirmed it with Henrik, and 2.0 cards will work mostly, but are still screwed if the emulator calls 2.1 functions for certain games. It's a borderline situation.

I'll update the main post now.

EDIT:- I also just realised that the baseline should be 2.0, since the Radeon X series also works just fine with PPSSPP, with only a few lingering issues (like in GTA that other cards don't have) and it doesn't support 2.1 either.

So, to summarize, the baselines for all 3 vendors are as follows.

NVIDIA:- 6xxx series minimum (2.1 support)

AMD:- X series minimum (X300+, 2.0 support)

Intel:- GMA 3000 series minimum, with the right drivers.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
08-25-2013, 10:58 AM (This post was last modified: 08-25-2013 11:15 AM by Danyal Zia.)
Post: #17
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
(08-25-2013 08:52 AM)solarmystic Wrote:  EDIT:- I also just realised that the baseline should be 2.0, since the Radeon X series also works just fine with PPSSPP, with only a few lingering issues (like in GTA that other cards don't have) and it doesn't support 2.1 either.
I don't think that you are right here. X-series supports upto OpenGL 2.1. If you don't believe me then just take a look at the screenshot provided below with the use of OpenGL Extensions Viewer. Even that damn ancient X300 supports 2.1 , which means those cards that came after X300 such as X800, X1300 etc supports OpenGL 2.1 as well.
   
That's a different case though, if some extensions of 2.1 is broken in those GPUs such as ARB_pixel_buffer_object which permits buffer objects (PBO/FBO) to be used not only with vertex array data, but also with pixel data. Also, GTA VCS uses Motion Blur all the time which is an FBO effect after all, that makes a lot of sense to me why the current implementation of those extensions in PPSSPP breaks GTA VCS for those GPUs. Anyway, drivers of ATI/AMD always seems to be inferior as compared to their rival e.g, Nvidia.
Find all posts by this user
Quote this message in a reply
08-25-2013, 07:15 PM (This post was last modified: 08-25-2013 08:00 PM by solarmystic.)
Post: #18
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
(08-25-2013 10:58 AM)Danyal Zia Wrote:  
(08-25-2013 08:52 AM)solarmystic Wrote:  EDIT:- I also just realised that the baseline should be 2.0, since the Radeon X series also works just fine with PPSSPP, with only a few lingering issues (like in GTA that other cards don't have) and it doesn't support 2.1 either.
I don't think that you are right here. X-series supports upto OpenGL 2.1. If you don't believe me then just take a look at the screenshot provided below with the use of OpenGL Extensions Viewer. Even that damn ancient X300 supports 2.1 , which means those cards that came after X300 such as X800, X1300 etc supports OpenGL 2.1 as well.

That's a different case though, if some extensions of 2.1 is broken in those GPUs such as ARB_pixel_buffer_object which permits buffer objects (PBO/FBO) to be used not only with vertex array data, but also with pixel data. Also, GTA VCS uses Motion Blur all the time which is an FBO effect after all, that makes a lot of sense to me why the current implementation of those extensions in PPSSPP breaks GTA VCS for those GPUs. Anyway, drivers of ATI/AMD always seems to be inferior as compared to their rival e.g, Nvidia.

Interesting.

So the wiki must be wrong then, since it claims ATI's X series only supports up to 2.0.

The drivers could support 2.1, but does the card ITSELF support all of 2.1's extensions?

[Image: iX9quhbqMkUr2.PNG]

This means that the X series is NOT fully 2.1 compliant in hardware, which is what I meant in my initial statement. The version exposed to the hardware is 2.1, but the hardware itself is only capable of ALL 2.0 extensions.

Here, look at this example provided from AMD themselves, even THEY state that their BEST X series cards are only fully 2.0 compliant:-

(This is the official spec page for the X1950, which was the TOP of LINE card for the X series)

http://www.amd.com/us/products/desktop/g...tions.aspx

[Image: ipQArOGACr2G9.PNG]

The same Extension Viewer application says that the DirectX version supported is 9.0c, but we damn well know that the X300/X800 series ONLY supports up to DX9.0b in hardware.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
08-26-2013, 10:56 AM
Post: #19
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
(08-25-2013 07:15 PM)solarmystic Wrote:  
(08-25-2013 10:58 AM)Danyal Zia Wrote:  
(08-25-2013 08:52 AM)solarmystic Wrote:  EDIT:- I also just realised that the baseline should be 2.0, since the Radeon X series also works just fine with PPSSPP, with only a few lingering issues (like in GTA that other cards don't have) and it doesn't support 2.1 either.
I don't think that you are right here. X-series supports upto OpenGL 2.1. If you don't believe me then just take a look at the screenshot provided below with the use of OpenGL Extensions Viewer. Even that damn ancient X300 supports 2.1 , which means those cards that came after X300 such as X800, X1300 etc supports OpenGL 2.1 as well.

That's a different case though, if some extensions of 2.1 is broken in those GPUs such as ARB_pixel_buffer_object which permits buffer objects (PBO/FBO) to be used not only with vertex array data, but also with pixel data. Also, GTA VCS uses Motion Blur all the time which is an FBO effect after all, that makes a lot of sense to me why the current implementation of those extensions in PPSSPP breaks GTA VCS for those GPUs. Anyway, drivers of ATI/AMD always seems to be inferior as compared to their rival e.g, Nvidia.

Interesting.

So the wiki must be wrong then, since it claims ATI's X series only supports up to 2.0.

The drivers could support 2.1, but does the card ITSELF support all of 2.1's extensions?

[Image: iX9quhbqMkUr2.PNG]

This means that the X series is NOT fully 2.1 compliant in hardware, which is what I meant in my initial statement. The version exposed to the hardware is 2.1, but the hardware itself is only capable of ALL 2.0 extensions.

Here, look at this example provided from AMD themselves, even THEY state that their BEST X series cards are only fully 2.0 compliant:-

(This is the official spec page for the X1950, which was the TOP of LINE card for the X series)

http://www.amd.com/us/products/desktop/g...tions.aspx

[Image: ipQArOGACr2G9.PNG]

The same Extension Viewer application says that the DirectX version supported is 9.0c, but we damn well know that the X300/X800 series ONLY supports up to DX9.0b in hardware.
Interesting. I think you are right. I always thought that it supports OpenGL 2.1 as per Extensions Viewer, so thanks for the correction. I'm seriously starting to loose respects for AMD. Btw, does most Android devices supports OpenGL 2.1? I've seen some Android users reporting Black screen on GTA VCS.
Find all posts by this user
Quote this message in a reply
08-26-2013, 10:58 AM
Post: #20
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
Mobile devices use OpenGL ES 2.0(and 3.0 in newer devices), an entirely different beast.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
08-26-2013, 11:44 AM
Post: #21
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
Ah my little Android phone is a Armv6, uses according to the system info built into PPSSPP (A great feature BTW thanks) states mine uses only OpenGL ES 2.0 Extensions. so it seems I don't have ES 2.1.

Funny enough my PC also only has OpenGL ES 2.0 Extensions.
Yet I don't have many issues with that. Huh
So my conclusion is what others are saying, its something to do with AMD/ATI graphics cards that's causing problems.
Find all posts by this user
Quote this message in a reply
08-26-2013, 12:04 PM
Post: #22
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
There is no ES 2.1.

OpenGL 2.0 isn't the same as OpenGL ES 2.0, and OpenGL 2.1 is also not the same as OpenGL ES 2.0.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
08-31-2013, 12:48 AM
Post: #23
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
Either way systems that aren't actualy able to use any of the current versions of OGL they are 100% not capable/suitable for PSP emulation at all so it's not really worth discussing if your system just barely meets the OGL 2.1 requirement, these systems are so outdated that PSP emulation on them is a no go route.
Find all posts by this user
Quote this message in a reply
08-31-2013, 01:04 AM (This post was last modified: 08-31-2013 01:04 AM by solarmystic.)
Post: #24
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
(08-31-2013 12:48 AM)VIRGIN KLM Wrote:  Either way systems that aren't actualy able to use any of the current versions of OGL they are 100% not capable/suitable for PSP emulation at all so it's not really worth discussing if your system just barely meets the OGL 2.1 requirement, these systems are so outdated that PSP emulation on them is a no go route.

The point of this thread is just to make a one stop place to point to in other threads when folk come around asking about the issue.

That is all.

Also the same reason why I made the performance guide, I got tired (and I bet others forum contributors are too), of answering the same questions over and over again from 1 post driveby junior posters who only ask that question and leave, never to be heard of again.

This way we can just link them, saving time and effort that could be better spent in other more useful efforts with regards to the emulator.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
08-31-2013, 11:55 AM
Post: #25
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
(08-31-2013 01:04 AM)solarmystic Wrote:  The point of this thread is just to make a one stop place to point to in other threads when folk come around asking about the issue.

That is all.

Also the same reason why I made the performance guide, I got tired (and I bet others forum contributors are too), of answering the same questions over and over again from 1 post driveby junior posters who only ask that question and leave, never to be heard of again.

This way we can just link them, saving time and effort that could be better spent in other more useful efforts with regards to the emulator.

I know but I think the best thing you can do for this is make a section on PPSSPP's homepage that clarifies such stuff and then create a rule that restricts people from making such questions which will mean problem solved.
Find all posts by this user
Quote this message in a reply
08-31-2013, 06:09 PM
Post: #26
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
well if it wont work, on my laptop thats only 2 years old, what good is it. im done on this emu then, no gold purchase for them.
Find all posts by this user
Quote this message in a reply
08-31-2013, 06:23 PM
Post: #27
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
If you want someone to blame, blame Intel. It's not our fault they have crap support for OpenGL.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
09-01-2013, 11:08 AM
Post: #28
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
the "ppsspp has stopped working" doesn't appear on 0.76
Find all posts by this user
Quote this message in a reply
09-20-2013, 03:58 PM
Post: #29
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
Hey I'm not sure but I have an intel graphics card and ppsspp emu used to work on my pc on win 7 but when I upgraded to Win 8 It then said that I don't have open gl 2.1 , I'm confused since it did work before, my chipset for my laptop is: mobile intel ® 4 series express chipset family. Will the ppsspp emu work on this chipset? Pls reply asap.
Find all posts by this user
Quote this message in a reply
09-20-2013, 04:19 PM
Post: #30
RE: Attention: Intel Integrated Graphics Owners on Windows. Read This.
(09-20-2013 03:58 PM)Thefreak121 Wrote:  Hey I'm not sure but I have an intel graphics card and ppsspp emu used to work on my pc on win 7 but when I upgraded to Win 8 It then said that I don't have open gl 2.1 , I'm confused since it did work before, my chipset for my laptop is: mobile intel ® 4 series express chipset family. Will the ppsspp emu work on this chipset? Pls reply asap.

i think you need to update your gpu driver firstly

my english is poor , sorry
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: