Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fast Memory on Galaxy S4
02-12-2014, 10:02 PM
Post: #1
Question Fast Memory on Galaxy S4
[Latest play store build on Verizon GS4, 4.3 stock rom, no root]

Hi all, I have a question on the Fast Memory option. When I updated to 0.9.6 in the play store, the Fast Memory setting was checked by default on both my old S3 and my new S4. In the past (on an S3), I knew this options greatly helped speed, but caused crashes.

I left the option on, figuring maybe the crashing was fixed and you wanted it on by default now. Is that the case? Because I have played Persona 3, Valkyria 2 and 3, and Corpse Party so far with next to no crashing and almost perfect performance. Persona still crashes from time to time, but its not a big deal.

I love the performance of PPSSPP now, it can run great even with frame skipping off and anisotropic filtering set to 4x.

BUT... My main question is this: can it cause Android to not properly release some memory even after PPSSPP is closed? I've been having issues with a memory leak/creep of sorts on my phone lately and I've been trying to track it down.

I know Android is supposed to use all the memory it can and all that, but my phone will eventually get up to around ~1.6GB used and start running poorly and having issues until a reboot. The touchwiz clear memory option and using other means to try and clear it out have no meaningful effect.

I'm not trying to blame PPSSPP, but I've noticed it seems to happen more often or quicker when I've been playing the emulator. I don't have many other games/apps installed otherwise, and all the bloatware I can is disabled. Not sure why I seem to hit this memory performance wall, when Android should be managing it for me.

Is this a known issue, anyone else seeing this?

(sorry, I tried a search)
Find all posts by this user
Quote this message in a reply
02-13-2014, 01:53 AM
Post: #2
RE: Fast Memory on Galaxy S4
Fast memory is basically "direct access". With it off, there's a police car at every corner making sure that memory is accessed properly.

Fast memory itself works perfectly and has no crashes/bugs whatsoever. It's like the roads in my above example: they're all well maintained, there's no potholes, it's all good.

However, there are still drunk drivers (bugs.) With police cars at every corner, we can catch them before they kill anyone or themselves, but without that bad things can become even worse. We've fixed a lot of bugs now, and most of the streets don't have drunk drivers on them.

So, fast memory itself has not been "fixed." But we enabled it because for the vast majority of games, "slow memory" is not needed, and it really is a LOT slower.

Anyway, fast memory is just about access, it's not about how it's stored, allocated, or freed. It won't affect leaking.

I haven't run PPSSPP through a leak detector lately, but I don't know of any leaks. Anyway, once a process exits, it really shouldn't be able to leak memory (unless it talks to other processes and THOSE leak, or it doesn't actually fully exit.) It *is* possible that your OpenGL driver or something else is leaking, but it's not likely.

Android should have tools to show you which processes are using how much memory. Does it not show anything useful?

Find all posts by this user
Quote this message in a reply
02-13-2014, 02:21 PM
Post: #3
RE: Fast Memory on Galaxy S4
Thanks for the reply and explanation of fast memory.

I did install System Panel Lite, which allows you to view more advanced settings like CPU use and a nice break down of memory use. When my memory is hosed like that I can check the memory in system panel, and everything seems to be normal processes that should be running. I even ran through it with a calculator to make sure it all added up to the total used and that there wasn't some phantom process not shown. Not sure why the memory use gets so high under light use, but there is nothing out of place otherwise.

It's like it gets to a point that clearing the memory, whether manually or Android's automatic background process stops working. This causes the memory to keep "creeping" up until I get some serious lag, even with home screen redraws, and apps freezing or crashing. A reboot will solve all the problems and level out my memory until the next time it happens again.

I'm starting to suspect PPSSPP is my issue, because I have not had an issue for this whole week, and have not played since Sunday. I've been monitoring my memory strictly this whole week because I tried the "limit background processes" developer option set to 4. Turns out when I rebooted the phone after making the change, it seems it defaulted back, so I was really just watching the memory without playing PPSSPP. The highest I saw my memory use was 1.36gb when I rebooted for another reason (the phone was still responsive, I was having an issue with my 4G antenna).

I'm going to keep monitoring it for the next few days and see if the problem goes away. Then I will start playing PPSSPP again, and see if I can get the memory issue to happen again. I'll report back when I know more.

Find all posts by this user
Quote this message in a reply
02-13-2014, 04:42 PM (This post was last modified: 02-13-2014 05:12 PM by Stixan.)
Post: #4
RE: Fast Memory on Galaxy S4

in my case, the game FinalFantasy-CrisisCore have a problem (crash emulator) with fast mem setting enabled ( in some combat scenes, or when i use the specialmode-UMD, an example is the blaster helicopter missiles, when there are many enemy characters in area).

ps: I have 2GB Ram (free after reboot, 1.43GB), Android stock.
Find all posts by this user
Quote this message in a reply
02-18-2014, 09:33 PM
Post: #5
RE: Fast Memory on Galaxy S4
I *think* I figured out my issue.

Short answer: it's not PPSSPP

In case anyone is curious: I have an OCD tendency to use the touchwiz recent app menu to swipe all the running apps closed as I am done with them. I think I am doing this way too aggressively and screwing with the automatic minfree manager in Android. I've toned it down quite a bit and my problems seem to have stopped for now.

Strange though, I used to do the same thing on my GS3 with no issues. Maybe its a 4.3 thing, I only had the 4.3 update on my S3 for like a week or so before getting the new phone.
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump: