Post Reply 
 
Thread Rating:
  • 4 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dissidia 012: Duodecim Final Fantasy
11-03-2015, 04:08 AM (This post was last modified: 11-03-2015 09:05 AM by AdamN.)
Post: #120
RE: Dissidia 012: Duodecim Final Fantasy
(11-03-2015 03:52 AM)Sys-XN Wrote:  
(11-03-2015 03:17 AM)AdamN Wrote:  I don't think it use random ports, everytime i tested it it always use port 1-4, i know it's an absurd port number in most system, but on a real PSP no other application is using those port, and all port can be used by the game i guess.
I updated my build recently to add another network option (thanks to LunaMoo) to change the port offset value so it won't use absurd or privileged (<1024) port anymore.

And client didn't actually "scan" but it listen to broadcasted data from host in order to know that there is room available.

Anyway, i think the remaining issue is caused by memory corruption in the PSP memory, which probably related to adhoc callback, as i have no information whether the buffer used by the callback should be managed (freed) by system or by the game, currently i assume it's allocated and freed by system (part of adhoc implementation) and i'm sharing the same buffer to be used for all matching events.
I'll try to separate the buffer for each event later to see whether it makes any difference when i had the time.
Tonight's summary (64-bit build only):

2 out of 10+ attempts worked. Both times used my IP, all other attempts on other client's IP which failed. Note that the first succeeded attempt was with 3 players, and the second succeeded attempt was with 4 players. The total # of clients capped at 5 which failed.

Network settings used by everyone:
Enable Networking/WLAN = ON
Enable built-in PRO AdHoc server = ON (host only), OFF (everyone else)
Change MAC Address = changed at least once every time we tried a group session. (Does it matter what numerical digits the MAC address is? Always confused about that)

- One of our clients, after the second successful attempt with 4 people, suggested to us to try doing Group with us 64-bit people with his 32-bit test build, but only as a spectator. That attempt failed due to a network desync (most likely because not everyone was using the same bit and/or partly because there was too many people?)

- Most of the failed attempts were due to socket errors, white screens, crashes, and the like.

- The included attachment also shows the distorted/bugged graphical display of the PPSSPP's menus in the test build... it caused complications at first and it may cause more in the future with newer users of this test build if this isn't rectified.

=End of report=

- quick note, did you upload the wrong version of Windows 32? We all tried it and it didn't work out... either that or we didn't test it thoroughly enough
- Also, what does Port offset do exactly? We left it alone for most of our tests except one where we changed 0 -> 100 (seemed like it made no difference)

Good to know you tried playing with 6 people at least, although it didn't work out... hope this report helps in this endeavor Smile
Thank for the report Smile

For the GUI issue try downloading the latest official version from here http://buildbot.orphis.net/ppsspp/ and then overwrite the exe using my build, since my builds are based on those nightly version.

The port offset is used to prevent PPSSPP (PSP games) from using privileged port (<1024) which usually requires Admin rights and to prevent the game using an already used port (ie. there are games that use port 80 where some people using it for web server)
For example, if the game normally using port 80 with port shift = 5000 the actual port will be used by the game will be 5080 (and hopefully that port isn't being used by other application also), the game it self will choose the port they wanna use, emulator can only shift it.
So if you wanna use port shifting make sure to set it to 1024 or higher (i recommend higher than 5000), And all players need to use the same port offset in order to communicate properly.

Btw, what do you mean Win32 build didn't work? was it DLL issue? if it's you'll need to install the vcredist for 32bit also, on my laptop i installed both x86 and x64-bit of vcredist so both versions worked just fine on my laptop.
PS: I build those using visual studio 2015
Here is the vcredist for vs2015 https://www.microsoft.com/en-us/download...x?id=48145

Edit: I tried running 2x 64bit + 2x 32bit on localhost and didn't have any issue starting group battle (i tried round robin (3 rounds) this time), but after a few seconds in battle i did get network sync issue Sad
And i was mistaken the port Dissidia 012 using is port 100-103 instead of 1-4 Big Grin 1-4 is the socket id

Btw, if you're having issue when Starting group battle, try starting it as soon as possible (right after the last player joined)

Edit2: I've reuploaded my builds to fix an issue with Port Shifting feature.

My Modified PPSSPP :
==============
Win32 (Old version): https://www.dropbox.com/s/iowb4kr00nzbs7k/PPSSPPWindows.zip?dl=0
Win32/64 (Newer version): https://www.dropbox.com/s/azy0qu88lolu5mj/PPSSPPWin32x64_193test.zip?dl=0
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Dissidia 012: Duodecim Final Fantasy - AdamN - 11-03-2015 04:08 AM
Dissidia 012 Support? - xokrath - 01-29-2014, 03:20 PM
Duodecim lobby problems - Scrawny - 08-21-2014, 12:18 PM
Dissidia Duodecim 012 - Esperstarr - 10-31-2014, 03:47 AM
Dissidia 012 online - 12771a - 04-04-2015, 01:41 AM

Forum Jump: