Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How do I go full screen and play music on linux?
09-21-2013, 05:17 PM
Post: #1
How do I go full screen and play music on linux?
Emulator works great, however, I can't figure out how to go full screen and the atrac3+ plugin does not appear to exist for linux so I can't hear music. Is there anyway to get around these problems?
Find all posts by this user
Quote this message in a reply
09-21-2013, 05:29 PM
Post: #2
RE: How do I go full screen and play music on linux?
Only the Windows version supports a fullscreen option right now, I believe. As for Atrac3+ plugin, you need to compile it yourself and then put libatrac3plus.so in /usr/lib.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
09-21-2013, 11:31 PM (This post was last modified: 09-22-2013 12:14 AM by SteveDeFacto.)
Post: #3
RE: How do I go full screen and play music on linux?
(09-21-2013 05:29 PM)daxtsu Wrote:  Only the Windows version supports a fullscreen option right now, I believe. As for Atrac3+ plugin, you need to compile it yourself and then put libatrac3plus.so in /usr/lib.

Lame and building 32bit binaries on a 64bit system is a lot easier said than done... Any idea how I can get around this error?
Code:
Linking CXX shared library lib/libat3plusdecoder.so
/usr/bin/ld: lib/libbase.a(MaiBitReader.cc.o): relocation R_X86_64_32 against `__gxx_personality_v0' can not be used when making a shared object; recompile with -fPIC
lib/libbase.a: could not read symbols: Bad value
collect2: error: ld returned 1 exit status
make[2]: *** [lib/libat3plusdecoder.so] Error 1
make[1]: *** [CMakeFiles/at3plusdecoder.dir/all] Error 2
make: *** [all] Error 2

EDIT: Going to leave this here for others who have this problem.
Code:
cmake -DCMAKE_REQUIRED_FLAGS:STRING="-m32"

(09-21-2013 05:29 PM)daxtsu Wrote:  Only the Windows version supports a fullscreen option right now, I believe. As for Atrac3+ plugin, you need to compile it yourself and then put libatrac3plus.so in /usr/lib.

I tried copying libat3plusdecoder.so to both /usr/lib and /usr/lib32 I also tried renaming it to libatrac3plus.so but it does not work.
Find all posts by this user
Quote this message in a reply
09-22-2013, 02:26 AM
Post: #4
RE: How do I go full screen and play music on linux?
I don't know how to get ppsspp to compile in 32bit and I don't know how to get libatrac2plus to compile in 64bit... Only way I can think of to get this to work would be to create a virtual machine to compile them both in 32bit...
Find all posts by this user
Quote this message in a reply
09-22-2013, 03:02 AM
Post: #5
RE: How do I go full screen and play music on linux?
You don't need to compile it as 32bit. It should compile fine with your system's 64-bit GCC.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
09-22-2013, 03:08 AM (This post was last modified: 09-22-2013 05:55 AM by SteveDeFacto.)
Post: #6
RE: How do I go full screen and play music on linux?
(09-22-2013 03:02 AM)daxtsu Wrote:  You don't need to compile it as 32bit. It should compile fine with your system's 64-bit GCC.

I posted the error message I got above. I tried export LDFLAGS="-fPIC" before calling make but it still gave the error. Also tried putting that flag in cmake like I did with -m32 but no luck.

EDIT: *facepalm* realize there was a PKGBUILD in AUR for this... All is well now except fullscreen...
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: