Post Reply 
 
Thread Rating:
  • 2 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Attention: Intel Integrated Graphics Owners on Windows. Read This.
08-24-2013, 12:54 AM (This post was last modified: 08-02-2014 03:52 PM by solarmystic.)
Post: #1
Attention: Intel Integrated Graphics Owners on Windows. Read This.
I've decided to open up this thread because of the numerous "PPSSPP has stopped working" posts in that other thread from people with Intel Integrated Graphics.

Let me just make this clear.

To those of you with Intel Integrated Chipsets prior to the GMA 3000 and Intel HD series (plain HD Graphics/HD 2xxx/HD 3xxx/HD 4xxx/HD 5xxxx) on your laptop/desktop PC who wish to run PPSSPP on Windows.

It is not going to happen. All you'll get is a "PPSSPP has stopped working" message.

PPSSPP NEEDS your card/graphics chipset to be OpenGL 2.0 compliant (from Henrik's FAQ on the main webpage) and to also have the drivers that support it from Intel.

In fact, why don't I make your lives easier and list out the Intel Integrated Graphics Cards that DO support PPSSPP (OpenGL 2.0 compliant) with the correct drivers from Intel:-

(Get the latest drivers from Intel here.)

(Use GPUz to quickly identify the make and model of your Intel Integrated Graphics Card.)

Quote:Fourth generation:-
(Only OpenGL 2.0 support on Windows and OpenGL 2.1 support on Linux. Yep, Intel did it again.)

GMA 3000 (946GZ, Q963, Q965)
GMA X3000 (G965)
GMA X3500 (G35)
GMA X3100 (GL960, GLE960, GM965, GME965)

Fourth Generation:-
(OpenGL 2.1 support on Windows)

GMA 4500
GMA X4500
GMA X4500HD
GMA 4500MHD

Fifth Generation:-
(OpenGL 2.1 support on Windows)

HD Graphics

Sixth Generation:-
(OpenGL 3.1 support on Windows)

HD Graphics 2000
HD Graphics 3000
HD Graphics P3000

Seventh Generation:-
(OpenGL 4.0 support on Windows)

HD Graphics 2500
HD Graphics 4000
HD Graphics P4000
HD Graphics
HD Graphics 4200
HD Graphics 4400
HD Graphics 4600
HD Graphics 5000
Iris Graphics 5100
Iris Pro Graphics 5200


The following cards are NOT OpenGL 2.0 compliant on Windows (either through capability or the lack of driver support), and if you have a card from this list, you are out of luck:-

Quote:(Chipset names in parentheses)

First Generation:-
(Capable of OpenGL 1.1 and 1.2 only)

Intel740
752
3D graphics with Direct AGP (810, 810-DC100, 810E, 810E2, 815, 815E, 815G, 815EG)

Second generation (a.k.a Intel Extreme Graphics):-
(Capable of OpenGL 1.3 only)

Extreme Graphics (845G, 845GL, 845GV, 830M, 830MG)
Extreme Graphics 2 (865G, 865GV, 852GM, 852GME, 852GMV, 854, 855GM, 855GME)

Third generation:-
(These cards are capable of OpenGL 2.0 on Linux but only of OpenGL 1.3/1.4 on Windows. Yes, Intel in their infinite wisdom decided not to make drivers with 2.0 support for these cards on Windows)

GMA 900 (910GL, 915GL, 915GV, 915G, Mobile 915 Family)
GMA 950 (945GZ, 945GC, 945G, Mobile 945 Family)
GMA 3100 (Q33, Q35, G31, G33)
GMA 3150 (Atom D4xx, Atom D5xx, Atom N4xx, Atom N5xx)

So either upgrade your graphics card, or get a new computer if you want to run PPSSPP and have an Intel graphics chipset from the list above. Posting your issue on the ppsspp forums won't do you any good, since all we'll do is just point out that you have an unsupported chipset for OpenGL 2.0 on Windows and tell you to do the same thing anyway.

Thanks for reading.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Attention: Intel Integrated Graphics Owners on Windows. Read This. - solarmystic - 08-24-2013 12:54 AM

Forum Jump: