Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Android 4.0.3] Crashing with iPega gamepad.
07-30-2013, 08:09 PM
Post: #1
[Android 4.0.3] Crashing with iPega gamepad.
Hello everyone, I'd want to report a bug, confirmed on newest development and market versions.

With iPega gamepad, connected in gamepad mode, the emulator instantly crashes with "Unfortunately, PPSSPP has stopped." whenever I press the dpad or use analog sticks. One cause of the bug could be the fact Android seems to report the axes oddly. When a program is aware of them, it goes lilke this:
Left stick: AXIS_X and AXIS_Y
Right stick: AXIS_Z (left-right) and AXIS_RZ (up-down)
But when one launches an app that doesn't use the gamepad API, it's recognised like this:
DPAD: DPAD UP, DPAD LEFT, DPAD RIGHT and DPAD DOWN (depending on app it's either with or without _ between words)
Left stick: same as dpad
Right stick: nothing at all.

My guess would be that PPSSPP gets two different inputs at the same time and crashes. It happens everywhere, menu, input settings, in-game. Even when launching and the splash screen shows up.
Find all posts by this user
Quote this message in a reply
07-30-2013, 10:22 PM
Post: #2
RE: [Android 4.0.3] Crashing with iPega gamepad.
I had the same problem with my Steelseries Free gamepad. I was able to download Bluez IME and use that as the main input instead of liking the controller natively. I don't know if this would work for you or at least give you an idea of a solution. I tried GameKeyboard and some other apps but this is the only way that worked. It still crashes on the most recent build if I try to use it natively.

Here is my post from the other thread:

So I found a solution to the problem.

The bad news is that it is more of a band-aid solution since it doesn't fix the problem with ppsspp crashing with the pad as native.

The good news is that I found a workaround to get all of the buttons to work. PPSSPP supported the Bluez IME but not native, however Bluez didn't recognize some of the Steelseries Free buttons. After some digging I found a developer build specific for this type of controller which lets me map all buttons and allows me to use it on PPSSPP. Here is the link where they had broken down the inputs and for anyone else that may use this type of controller:

I don't know if the information contained there would help in determining the cause of the crash.

Good luck.
Find all posts by this user
Quote this message in a reply
07-30-2013, 10:30 PM (This post was last modified: 07-31-2013 04:17 PM by PewnyPL.)
Post: #3
RE: [Android 4.0.3] Crashing with iPega gamepad.
Bluez IME is kinda a solution, yes. There is a version on XDA that is made with iPega in mind. But there are some problems with it. PPSSPP doesn't get the true-analog (as bluez ime assigns it to keypresses) and I had quite some serious problem with ePSXe when I had it installed.

Here's an article that the devs may find helpful, at the bottom of it is a table with specified each keycode for each button on the gamepad:

EDIT: Created an issue for it on Github.
Find all posts by this user
Quote this message in a reply
07-31-2013, 04:34 PM
Post: #4
RE: [Android 4.0.3] Crashing with iPega gamepad.
I don't think the keycodes are the issue, they seem normal for Android pads actually, nVidia Shield has the same mappings (HAT as dpad etc).

I'm gonna comment in the github issue from now on.
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump: