Post Reply 
Thread Rating:
  • 3 Votes - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Valkyria Chronicles II
03-14-2016, 08:19 PM (This post was last modified: 03-14-2016 11:09 PM by Vashzaron.)
Post: #196
RE: Valkyria Chronicles II
(03-14-2016 04:42 AM)[Unknown] Wrote:  Thanks. This is caused by depth clamping.

A workaround at the moment in the latest git builds is:
1. Switch to Direct3D 9.
2. Edit your ppsspp.ini file (in memstick/PSP/SYSTEM/) and find "HighQualityDepth". Change from True to False.

There are some git builds where this was working in OpenGL, but unfortunately there are lots of issues on mobile devices with depth accuracy, so it's been disabled for now. There might be other glitches in Direct3D 9 (OpenGL is generally better in PPSSPP), but I think it will be fine in this game.

Hopefully we'll find a proper solution in a future version.


Thanks, it worked for the Sky.

Tho it breaks the opening logos and video intro, oh well. Acceptable tradeoff.

Edit: Also invisible class change dialogue. Plus some Z-Fighting on far away character models.
Find all posts by this user
Quote this message in a reply
03-16-2016, 04:29 AM
Post: #197
RE: Valkyria Chronicles II
Hmm, z-fighting is expected but the other problems aren't. Probably more of the same issues, depth is troublesome because some games depend on it being very accurate in a 16-bit PSP buffer, but modern devices (including phones) typically use a 24-bit buffer which has more precision and therefore different accuracy.

Find all posts by this user
Quote this message in a reply
07-25-2016, 01:11 PM
Post: #198
RE: Valkyria Chronicles II
Hi all,

I'm struggling to get this game to a playable state in RetroPie. I'm using the standalone PPSSPP emulator (not Retroarch) and I've installed from source.

The game launches, and everything looks great until I start a battle. Nothing renders except the menu/2d elements. The actual battle field is completely black. Audio is fine, and I can run around (confirmed by the map).

I've tried many different settings, but perhaps I am missing something. Any help?
Find all posts by this user
Quote this message in a reply
09-02-2016, 11:18 AM
Post: #199
RE: Valkyria Chronicles II
Is there any way to fix the audio crackling issues? I'm playing it on windows and the audio is so awful it's pretty much unplayable.
Find all posts by this user
Quote this message in a reply
09-03-2016, 04:42 PM
Post: #200
RE: Valkyria Chronicles II
Most of the time if audio isn't smooth, it means you aren't getting 100% speed. Audio is output by the game as it runs.

You probably need to turn on frameskip.

Find all posts by this user
Quote this message in a reply
10-14-2016, 02:14 PM
Post: #201
RE: Valkyria Chronicles II
I haven't touched this game for a long time, but the current builds on android seems less stable than the ones from 2014. Whenever I put the screen to sleep with the power button, PPSSPP shows a black screen and crashes on wake. Any solutions?

Running the game on a Oneplus One
Find all posts by this user
Quote this message in a reply
10-26-2016, 10:54 AM
Post: #202
RE: Valkyria Chronicles II
Hey there!

It seems like other people are able to play this game mostly fine, but I'm having trouble with it. When I load the game I can see only black (and the on-screen control overlay). No textures, no splash screens, no sound of any kind, just a black screen. None of the controls do anything.

I can get to the game-specific sub-menu where I can create and load save states and the background there looks fine. But the game itself is completely dead.

What could be wrong? What should I do/try? I've fiddled with most of the setting one by one, but nothing has made any difference.

I'm using ppsspp on a Sony Xperia V (LT25i).

Any suggestions?
Find all posts by this user
Quote this message in a reply
10-31-2016, 10:35 AM
Post: #203
RE: Valkyria Chronicles II
Eh, never mind.

After trying nearly every setting and upgrading to the latest PPSSPP version, I realized that the problem must be with my game media. So I re-extracted and transferred the game image again and now it works fine. In fact this game runs very well, possibly better than any other game I have tried with PPSSPP.

But it occurred to me that this can happen to anyone, with any game. So it might be a good idea to include this tip in the FAQ.
Find all posts by this user
Quote this message in a reply
11-20-2016, 10:26 AM (This post was last modified: 03-17-2017 09:28 AM by LunaMoo.)
Post: #204
RE: Valkyria Chronicles II
Sharing some visual hackery, check this post to see what it does as it's same thing.
_S ULUS-10515
_G Valkyria Chronicles II
_C0 LOD multiplier
_L 0xE006B0BD 0x000CCF3C
_L 0x200CCF3C 0x0E200560
_L 0x20001580 0x3C1B4080 // change 4080 on the end here for first 4 digits of floating point, 4080 == 0x40000000 == 4.0
_L 0x20001584 0x449BF800
_L 0x20001588 0x0A31B0BD
_L 0x2000158C 0x461F6302
_L 0x200CCF4C 0x0E200560
_C0 LOD multiplier [Disable]
_L 0x200CCF3C 0x0E31B0BD
_L 0x200CCF4C 0x0E31B0BD
When used on ppsspp older than v1.3-140-g547b362 remove the comment from the code line or put it into newline as comments after code lines weren't supported in the past.

Edit: Another visual improvement, hackish fix for black sky:
_C0 Black Sky Fix
_L 0xE004002D 0x004884B8
_L 0x204884B8 0x0A200580
_L 0x20001600 0x254AFFFF
_L 0x20001604 0x0A322130
_L 0x20001608 0x98CB002D
_C0 Black Sky Fix [Disable]
_L 0x204884B8 0x98CB002D
For same game version as above, comparison screenshots also in the post linked above for the other hack.

Edit: Also new version of my 60 fps patch:
_C0 60 fps v2
_L 0xE003FFF7 0x003EBC4C
_L 0x203EBC4C 0x00000000
_L 0x20044800 0x46006346
_L 0x20044AEC 0x46006B06
//requires restart after activating:3
_C0 60 fps v2 [Disable]
_L 0x203EBC4C 0x1620FFF7
_L 0x20044800 0x460C0342
_L 0x20044AEC 0x460D6302
just like for Senjou no Valkyria 3 E2 this only unlocks fps a bit differently, not sure if it even benefit this game as I didn't played it for a long time. - Custom PPSSPP Shaders! - simple CE scripts to help creating CWCheats, - CWCheat workarounds.
Find all posts by this user
Quote this message in a reply
03-19-2017, 10:43 PM (This post was last modified: 03-19-2017 10:46 PM by Vashzaron.)
Post: #205
RE: Valkyria Chronicles II
Trying to Network Adhoc this game with 3 people and I'm wondering if anyone else has done so without issues?

2 People = No problem everything is fine.
3 People = Lobby issues where the 2nd person who joins the majority of the time doesn't see the 3rd join and if you hit deploy from the lobby in this state it just ends in network errors, only "fix" I've seen so far is for the 2nd and 3rd player to leave and come back how many times it takes that everyone sees each other. (The host and the last to join sees everyone always)

Like no idea what the this issue is about considering the person who doesn't "see" the other join can at the same time see the 3rd join for a split second and leave (they are still in) and/or they hear the bell noise of another player joining but see nothing. Typically what also happens is this person can leave but a "ghost" of them stays and if they try to rejoin in this state they get infinite loading of trying to rejoin the lobby, so room remake is required.

From Hamachi to Evolve, same issue. Changing hosts, same issue. Try changing some settings in PPSSPP like turning off fast memory and cheats, same issue.

TD:LR: Getting 3 people multiplayer working consecutively seems like RNG lol.

Any recommendations on trying something to fix this? It's really annoying, because after you get through that it all works fine but rooms need to be remade for every mission.
Find all posts by this user
Quote this message in a reply
02-10-2020, 06:43 PM
Post: #206
RE: Valkyria Chronicles II

I've been trying to get the DLC missions but can't figure out what I'm doing wrong.

Downloaded the dlc (there's around 10 of them, each in a folder e.g. DL15, DL16 etc), and I placed those folders in SAVEDATA.
I don't see the missions in EXTRAS or in the game itself.. I also tried placing the dlc folders in GAME.

Any ideas?
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump: