Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Video support
06-07-2013, 12:44 PM
Post: #76
RE: Video support
(06-07-2013 12:37 PM)tiktakt0w Wrote:  
(06-07-2013 12:34 PM)aki21 Wrote:  
(06-07-2013 12:25 PM)tiktakt0w Wrote:  
(06-07-2013 12:20 PM)aki21 Wrote:  I have edit my post above,btw I use xperia mini.

Ahhh thanks! and I experience lags too, albeit, the emu is still in beta. Smile

there's many optimization in the future,the speed will slightly increase little by little,there also some games running perfect on my phone,the sound and videos making good progress tooSmile

Hahaha! Yes yes. Smile
Well, I know this is kinda off topic but what games runs at full speed on your phone?

Yes I know, Off - topic. Confused

(haha! You edited your Signature Ehh? Wink )

well some 2d games like trail in the sky and some more, 3d games kamen rider climax,naruto (kizuna,ultimate 3,impact)and some more,other games I just play using my laptopSmile

my sub weapon:
xperia mini hd
1ghz scorpion
single core
not clocked

my ultimate weapon
acer(laptop)
2.2ghz ?core
intel media accelarator 3000

i'm a tester,but not as good as other,please be kind with me,haha.
Visit this user's website Find all posts by this user
Quote this message in a reply
06-07-2013, 03:52 PM
Post: #77
RE: Video support
FMV doesn't work for God of War: Chains of Olympus. Is there any way to fix this? I'm using v0.7.6-1171.
Find all posts by this user
Quote this message in a reply
06-07-2013, 04:27 PM (This post was last modified: 06-07-2013 04:27 PM by the avenger.)
Post: #78
RE: Video support
so i am trying to get this for ios,it works if you link the libraries when building manually,whoever i am trying to get it to work out of the box,i tried adding the following to the cmakelists.txt
Code:
add_definitions(-DUSE_FFMPEG)
include_directories(ffmpeg/ios/universal/include)
link_directories(iffmpeg/ios/universal/lib)
target_link_libraries(PPSSPP iconv libavformat.a libavcodec.a libswresample.a libswscale.a libavutil.a bz2)
however it gives me the following linker errors when compiling
Code:
directory /path/to/ppsspp/ffmpeg/ios/universal/release_iphoneos not found
library not found for -lavformat
any help appreciated
Find all posts by this user
Quote this message in a reply
06-07-2013, 04:50 PM
Post: #79
RE: Video support
http://www.cmake.org/Wiki/CMake:How_To_Find_Libraries

find_library() might be needed? I'm not sure.

-[Unknown]
Find all posts by this user
Quote this message in a reply
06-07-2013, 06:22 PM
Post: #80
RE: Video support
It seems that if I disable subtitles, the FMV works in God of War: Chains of Olympus. However, the first FMV doesn't show even when the subtitles are off.
Find all posts by this user
Quote this message in a reply
06-11-2013, 04:51 PM (This post was last modified: 06-11-2013 04:54 PM by XinXin.)
Post: #81
RE: Video support
Crisis Core FMVs work perfectly with one issue. When it starts to play a video, the system RAM usage keeps steadily increasing very fast. Now this may not be a problem for small videos or on systems with a large RAM but my laptop has just 4GBs and when this RAM usage nears this mark, the emulator freezes and I've to close it via task manager.
Haven't tested other games yet.

*edit, version used was v0.7.6-1267-gc98d2eb
Find all posts by this user
Quote this message in a reply
06-11-2013, 04:55 PM
Post: #82
RE: Video support
Those RAM issues have been reported from users using AMD Catalyst "AI mode" or something like that, and it's fixed if you turn it off.

Do you have a Radeon card?
Find all posts by this user
Quote this message in a reply
06-11-2013, 05:02 PM (This post was last modified: 06-11-2013 05:24 PM by XinXin.)
Post: #83
RE: Video support
Yes, Its an ATI Mobility Radeon. I'll Be back after fiddling with some more settings then. Big Grin

And wow! Fast reply Smile Thanks.

*edit, It works now, somewhat. The increase in RAM usage is lower. With Catalyst AI on, PPSSPP went upto 3.1GB RAM before crashing, now with it turned off after playing the same video, it went to ~124MB. But what seems strange is it doesn't come down after the video playback is done.
Find all posts by this user
Quote this message in a reply
06-11-2013, 11:50 PM
Post: #84
RE: Video support
Currently it reads the full video into memory to play it, which isn't exactly ideal but works. That might be why.

I think if we mux correctly, we just need the header and maybe a few mpeg frames back to do savestates and etc. properly, but I don't know if ATRAC3+ can decode that way.

Still, it should not go too high.

-[Unknown]
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: