Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help PPSSPP Switch crash
03-26-2021, 01:33 AM
Post: #1
Help PPSSPP Switch crash
So yesterday I installed and started playing Legend of Heroes Prophecy of the moonlight witch through PPSSPP standalone on my Nintendo switch that I acquired from the home brew browser. Resolution set to PSP 3x upscale set to auto-xBRZ. For the most part besides these two setting I think all others were default. It worked for at least an hour when I decided I wanted to play Lunar Silver Star Harmony on my Switch. I’m aware of it’s font problems so I pulled the font folder from the PPSSPP assets and moved them to the flash0 folder (noticing it already had some in there but assuming these were the ones that would fix it) I then copied over my Lunar rip as well as the other two Legend of Heroes games so I could have them all in one place. Lunar gave me hell getting it working but eventually it worked. I decided to go back to LoH:PotMW and it crashed immediately. I noticed I was accidentally trying to run it in applet mode so I ran it in game replace mode and it crashed. I rebooted my switch and it still won’t even launch, so I tried it in the PPSSPP core of RetroArch and it crashes. I updated assets and cores in retroarch and still nothing. So I uninstalled and reinstalled PPSSPP Standalone. still crashes. I uninstalled again, deleted everything associated to it, came to this website, downloaded the 1.9.3 and 1.9 versions, installed and tried them both and still, it crashes. Lunar, Crisis Core, Star Ocean 2 and Legend of heroes Tears of Vermillion all work fine but Legend of Heroes Prophecy of the moonlight witch and Legend of Heroes Song of the Ocean both crash immediately.

I thought maybe having all 3 with such similar long names was the problem so I deleted the two I’m not playing and just tried prophecy witch again, still crashes, I deleted retroarch completely just to make sure it’s not interfering, reinstalled PPSSPP standalone, rebooted my switch and for the life of me prophecy witch won’t launch, I’ve deleted the iso and copied it over many times through ftp and through goldtree thinking maybe it’s corrupt. The iso works fine on my windows pc, works fine on my vita and PSPGO, worked fine for an hour yesterday on my switch but for the life of me I can’t get it working again on my switch. I’ve tried different switch over clock cpu speeds to see if that’s it. I’ve tried renaming the iso to a much shorter name. Nothing works. I’m about this close to wiping my entire switch. Any ideas would be much appreciated, either new settings I can try, maybe someone could look at a log, I don’t know. I really want to keep playing this game on my switch and I’m super frustrated.
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump: