Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
English Font issue
06-20-2016, 10:44 AM (This post was last modified: 06-20-2016 11:02 AM by Hizaki.)
Post: #1
English Font issue
Hi,Dudes!I have some problem.
I reinstalled my OS on new from Linux Kubuntu 15.04 to 16.04 version. Before that i saved all my saves from ppsspp emulator saves directory.After installing new OS I installed latest version of PPSSPP it's 1.2.2 , load back all saves in /home/user/.config/ppsspp/SAVEDATA ,oh yeah, all saves saved correctly and when I loading the game emulator display saves.But there's a problem with font,all english letters/symbols look like squares,and only some japanese letters/symbols display correct.WTF?Maybe there in config file have option of encode,which i should to setup like UTF-8? Please,help somebody. Before PPSSPP version 1.2.2 was 0.9.X don't remember exactly.
Thanks for answers and helps!

For example i attached 2 pic
First display,when i load the game save(any game) there's problem
   
Second pic display how it looks when i open in emulator settings-tools-Save manager(there's looks normal)
   
Find all posts by this user
Quote this message in a reply
08-03-2016, 05:23 PM
Post: #2
RE: English Font issue
I am having exactly the same issue on Linux right now - did you eventually fix your problem? I have tried with a fresh configuration, with my current config, etc, no matter what I do those fonts look like boxes like on your screenshots...[/align]
Find all posts by this user
Quote this message in a reply
08-04-2016, 01:40 PM
Post: #3
RE: English Font issue
Hmm, we should be using the ppge atlas for these letters. Where did you get the PPSSPP build from?

-[Unknown]
Find all posts by this user
Quote this message in a reply
08-05-2016, 12:43 AM (This post was last modified: 08-05-2016 12:52 AM by elafargue.)
Post: #4
RE: English Font issue
Got the build from the official ppa repositories on the ppsspp.org page, for Linux.

Interestingly, when using an older version of ppge_atlas.zim in the assets folder, I get something else - not squares, but random-looking garbage...

The version of ppsspp I'm using is the current one on ppa, which is 1.2.2
Find all posts by this user
Quote this message in a reply
08-05-2016, 07:00 AM
Post: #5
RE: English Font issue
I think that ppa is rebuilding the zim using some other fonts or something, due to some Debian licensing requirements. Maybe there's a bug in whatever is doing that.

Can you try the official ppge_atlas.zim?

https://github.com/hrydgard/ppsspp/blob/..._atlas.zim

-[Unknown]
Find all posts by this user
Quote this message in a reply
08-05-2016, 11:16 AM
Post: #6
RE: English Font issue
awesome
Find all posts by this user
Quote this message in a reply
08-07-2016, 01:40 AM
Post: #7
RE: English Font issue
I tried that one, it gave me garbage on the screen - a different kind but still unreadable. I ended up installing the Linux packages directly from build.ppsspp.com ... downloads#linux and those seem to work fine.


(08-05-2016 07:00 AM)[Unknown] Wrote:  I think that ppa is rebuilding the zim using some other fonts or something, due to some Debian licensing requirements. Maybe there's a bug in whatever is doing that.

Can you try the official ppge_atlas.zim?

-[Unknown]
Find all posts by this user
Quote this message in a reply
08-07-2016, 03:34 AM
Post: #8
RE: English Font issue
Ah, it must've built it with different metrics too.

-[Unknown]
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: