Post Reply 
Thread Rating:
  • 5 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Grand Theft Auto: Liberty City Stories
03-27-2015, 08:52 PM (This post was last modified: 03-29-2015 10:49 PM by scottishgamer.)
Post: #133
RE: Grand Theft Auto: Liberty City Stories
Hello, Can anyone Help me please!

I have got all the way to the last level "Sicilian Gambit" and i have encountered this strange glitch - When I get to the Pier and I have to shoot this baddie in order to get on a boat, I kill him but the game doesn't seem to register it as a kill (down arrow remains over his body), therefore I cant get the cutscene to advance onto the boat. It's the 1st time it's happened the entire time i've played it. Why now, 99% done of the game and it goes and does this on me Angry. I've tried loads of different ways of killing him as well as applying different game settings to try and correct it but nothing. Anyone else encountered this glitch?
My specs:
Windows 7 Ultimate 64 bit
2GB ram
AMD Radeon 5670 Graphics card
AMD Athlon 64 FX-60 Dual Core Processsor

The ISO i'm playing is the USA version on ppsspp 1.0 - 64bit.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Grand Theft Auto: Liberty City Stories - scottishgamer - 03-27-2015 08:52 PM
GTA Liberty City Stories v3 - godlesplay - 04-17-2013, 03:03 PM
gta lcs cheatdevice - joeywen0830 - 04-08-2014, 03:18 AM
gta lcs graphics glitch - adeeb222 - 04-18-2014, 01:39 PM
Can i run...? - Jaxx02 - 03-01-2015, 01:55 PM
GTA LCS black screen - Addyboy - 08-31-2015, 11:09 PM

Forum Jump: