Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Prevent FPS From Exceeding 30?
03-29-2014, 03:38 AM (This post was last modified: 03-29-2014 03:39 AM by Adeno.)
Post: #1
Prevent FPS From Exceeding 30?
(This should go to General... no idea how it ended up here)

I noticed that there's an option to "Prevent FPS From Exceeding 60" in the emulator for pc, but what if I don't want it to go over 30? It's just that at 60 fps, the game runs at double speed. I tried using the Alternative Speed option and setting it to 50%, but it seems to garble the audio.

Normally, the game I play runs at only 30 fps and everything moves normally, but during a specific scene, it triggers some kind of glitchy turbo mode that doubles the fps to 60 and makes the game ridiculously fast that a timer that counts down from 3 minutes can be finished in just 1:30 min of real life time.

Thanks to anyone who can give me tips on how to change that "Prevent FPS From Exceeding 60" into just not exceeding 30.Smile

Maybe having a 30 fps max option would be nice to have in the next version of the emulator for pc.
Find all posts by this user
Quote this message in a reply
03-29-2014, 12:15 PM
Post: #2
RE: Prevent FPS From Exceeding 30?
Moved.

♦ Intel Core i7-6700HQ | 16 GB RAM | NVIDIA GeForce GTX 960M | Debian Testing
♦ Intel Core i7-2630QM | 4 GB RAM | NVIDIA GeForce GT 540M | Debian Testing
♦ PSP-3004 | 6.60 PRO-C2
Find all posts by this user
Quote this message in a reply
03-29-2014, 12:30 PM
Post: #3
RE: Prevent FPS From Exceeding 30?
If you want to limete the emulator to 30 FPS, open the ppsspp.ini file (on Android is in "sdcard/PSP/SYSTEM" and on Widows should be in "ppsspp/SYSTEM") and find the line "ForceMaxEulatedFPS = 60" and change 60 to 30, remember that the option need to be enabled on the emulator.

I hope this helps. Smile

Phone: Xiaomi Redmi Note 6 Pro 4/64GB

PC: Core i5 3470/8GB RAM/GTX 660 2GB/Windows 10 Pro x64
Find all posts by this user
Quote this message in a reply
03-29-2014, 01:47 PM
Post: #4
RE: Prevent FPS From Exceeding 30?
(03-29-2014 12:30 PM)GuilhermeGS2 Wrote:  If you want to limete the emulator to 30 FPS, open the ppsspp.ini file (on Android is in "sdcard/PSP/SYSTEM" and on Widows should be in "ppsspp/SYSTEM") and find the line "ForceMaxEulatedFPS = 60" and change 60 to 30, remember that the option need to be enabled on the emulator.

I hope this helps. Smile

Thanks, I'll try that! I hope it works Smile
Find all posts by this user
Quote this message in a reply
03-29-2014, 05:38 PM
Post: #5
RE: Prevent FPS From Exceeding 30?
(03-29-2014 12:30 PM)GuilhermeGS2 Wrote:  If you want to limete the emulator to 30 FPS, open the ppsspp.ini file (on Android is in "sdcard/PSP/SYSTEM" and on Widows should be in "ppsspp/SYSTEM") and find the line "ForceMaxEulatedFPS = 60" and change 60 to 30, remember that the option need to be enabled on the emulator.

I hope this helps. Smile

I tested with MHFU and it doesn't work...
I don't know if it could work with another game...

♦ Intel Core i7-6700HQ | 16 GB RAM | NVIDIA GeForce GTX 960M | Debian Testing
♦ Intel Core i7-2630QM | 4 GB RAM | NVIDIA GeForce GT 540M | Debian Testing
♦ PSP-3004 | 6.60 PRO-C2
Find all posts by this user
Quote this message in a reply
03-29-2014, 09:04 PM
Post: #6
RE: Prevent FPS From Exceeding 30?
Um...I tested some versions ago and it worked, I played GoW Chais of Olympus. I was looking for more Speed and less FPS, but at 30 FPS it was running so slower.

Phone: Xiaomi Redmi Note 6 Pro 4/64GB

PC: Core i5 3470/8GB RAM/GTX 660 2GB/Windows 10 Pro x64
Find all posts by this user
Quote this message in a reply
03-30-2014, 11:03 PM
Post: #7
RE: Prevent FPS From Exceeding 30?
Hi again!

I was able to try it but for some strange reason, it doesn't seem to work (PPSSPP 0.9.8). What happens is that upon running PPSSPP, things still run at the same speed/fps. I checked the ini file after I closed the program and found out that the forcedmaxemulatedfps value went back to 60. I even tried changing it back to 30, saving it, and then setting the file to Read Only mode but that didn't work as the game just went about its normal speed.

The game I'm trying to limit to 30 fps is called Boxer's Road 2 The Real.

I'm still trying to figure out how to make a log file out of it so I can post more information in the game's thread in the Playable section so the developers might see what's going on.

Thanks anyway Big Grin
Find all posts by this user
Quote this message in a reply
03-31-2014, 08:37 AM (This post was last modified: 03-31-2014 08:37 AM by Nezarn.)
Post: #8
RE: Prevent FPS From Exceeding 30?
Why do you want 30 fps? If you're on PC, then download Dxtory trial (this is a video recording software), and there is an option to limit FPS (and you dont even need to start recording a video, and you can use this with like every game)
[Image: wWK40oM.png]

PC Specs:
Intel Pentium Dual-Core E6700 3.2 Ghz
4gb ddr3 ram
Geforce GTS 450 1 GB DDR3
Windows 7 x64
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: