Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
03-27-2014, 02:59 PM (This post was last modified: 04-26-2014 05:37 PM by TheDax.)
Post: #1
Information Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
After the update, the emulator does not work anymore.
This occur with both latest versions (0.9.7 and 0.9.8).
In the image, you can see the problem. I wait for 'informations'.
Thanks!

Moderator's note: If your legacy ATI card (e.g. HD 2000/3000/4000 series, not including the old Radeon X series) is exhibiting this behaviour after updating to 0.9.8, you should update your ATI drivers to 11.11a (Windows Vista, 7).

For Windows XP: http://drivers.softpedia.com/get/GRAPHIC...r-XP.shtml.


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
03-27-2014, 06:10 PM (This post was last modified: 05-31-2014 01:17 PM by TheDax.)
Post: #2
RE: Help!
I'll assume this is another old ATI GPU user issue, since they've been the only people to report oddities like this.

Make sure your GPU drivers are updated to 11.11a, if you're on an old ATI/AMD card, and you're using really old drivers.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
03-27-2014, 10:07 PM
Post: #3
RE: Help!
Thank you! I've downloaded the Win XP version of the update, and now, is working great!
Find all posts by this user
Quote this message in a reply
03-27-2014, 10:11 PM (This post was last modified: 04-01-2014 02:18 AM by TheDax.)
Post: #4
RE: Help!
No problem, have fun. Smile

Marked topic as resolved, and added some details to the title.

Edit: 3/31/2014: Made this topic a sticky, since its occurrence is starting to rise. We can always remove it later.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
04-01-2014, 12:51 PM (This post was last modified: 04-01-2014 12:53 PM by solarmystic.)
Post: #5
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
Just to futher elaborate on the matter, "old" in this case means "Legacy", i.e. cards that AMD doesn't actively support anymore with the latest driver updates.

Basically the ATI Radeon HD and Mobility HD 2xxx/3xxx/4xxx series but NOT including the even older super legacy X series cards. 11.11a does not even cover those.

The 5xxx series can be considered old (it was first released in 2009), but is still actively supported by AMD. If you have this issue and are using a Radeon/Mobility Radeon 5xxx series or newer card, you should not use the 11.11a drivers, head straight for the latest ones that AMD provides on its website.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
04-01-2014, 06:10 PM
Post: #6
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
Thanks for the note. I added it to the first post.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
04-26-2014, 05:37 PM
Post: #7
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
Added a link for Windows XP drivers into the first post.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
05-05-2014, 04:13 PM (This post was last modified: 05-05-2014 08:11 PM by jkpwed.)
Post: #8
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
New drivers (13.9) for ATI Radeon HD 2000/3000/4000 series Windows 7-64 bit and Windows Xp-32bit (Old ones in my case were 13.1)

ASRock Fatal1ty Z97 Killer | Intel i5-4690k @ 3.50GHz | G.Skill Ripjaws X Series 2x4GB DDR3 1600MHz | ASUS Radeon R9 270X DirectCU II TOP 2GB | Windows 7 Ultimate x64

ASRock Z97 Anniversary | Intel Pentium G3258 @ 3.20GHz | Corsair Vengeancez 2x4GB DDR3 1600MHz | Evga GeForce GTX 750 2GB SC | W7 Ultimate x64
Find all posts by this user
Quote this message in a reply
05-05-2014, 05:17 PM
Post: #9
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
any newer drivers for ATI Radeon XPRESS 200M SERIES?
Find all posts by this user
Quote this message in a reply
05-05-2014, 07:54 PM (This post was last modified: 05-05-2014 08:11 PM by jkpwed.)
Post: #10
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
@godlesplay
Try Solarmystic link on step 2: auto detect and install, open up AMD Driver Autodetect.exe Big Grin

ASRock Fatal1ty Z97 Killer | Intel i5-4690k @ 3.50GHz | G.Skill Ripjaws X Series 2x4GB DDR3 1600MHz | ASUS Radeon R9 270X DirectCU II TOP 2GB | Windows 7 Ultimate x64

ASRock Z97 Anniversary | Intel Pentium G3258 @ 3.20GHz | Corsair Vengeancez 2x4GB DDR3 1600MHz | Evga GeForce GTX 750 2GB SC | W7 Ultimate x64
Find all posts by this user
Quote this message in a reply
06-07-2014, 11:30 AM (This post was last modified: 06-07-2014 01:22 PM by ChrisHateZ.)
Post: #11
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
I'm using ATI Radeon 2600 HD PRO and according to the AMD website the latest display driver that supports my card is 8.97.100.7

Now you guys said there's 11.11a and someone even said there's 13.9 for legacy cards. I googled a bit and I found a "AMD Catalyst Legacy Display Driver 13.1" for which the website hosting it says supports HD 2000 and other legacy series.

I'm not really sure what to think here. Why would AMD website say 8.9 is latest driver supporting legacy? Could it be that they just didn't care updating the information on their website?

Also how would I install this newer drivers that are supposed to support legacy cards? Once I download them from the website hosting them should I uninstall my current drivers before installing them, or should I just install the new ones over the old ones?

I'd appreciate answers as soon as possible.
Find all posts by this user
Quote this message in a reply
06-07-2014, 02:47 PM (This post was last modified: 06-07-2014 02:48 PM by solarmystic.)
Post: #12
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
@ChrisHatez

Simple answer, for your card, just grab the 11.11a drivers from the links in the first post.

Uninstall any current ATI graphics drivers before installing them.

That should do it.

Those Legacy drivers that ATI recommends for your card is not good for PPSSPP and may cause crashes and instabilities.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
07-19-2014, 07:40 AM
Post: #13
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
why i cant download the 11.11a?when i click download just back to fist page
Find all posts by this user
Quote this message in a reply
07-19-2014, 11:01 AM
Post: #14
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
(07-19-2014 07:40 AM)jakasasori Wrote:  why i cant download the 11.11a?when i click download just back to fist page

Works fine here. Try this link:-

http://download2us.softpedia.com/dl/7ff1...ista_7.exe

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
07-19-2014, 04:47 PM
Post: #15
RE: Help! Old ATI card isn't working properly after updating the emu to 0.9.8 or later!
how to install it sir? thank you anyway Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: