Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vsync in Windows 8.1
07-27-2014, 07:08 AM
Post: #1
Vsync in Windows 8.1
Hello everyone. First off I want to say I love this emulator. Plays every game I've thrown at it perfectly so far. The only problem is no matter how I change the settings, I get terrible screen tearing in fullscreen. I have the latest Nvidia drivers (337.88), and the latest version of PPSSPP. Forcing vsync in the Nvidia Control Panel doesn't work, and neither does the option in the emulator. Is there some sort of workaround?
Find all posts by this user
Quote this message in a reply
08-15-2014, 07:21 PM
Post: #2
RE: Vsync in Windows 8.1
I have the exact same problem, only in Windows 7 64-bit. The problem started in later development builds of version 0.9.8, and is still there in the official 0.9.9 release and the latest development builds. I've spent hours (over the course of months) trying to figure out a solution on my own
(even trying different Nvidia driver versions), but I'm at the end of my rope. The only solution I've found is to keep using version 0.9.8 of the emulator, but I'd really like to use 0.9.9 so that I can play Final Fantasy Type-0 and Star Ocean. That's only if I can do it in fullscreen mode without atrocious levels of tearing, though.

Any help would be appreciated, thanks!
Find all posts by this user
Quote this message in a reply
08-16-2014, 01:16 AM
Post: #3
Information RE: Vsync in Windows 8.1
(08-15-2014 07:21 PM)MyNinjaPenguin Wrote:  I have the exact same problem, only in Windows 7 64-bit. The problem started in later development builds of version 0.9.8, and is still there in the official 0.9.9 release and the latest development builds. I've spent hours (over the course of months) trying to figure out a solution on my own
(even trying different Nvidia driver versions), but I'm at the end of my rope. The only solution I've found is to keep using version 0.9.8 of the emulator, but I'd really like to use 0.9.9 so that I can play Final Fantasy Type-0 and Star Ocean. That's only if I can do it in fullscreen mode without atrocious levels of tearing, though.

Any help would be appreciated, thanks!
Hi there,

Did you know there are 2 types of Sync options, try enabling both.
The first one on the graphics tab, 'Vsync' & on the System tab, 'Force real clock sync' that should solve your problem. Cool
Find all posts by this user
Quote this message in a reply
08-16-2014, 10:44 AM (This post was last modified: 08-16-2014 11:04 AM by MyNinjaPenguin.)
Post: #4
RE: Vsync in Windows 8.1
Thanks for the reply! Sadly, when I tried it, there was no change. I suppose I could always play in windowed mode, where there's no tearing, but I don't like windowed mode and I don't like giving up. EDIT: I just discovered something interesting. I use a laptop that features two graphics processors, an Nvidia GeForce GTX660M and an Intel HD 4000. I've been using the Nvidia, but when I tried forcing PPSSPP to use the Intel integrated thing, there was no tearing. The games run like crud on the Intel obviously, so it's not really a solution, but it's interesting nonetheless.
Find all posts by this user
Quote this message in a reply
08-16-2014, 04:46 PM
Post: #5
Lightbulb RE: Vsync in Windows 8.1
(08-16-2014 10:44 AM)MyNinjaPenguin Wrote:  Thanks for the reply! Sadly, when I tried it, there was no change. I suppose I could always play in windowed mode, where there's no tearing, but I don't like windowed mode and I don't like giving up. EDIT: I just discovered something interesting. I use a laptop that features two graphics processors, an Nvidia GeForce GTX660M and an Intel HD 4000. I've been using the Nvidia, but when I tried forcing PPSSPP to use the Intel integrated thing, there was no tearing. The games run like crud on the Intel obviously, so it's not really a solution, but it's interesting nonetheless.
Yes that is interesting, very strange though Huh
I am wondering if since you have updated your Nvidia drivers, that its reset the Nvidia settings back to default on the dashboard?
Go to your Nvidia dashboard, it should be found on your control panel, un-sure of how to get to that on Windows 8.1, as I use Windows 7.
Click on the icon, look on the left hand side, and make sure its hightlighting the 'Adjust image settings with preview', you will see three options.
Make sure its on the option with the slider, and is set on performance far left, then click on apply.

Retest the emulator now, if still same problem - are you using a laptop by any chance, as most laptops are set to a balanced power plan particularly when its unplugged from the mains supply, so try and keep the laptop plugged in while playing emulators to keep it at its best performance.
To check what power setting it currently on, you will find that also on your control panel, click on Power options, make sure the radio dot is selecting High performance, then clicking on edit plan settings, change to Never on all settings, to stop it from shutting down, unless you want it to.

Hope that helps. Cool
Find all posts by this user
Quote this message in a reply
08-17-2014, 02:51 PM
Post: #6
RE: Vsync in Windows 8.1
*sigh* No good. I AM using a laptop, and it has a built-in gaming power setting, but I tried your suggestions and... no good. Very kind of you to help, though. Since the old version of the emulator still has Vsync working, I'll see if I can track down what build the problem started on (compiled sometime in May or June, I think). That way perhaps someone who knows the technical details can tell me what changed in that build, and what might therefore be the problem. I'll report back.
Find all posts by this user
Quote this message in a reply
08-17-2014, 06:54 PM
Post: #7
Sad RE: Vsync in Windows 8.1
(08-17-2014 02:51 PM)MyNinjaPenguin Wrote:  *sigh* No good. I AM using a laptop, and it has a built-in gaming power setting, but I tried your suggestions and... no good. Very kind of you to help, though. Since the old version of the emulator still has Vsync working, I'll see if I can track down what build the problem started on (compiled sometime in May or June, I think). That way perhaps someone who knows the technical details can tell me what changed in that build, and what might therefore be the problem. I'll report back.
Sorry I couldn't help!!! my knowledge is very limited on these matters, but I try to help. Sad

Good idea on tracking down the build responsible, I am sure that would be very useful to the developers, good luck in that. Cool
Find all posts by this user
Quote this message in a reply
08-18-2014, 07:21 PM (This post was last modified: 08-18-2014 07:22 PM by MyNinjaPenguin.)
Post: #8
RE: Vsync in Windows 8.1
AHA! Found it. It's earlier than I thought, back in March. Vsync works fine in build v0.9.8-128-g69d5c75, but is broken in v0.9.8-131-g98b6f0d and all later builds.

The changelog for v0.9.8-131-g98b6f0d says:
"Merge: 69d5c75 1ca3d39Merge pull request #5717 from thedax/win32NVidiaVSyncWin32/NVidia: go fullscreen later than previous builds, to avoid vsync being ignored"

It sounds like while trying to avoid vsync being ignored on Nvidia cards, they caused vsync to be ignored on (at least some) Nvidia cards. Ironic.
So, can this be fixed or at least worked around? That would be fantastic, thanks. Smile
Find all posts by this user
Quote this message in a reply
08-18-2014, 08:08 PM (This post was last modified: 08-18-2014 08:14 PM by TheDax.)
Post: #9
RE: Vsync in Windows 8.1
I can't reproduce it on my Nvidia card on Windows 7, so I'm not really sure what sort of fix to try. I guess I can try reverting it back to how it used to be, but then it'll break it for my card, and others that it was broken for before, I'm pretty sure. I'll check and see.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
08-18-2014, 08:13 PM (This post was last modified: 08-18-2014 08:13 PM by MyNinjaPenguin.)
Post: #10
RE: Vsync in Windows 8.1
(08-18-2014 08:08 PM)TheDax Wrote:  I can't reproduce it on my NVidia card, so I'm not really sure what sort of fix to try.

That's... a problem. Thank you for trying to help, though! I'm guessing it's only certain models of card. I'm using a GeForce GTX 660M ("M" being the laptop one of course), perhaps there are issues with that card in particular? Can anyone else confirm?

EDIT: Ah! Just saw your edit. Thanks again.
Find all posts by this user
Quote this message in a reply
08-18-2014, 08:17 PM (This post was last modified: 08-18-2014 08:28 PM by TheDax.)
Post: #11
RE: Vsync in Windows 8.1
Well, I looked at the newer code and we're showing the window completely differently compared to how we used to, so it's not a matter of simply moving some code around..sure would help if I could reproduce it somehow..

Out of curiosity, if you have Aero Glass turned on, does it help if you simply keep vsync off? IIRC, Aero is supposed to force vsync regardless of what the application wants.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
08-18-2014, 08:27 PM (This post was last modified: 08-18-2014 08:37 PM by MyNinjaPenguin.)
Post: #12
RE: Vsync in Windows 8.1
(08-18-2014 08:17 PM)TheDax Wrote:  Well, I looked at the newer code and we're showing the window completely differently compared to how we used to, so it's not a matter of simply moving some code around..sure would help if I could reproduce it somehow..

Dang dangitty dang. Yeah, I'm guessing you'd need a GeForce 660M to do so. People with this card have had odd problems with a number of different games and applications. NVidia seems to have messed up with this one. Perhaps RussTech, the guy who started this thread, could tell us if he has the same card? And does anybody out there with a 660M have vsync working properly?

(08-18-2014 08:17 PM)TheDax Wrote:  Out of curiosity, if you have Aero Glass turned on, does it help if you simply keep vsync off? IIRC, Aero is supposed to force vsync regardless of what the application wants.

Vsync off looks exactly the same. The problem is that Aero only forces vsync in windowed mode, it doesn't do anything for fullscreen applications. So yeah, I have no tearing in windowed mode. Perhaps there's a way to put PPSSPP in a "fake fullscreen" mode that some other emulators use by default?
Find all posts by this user
Quote this message in a reply
08-18-2014, 08:38 PM
Post: #13
RE: Vsync in Windows 8.1
That's what we do already. We remove the borders, menu bar, and title bar, then maximize the window, unless that's not the right way to do it.

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
08-18-2014, 08:44 PM
Post: #14
RE: Vsync in Windows 8.1
(08-18-2014 08:38 PM)TheDax Wrote:  That's what we do already. We remove the borders, menu bar, and title bar, then maximize the window, unless that's not the right way to do it.

Huh... odd. No, that SHOULD do it. That's not what it acts like it's doing, though. I have an application called "Game Companion" that basically does that for most games and works great, but when I try it on PPSSPP there's no tearing, but it doesn't remove the menu bar. Perhaps that's not such a big deal, but it bugs the heck out of me.
Find all posts by this user
Quote this message in a reply
08-18-2014, 09:35 PM
Post: #15
RE: Vsync in Windows 8.1
It's NVidia doing driver magic. I noticed that on specific NVidia driver versions it detected whether a window covered exactly 100% of the screen and then acted like it was real fullscreen.

Even positioning the window at [1,0][1921,1080] made this effect go away. I don't remember the driver version which I tested this with.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: