forums.PPSSPP.org
WipEout Pure - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: WipEout Pure (/showthread.php?tid=885)

Pages: 1 2 3 4 5 6 7 8 9 10 11


RE: WipEout Pure - applepiejr - 06-10-2016 07:40 PM

(02-06-2016 03:04 PM)Hot Violet Wrote:  Hi. I just registered so that I can let you know that the 30 fps during free play and time attack and the slow down and lag during weapons fire still persist. Both these issues occur regardless of whether I use OGL or Direct3D. I have tried all the suggestions in this thread (ie/ texture scaling off etc). Nothing affects these issues.

I'm using the latest nightly build (v1.1.1-888-g609c8eb).

I have Windows 7 Pro x64, i7 4770k @ 3.5 GHz, GTX 780 GPU and 8 gigs of RAM. All drivers are up to date. Smile

its 30 fps in time trial, free play, and zone because that was dictated by the original code. for some strange reason Studio Liverpool thought it was a good idea to limit those modes to 30 fps but leave single race and tournaments at 60 fps. Huh uh the easier modes to render get the lower fps cap?? HuhHuh

and the slowdown from weapons fire is actually from the PSP itself. remember this is a PSP emulator, so it emulates the slowdown that a real PSP would experience. this happens in Pure because when the PSP first launched, it was locked at 222 MHz, hence the slowdown with a lot of action. its a CPU bottleneck. if you go and play WipEout Pulse the frame rate is higher in those modes because every mode in Pulse is capped at 60 FPS which the developers allowed (though with 222 MHz mode it hovers around 40-50 FPS most of the time). testing on a real PSP with CFW at 333 MHz it seems to run at or very close to the full 60 FPS.

going back to Pure, strangely enough if i try to force 333 MHz in PPSSPP and then reboot Pure i still encounter the same slowdowns from weapons fire. its almost like forcing the higher clock speed won't work in Pure Huh

but if you use the fps cheat from here (huge thanks to Kabuto_Kun):

-- uh i'm not allowed to post a link to a different thread from this forum Confused
/showthread.php?tid=4799&pid=106046#pid106046

you will notice perfect 60 fps in all modes and no more slowdowns with weapon fire because the game is forced to run at 60 fps at all times, with the only limiting factor being the power of your PC (which even on my little potato i have no problems getting the full 60 fps).


RE: WipEout Pure - applepiejr - 06-12-2016 07:58 PM

there is a rendering bug I've picked up on in WipEout Pure. it is most noticeable on Ubermall but it also happens on other tracks (such as Sebenco Peak). these are DLC tracks.

Recording from a real PSP:
/watch?v=ZhdOUkv7keE

seriously, i'm not allowed to post a video showing the bug??? Dodgy (they are youtube links, you can add them to the standard url)

Part 1 recording from PPSSPP v1.2.2:
/watch?v=ForZYGNw_EE&feature=youtu.be

When I first played Ubermall on PPSSPP I was like wtf I don't remember the devs being such jerks! they totally blind you into that corner! then I realized oh yea that must be a rendering bug. and sure enough it was.

As you can see, the bloom and lens flare are rendering in areas that it shouldn't. and you will see in the next part its not very consistent. most of the time you are blinded but sometimes it won't appear or it will show up at the last second.

Part 2 recording from PPSSPP v1.2.2:
/watch?v=NC3jXhnIkgA&feature=youtu.be

Of course I tried messing with all of the settings but the bug still persists.

I have a theory as to why it happens. first of all bloom and lens flare are based on sun coordinates on the map. if you look at the sun, you get bloom and lens flare, but there are situations on some maps where this could straight up blind the player as they approach corners, so the developers probably added a condition to not render (or greatly reduce) the bloom and lens flare in these situations. the code that dictates this change is not being used (or its not used properly).

hopefully this bug will be fixed in a future update for PPSSPP.


RE: WipEout Pure - [Unknown] - 06-12-2016 10:07 PM

Hmm, I wonder if this is a stencil-to-alpha issue. Just to be sure, what device are you playing on? Specifically, does it support higher than OpenGL 3.3 (you can see under Tools -> System Information.) Note that some platforms / devices do not support this, and it makes it very hard to get the rendering correct.

Next off, and be warned it'll be a slideshow and you'll need to enable generous frameskip, but does this happen with the software renderer? If there's code that isn't running properly, then the software renderer will maybe/probably have the same issue. I should mention the software renderer isn't perfect yet. But, if it doesn't have the bug, it means we're probably doing something wrong in OpenGL land - and at least the game is telling us what to do, and we're just not doing it correctly.

-[Unknown]


RE: WipEout Pure - applepiejr - 06-13-2016 01:13 AM

i'm running PPSSPP on Windows 7 Ultimate SP1 64-bit using the Direct3D 9 renderer. i need to use DirectX in order to maintain 60 FPS (i get at least a 20% boost over OpenGL).

I have an AMD 6000 series GPU which means I support up to DirectX 11/OpenGL 4.4 and i have drivers from 2015 which is fairly recent.

i mean sure since i'm using Direct3D 9 (a subset of DirectX 9, most likely 9.0c) that should mean a feature set comparable to OpenGL 2.1

regardless the bug occurs in OpenGL as well. and i disabled alpha test as well as stencil test and it still occurs.

lastly, i set it to software renderer (through OpenGL since the option wasn't available for Direct3D 9) and yes it still occurs.

so does this mean its a problem with the emulation base?


RE: WipEout Pure - [Unknown] - 06-13-2016 01:35 AM

Well, that definitely rules out some things. If it's wrong in the software renderer the same way, it most likely isn't something we know about. It could still be something we have wrong in lighting calculation or something, or it could be a vfpu bug perhaps.

This game had major problems with brightness until we started to figure out the strange way alpha and stencil work on PSPs.

-[Unknown]


RE: WipEout Pure - applepiejr - 06-13-2016 02:21 AM

interesting. thanks for your responses.


WipEout Pure Goodies - applepiejr - 08-01-2016 06:08 PM

WipEout.Pure.USA.Gamma.Packs.7z

The best DLC for WipEout Pure, adds the following:
- 4 tracks with the visual style of the 8 main tracks
- 2 vehicles
- 2 tournaments "Gamma" and "Descension"

VIRUSTOTAL:
https://virustotal.com/en/file/052714ed785f2f1703f1c410ed51c752663247ed977967367c466c554b6292e6/analysis/

DOWNLOAD:
http://www.mediafire.com/download/zjxugnfcwq6g9ng/WipEout.Pure.USA.Gamma.Packs.7z

WipEout.Pure.USA.Phantom.Descension.Synopia.Unlocked.7z

A barebones save file that unlocks all of the major content in the game but still leaves plenty of golds to obtain, includes the following:
- 19 gold metals on record (no silver or bronze)
- final phantom tournament unlocked "Descension"
- final zone track unlocked "Synopia"

VIRUSTOTAL:
https://virustotal.com/en/file/8e6404b462f7aa0b3a4b4dd213b7a8d26f6b07fd6d7e594ef1d786ee709d5db5/analysis/

DOWNLOAD:
http://www.mediafire.com/download/pqvv7a9gbymhuz1/WipEout.Pure.USA.Phantom.Descension.Syncopia.Unlocked.7z

WipEout.Pure.USA.v2.60.FPS.Fix.7z

A cheat that allows the game to run at a perfect 60 FPS in every mode. Zone, Free Play, and Time Trial ran at 30 FPS originally but now you can run them at 60 FPS. This cheat also fixes frame rate drops that occur in Single Race and Tournament.

Special thanks to Kabuto_Kun for creating the cheat!

VIRUSTOTAL:
https://virustotal.com/en/file/db124650fd278ee3188cfe6187c85f520f56d8d46882c24d40b1262b5a232976/analysis/

DOWNLOAD:
http://www.mediafire.com/download/c95spjp35lpidee/WipEout.Pure.USA.v2.60.FPS.Fix.7z

And here is a video showcasing the game nicely in its current state using PPSSPP v1.2.2:





RE: WipEout Pure - Lycanphoenix - 10-12-2016 07:00 AM

I have to ask... do the PSP WipEout games run in 16-bit color, and if so then does anybody here know the cheats to make them 32-bit?


RE: WipEout Pure - Lycanphoenix - 11-07-2016 01:03 AM

I have uploaded some custom replacement files for WipEout Pure.
https://drive.google.com/open?id=0B1URcZnhifwbbVFjNEcwSWpQWDQ

For the USA Greatest Hits version, use either of these files to replace file000270.at3 in Data.wad AND file000005.at3 in FEData.wad. In the Japanese version, use file000240.at3 instead of file000270.at3. And as always, BACK UP THE ORIGINAL FIRST.

I hope you enjoy my selections. The available options are Starlight by Wolfgun, or Future Club by Perturbator.


RE: WipEout Pure - doodle - 10-22-2019 10:04 PM

On OpenGl, most of the videos on the TVs in-game don't render correctly, and in Vulcan, the TV videos in-game do render correctly, but the shadows of the vehicles will sometimes not render correctly. These are not big issues, but it would be appreciated if they got fixed. I am using a Xiaomi Mi Mix 2s and PPSSPP version 1.9.4.