forums.PPSSPP.org
Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: General Discussion and Announcements (/forumdisplay.php?fid=2)
+--- Thread: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 (/showthread.php?tid=8635)

Pages: 1 2


Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - sterodicsquirell - 01-16-2014 06:46 PM

Am I screwed, or is there something I can do to get open gl 2.0?

http://imgur.com/a/mlGOQ


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - GuilhermeGS2 - 01-16-2014 06:57 PM

Your GPU is same as mine. Use the DirectX version: http://forums.ppsspp.org/showthread.php?tid=2399&page=4


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - sterodicsquirell - 01-16-2014 07:49 PM

(01-16-2014 06:57 PM)GuilhermeGS2 Wrote:  Your GPU is same as mine. Use the DirectX version: http://forums.ppsspp.org/showthread.php?tid=2399&page=4

i read through that thread but still confused on where to start Sad


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - GuilhermeGS2 - 01-16-2014 07:54 PM

Quote:I tried to make a very hackish simple ANGLE port, try to take this *.exe and the 2 ANGLE *.dlls in this archive and place them into a PPSSPP installation directory and try it please (backup the original exe).

MEGA

Dropbox

Download the builds between v0.9.5-560 and 567 (any one) (here), download the file from MEGA and later extract within the ppsspp folder.


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - sterodicsquirell - 01-16-2014 08:32 PM

(01-16-2014 07:54 PM)GuilhermeGS2 Wrote:  
Quote:I tried to make a very hackish simple ANGLE port, try to take this *.exe and the 2 ANGLE *.dlls in this archive and place them into a PPSSPP installation directory and try it please (backup the original exe).

MEGA

Dropbox

Download the builds between v0.9.5-560 and 567 (any one) (here), download the file from MEGA and later extract within the ppsspp folder.

ok now i got that working is there any way to change the language on somethings to english


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - vsub_ - 01-16-2014 08:46 PM

I tried the DX version on two laptops but on both of them I got the same error

Code:
Failed initializing OpenGL,Try updating your graphic drivers

Error message:

Unable to initialize EGL

This is the first time I'm using this version...maybe there are some requirements I didn't know about

The laptop I'm trying it right now is
Win7 Starter with
Intel Atom 1,67 Ghz
Intel GMA 3150
1GB ram

The other laptop is
Pentium Dual T2310 1.46GHz
ATI Mobility Radeon x1350
1GB RAM
Windows XP

On it,the DX version gives me that error but the OGL version just shows a blue screen with no errors and any attempt to run a game,makes ppsspp to crash


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - Raimoo - 01-16-2014 09:34 PM

Use the link that Isley provide instead,

Isley Wrote:Try downloading the (https://github.com/Bigpet/ppsspp/archive/ANGLEbuild.zip) 12.5mb and copy this 3 folders (flash0,lang,assets) to were libEGL.dll, libGLESv2.dll and PPSSPPWindows.exe is located at

the log.bat is at (ppsspp-ANGLEbuild\Windows) copy it to were libEGL.dll is located at

that link in the quote is better than the link in MEGA or dropbox.


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - mr.chya - 01-16-2014 09:36 PM

(01-16-2014 08:46 PM)vsub_ Wrote:  I tried the DX version on two laptops but on both of them I got the same error

Code:
Failed initializing OpenGL,Try updating your graphic drivers

Error message:

Unable to initialize EGL

This is the first time I'm using this version...maybe there are some requirements I didn't know about

The laptop I'm trying it right now is
Win7 Starter with
Intel Atom 1,67 Ghz
Intel GMA 3150
1GB ram

The other laptop is
Pentium Dual T2310 1.46GHz
ATI Mobility Radeon x1350
1GB RAM
Windows XP

On it,the DX version gives me that error but the OGL version just shows a blue screen with no errors and any attempt to run a game,makes ppsspp to crash

Weird, I looked up the x1350 card on amd's official site here: http://www.amd.com/us/products/notebook/graphics/ati-mobility-hd-x1000/x1350/Pages/x1350-specs.aspx

and it looks like it should support openGL 2.0 unless I'm completely reading that wrong but Ibelieve that should be the same family my radeon x1250 is from and it supports OpenGL 2.0. That said if it does support openGL 2.0 I would ask soarmystic where to get the best drivers for it and try that and if it still won't work than it may be related to this issue here: https://github.com/hrydgard/ppsspp/issues/4956


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - GuilhermeGS2 - 01-16-2014 09:55 PM

(01-16-2014 08:32 PM)sterodicsquirell Wrote:  
(01-16-2014 07:54 PM)GuilhermeGS2 Wrote:  
Quote:I tried to make a very hackish simple ANGLE port, try to take this *.exe and the 2 ANGLE *.dlls in this archive and place them into a PPSSPP installation directory and try it please (backup the original exe).

MEGA

Dropbox

Download the builds between v0.9.5-560 and 567 (any one) (here), download the file from MEGA and later extract within the ppsspp folder.

ok now i got that working is there any way to change the language on somethings to english

You should have downloaded the wrong build. Download any build between v0.9.5-560 and 567, I use the 560.


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - vsub_ - 01-16-2014 10:04 PM

I guess I miss that one but I tried now 0.9.5-560 and I got the same error

BTW from my tests on MY pc,ppsspp can run games even if it's just the exe(you will have problems with the text but the games are working)so you don't really need certain rev to add the DX version to it to make it work


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - GuilhermeGS2 - 01-16-2014 10:10 PM

I've just formatted my PC and now I downloading the drivers. I'll test it soon, I need to download some programs before.

Try the build 567


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - sterodicsquirell - 01-16-2014 10:11 PM

i got monster hunter portable 3rd hd working but now i am getting blue screen crashes


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - GuilhermeGS2 - 01-16-2014 10:23 PM

The v0.9.5-560 is working well here.

(01-16-2014 09:34 PM)Raimoo Wrote:  Use the link that Isley provide instead,

Isley Wrote:Try downloading the (https://github.com/Bigpet/ppsspp/archive/ANGLEbuild.zip) 12.5mb and copy this 3 folders (flash0,lang,assets) to were libEGL.dll, libGLESv2.dll and PPSSPPWindows.exe is located at

the log.bat is at (ppsspp-ANGLEbuild\Windows) copy it to were libEGL.dll is located at

that link in the quote is better than the link in MEGA or dropbox.

I don't understand what I have to do. Please explain me better.


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - Raimoo - 01-16-2014 11:19 PM

(01-16-2014 10:23 PM)GuilhermeGS2 Wrote:  The v0.9.5-560 is working well here.

(01-16-2014 09:34 PM)Raimoo Wrote:  Use the link that Isley provide instead,

Isley Wrote:Try downloading the (https://github.com/Bigpet/ppsspp/archive/ANGLEbuild.zip) 12.5mb and copy this 3 folders (flash0,lang,assets) to were libEGL.dll, libGLESv2.dll and PPSSPPWindows.exe is located at

the log.bat is at (ppsspp-ANGLEbuild\Windows) copy it to were libEGL.dll is located at

that link in the quote is better than the link in MEGA or dropbox.

I don't understand what I have to do. Please explain me better.

You just copy and paste the files in the zip file onto the PPSSPP files.


RE: Here is my direct x info, I can't get ppsspp to work because my opengl is 1.4 - sterodicsquirell - 01-17-2014 02:14 AM

why am i getting Japanese symbols? http://i.imgur.com/0vt9EIJ.png