forums.PPSSPP.org
Guide: compiling ppsspp SDL and Qt version on fedora - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Builds, releases and ports (/forumdisplay.php?fid=4)
+--- Thread: Guide: compiling ppsspp SDL and Qt version on fedora (/showthread.php?tid=7438)



Guide: compiling ppsspp SDL and Qt version on fedora - fastrizwaan - 11-20-2013 11:00 PM

Hi,

Here's how we can build ppsspp latest from git in fedora:

Prerequisites: first build dependencies for PPSSPPSDL (SDL version)
Code:
sudo yum -y install gcc gcc-c++ SDL-devel cmake zlib-devel glibc-devel libICE-devel libX11-devel libXext-devel libSM-devel alsa-lib-devel mesa-libEGL-devel  mesa-libGL-devel mesa-libGLU-devel SDL zlib

Next get the latest git version (about 100mb)
Code:
git clone https://github.com/hrydgard/ppsspp.git ~/build/ppsspp
cd ~/build/ppsspp
git submodule update --init

Build:
Code:
./b.sh

Run:
Code:
~/build/ppsspp/build/PPSSPPSDL --fullscreen
[Image: Screenshot_from_2013_11_21_05_28_03.png]

Prerequisites: To build Qt version, we need qt-devel package, fedora 19 has qt4 and qt5. Qt 5 has better sound, qt4 has stuttering sound issue. So, let's build the Qt5 version.
Code:
sudo yum -y qt5-qtbase-x11 qt5-qttools-devel qt5-qtmultimedia-devel qt5-qtbase qt5-qtdeclarative-devel qt5-qtmultimedia qt5-qtjsbackend qt5-qttools qt5-qtbase-devel

Build: Use qmake-qt4 if you want the Qt4 version
Code:
cd ~/build/ppsspp/buildQt/
qmake-qt5 ../Qt/PPSSPPQt.pro && make

Run:
Code:
~/build/ppsspp/buildQt/PPSSPPQt
[Image: Screenshot_from_2013_11_21_05_27_48.png]
Thanks!


UPDATE: Updating to the latest git version

First time, do this:
Code:
git remote add upstream https://github.com/hrydgard/ppsspp.git

Code:
cd ~/build/ppsspp/
git pull --rebase upstream master
git submodule update --init

# SDL
./b.sh

# Qt
cd ~/build/ppsspp/buildQt
qmake-qt5 ../Qt/PPSSPPQt.pro && make

That's all folks!


RE: Guide: compiling ppsspp SDL and Qt version on fedora - slavezeo - 11-26-2013 03:50 AM

Thanks for the guild. It worked!


RE: Guide: compiling ppsspp SDL and Qt version on fedora - xsacha - 11-26-2013 05:02 AM

Updated the guide. There was a lot of redundancy there.


RE: Guide: compiling ppsspp SDL and Qt version on fedora - yymars - 12-25-2013 02:46 AM

Hi,

I compiling ppsspp SDL with the guide on Fedora 19. But when I play games, all the games don't boot, totally black screen.

Here is the error report


####################################
58:50:388 idle0 E[G3D]: /opt/ppsspp/GPU/GLES/ShaderManager.cpp:129 Could not link program:
error: all shaders must use same shading language version

58:50:388 idle0 E[G3D]: /opt/ppsspp/GPU/GLES/ShaderManager.cpp:130 VS:
#version 110
#define lowp
#define mediump
#define highp
attribute vec4 position;
attribute vec2 texcoord;
attribute lowp vec4 color0;
uniform mat4 u_proj_through;
varying lowp vec4 v_color0;
varying mediump vec2 v_texcoord;
void main() {
v_texcoord = texcoord;
v_color0 = color0;
gl_Position = u_proj_through * vec4(position.xyz, 1.0);
}

58:50:388 idle0 E[G3D]: /opt/ppsspp/GPU/GLES/ShaderManager.cpp:131 FS:
#version 130
#define lowp
#define mediump
#define highp
uniform sampler2D tex;
varying vec4 v_color0;
varying mediump vec2 v_texcoord;
out vec4 fragColor0;
void main() {
vec4 t = texture2D(tex, v_texcoord);
vec4 p = v_color0;
vec4 v = p * t;
fragColor0 = v;
}

58:50:433 idle0 E[SCEGE]: /opt/ppsspp/GPU/GLES/Framebuffer.cpp:1316 glReadPixels: GL_INVALID_OPERATION

##################################################



I didn't know why, can anybody help me to fix this problem?


Thanks.