forums.PPSSPP.org
Shin Megami Tensei: Persona - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Shin Megami Tensei: Persona (/showthread.php?tid=689)

Pages: 1 2 3 4 5 6


RE: Shin Megami Tensei: Persona - Nightquaker - 07-24-2014 06:34 AM

(07-23-2014 09:09 PM)solarmystic Wrote:  
(07-23-2014 12:22 PM)Nightquaker Wrote:  On version 0.9.9 there seems to be a huge slowdown compared to revision 1408 of 0.9.8 I played it on earlier.

Where does the slowdown occur? Does it still occur with "Disable slower effects" enabled and "Simulate Block Transfers" disabled?

I'm not seeing it on my end, the game pushes out over 413 VPS/60 FPS on my system when unthrottled in a classroom scene, the same as it always did.

Actually, chugging occurs only in 3D corridors, not in rooms themselves. There's alot of sound crackling too. Slowdown isn't consistent, I get 60fps all the time, but it just chugs quite often. It's really weird... I think it is related to the latest update. Doesn't seem to occur with slower effects disabled.
Though, there is a problem with slow transitions too that doesn't get solved by disabling slower effects. Sometimes transition before battle sounds fuzzy. But it's quite a common issue amongst different games, so it doesn't bother me as much.
After all, I could just play Persona 1 on older version for now.


RE: Shin Megami Tensei: Persona - solarmystic - 07-24-2014 09:34 AM

@Nightquaker

I tried going through the 3D corridors/hallways outside the classrooms, performance is pretty solid there too. No sound crackling either.

It'd really help if you can share a save state/save file when the issue occurs, I'd really like to get to the bottom of the issue, but I can't reproduce it myself with the savedata I have.

There's one oddity though, in the 3D hallways/corridors, the framerate is 40/40 instead of the usual 60/60 in the classrooms. Still 100%, but I don't think the internal FPS is supposed to be 40 in the 3D areas.

It's been that way for several official releases though.


RE: Shin Megami Tensei: Persona - adamLiddle - 08-04-2014 10:05 AM

Hello, I need help with save data. I recently bought the game on PSN and then transferred my data from PSVITA over to PC.

So when I load it up another message pops up saying " CANCEL LOAD "

So to save our time, I went to another site to grab another save file and the Cancel Upload message still pops up. Can anybody help ?

Thanks.

EDIT : Ok I started the game all over again and it turns out I can save and load that file...But I don't want to start over -_- lol


RE: Shin Megami Tensei: Persona - lifeseeker128 - 09-07-2014 11:47 PM

I've been trying to advance through this game using PPSSPP, but I'm currently within the SEBEC building and trying to capture demon cards when suddenly the emulator freezes/stops working and has to shut down. I save state just before selecting a method of negotiation with a demon I select and once I select a method (dance/invite whatever) the emulator (I wanna say "crashes" but it's less sudden than that) stops working after my character makes the remark and at the time the demon would make theirs. I'm using version 0.9.9.1 of the emulator on Windows 7 with default graphics and system settings except for auto-load latest save state. I've not had issues with negotiating with demons inside or outside the SEBEC building before this issue. I could simply move on, but... I want to be OP and need the cards to do that.

Would someone be willing to help me troubleshoot this issue?

PS: Never mind, I was just able to load into a session of the game without a save state and successfully negotiate with a demon; no freezing. I guess this was just a case of save states getting corrupted or something similar.


RE: Shin Megami Tensei: Persona - snoopdogg5 - 12-12-2014 01:44 AM

(07-24-2014 06:34 AM)Nightquaker Wrote:  
(07-23-2014 09:09 PM)solarmystic Wrote:  
(07-23-2014 12:22 PM)Nightquaker Wrote:  On version 0.9.9 there seems to be a huge slowdown compared to revision 1408 of 0.9.8 I played it on earlier.

Where does the slowdown occur? Does it still occur with "Disable slower effects" enabled and "Simulate Block Transfers" disabled?

I'm not seeing it on my end, the game pushes out over 413 VPS/60 FPS on my system when unthrottled in a classroom scene, the same as it always did.

Actually, chugging occurs only in 3D corridors, not in rooms themselves. There's alot of sound crackling too. Slowdown isn't consistent, I get 60fps all the time, but it just chugs quite often. It's really weird... I think it is related to the latest update. Doesn't seem to occur with slower effects disabled.
Though, there is a problem with slow transitions too that doesn't get solved by disabling slower effects. Sometimes transition before battle sounds fuzzy. But it's quite a common issue amongst different games, so it doesn't bother me as much.
After all, I could just play Persona 1 on older version for now.

I get the same 40 fps with choppy audio in 3d corridors, even with hacks, 1x rendering, 1x window, and frameskipping all alternating between on an off. Disable Slower Effects and Simulate Block Transfers didnt affect the fps at all either. I tried on the most current rev at this time, 9.9.1 1150, stable 9.9.1, and 9.8 1572 and no changes.
Sadly I think rev 1408 has a save issue with Persona since I couldnt load my save in that rev!
I also tried changing the audio latency but it didnt help with the crackling and stopping audio with the lag.
It definitely doesn't break the game but it is annoying.


RE: Shin Megami Tensei: Persona - Vicyouz - 01-14-2015 09:47 PM

Does anybody have good settings for Android? I messed arround a little with them but i get a little laggy in school's hallway and get really slow no sebec.


RE: Shin Megami Tensei: Persona - Achelexus - 02-22-2015 06:21 AM

When I get to the corridors, the first person mode, that is, the screen starts flashing black really fast, what can I do to fix this?

edit: nvm it was easy, I just set it to render with a buffer


RE: Shin Megami Tensei: Persona - thadeu.menezes - 04-09-2015 01:13 PM

(02-22-2015 06:21 AM)Achelexus Wrote:  When I get to the corridors, the first person mode, that is, the screen starts flashing black really fast, what can I do to fix this?

edit: nvm it was easy, I just set it to render with a buffer

I have the same problem as you, my friend, how did you fix it? I can't fix it even if I set it to render with a buffer. Thanks in advance!


Shin-Megami-Tensei; Persona - FlamingChicken - 06-25-2015 09:00 PM

Hello!
I would like to bring to your attention that unfortunately resulting of my testing persona 1 for the psp does not work well kind of. After doing it on ios, android and pc, i have found the same problems. The audio is really glitchy and the screen will start having a seizure when you enter first persona (see what i did there) mode. After you get out of the hospital room and go into first person the game no longer works. I will try a different rom/umd and see if that works but it seems the us version is not working at the moment.


RE: Shin Megami Tensei: Persona - vnctdj - 06-26-2015 01:23 PM

Merged.


RE: Shin Megami Tensei: Persona - Hilaron - 08-07-2015 12:17 PM

Hello all. I'm using the latest version of the PPSSPP Emulator. The game works perfectly... until the Lost Forest section. The problem is that whenever I open any door to go to a room in the forest, the game crashes. I can't progress nor can I exit. Does someone know how to fix this?


RE: Shin Megami Tensei: Persona - Hilaron - 08-08-2015 04:49 AM

Well, never mind. I found out that... disabling cheats and reloading from a save point fixed the problem. (Don't judge me!) Loading a save state does not fix it. Oh well...


RE: Shin Megami Tensei: Persona - unijeje - 10-06-2015 04:47 PM

Hello. I'm getting an error after exiting the first room where you can get control of your character on Android 5, the app just crashes, it works fine on PC with the same iso. I'm using default settings. Anybody has any idea what to test?


RE: Shin Megami Tensei: Persona - shadowmoon522 - 11-05-2016 04:47 PM

having a bit of a sound issue on my droid, as the sound is all choppy/laggy.
i'm using a ppsspp on a LG-L38C, the iso works fine on my pc just a\not on the droid.


RE: Shin Megami Tensei: Persona - TkSilver - 11-11-2016 03:27 PM

Shadowmoon I am slightly more amazed that you got the game to work on the LG optimus dynamic at all. That being said choppy and laggy audio can usually be a sign of the emulator not being able to keep up with the game at full apeed. You could try to increase the frameskip or lower the resolution, but a 800MHz processor can rally only be expected to do so much and there will always be compromises on lower powered devices.