forums.PPSSPP.org
Shin Megami Tensei: Persona - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Shin Megami Tensei: Persona (/showthread.php?tid=689)

Pages: 1 2 3 4 5 6


Shin Megami Tensei: Persona - hyakki - 01-16-2013 07:29 AM

DiscID: ULUS10432
ImageID: 1925
Version: v0.5-328-ge23365d (64-bit, 1/16/13)
OS: Windows 7 (64-bit)
Notes: shows a few screens.

Code:
24:19:116 HLE\sceMpeg.cpp:848 E[HLE]: UNIMPL sceMpegAvcDecodeYCbCr(08cbe68c, 08cbe6a8, 08cbe5ec, 09fff3a0)
24:25:548 HLE\__sceAudio.cpp:184 E[HLE]: channel 2 buffer underrun at 16 of 60



RE: [v0.5] Shin Megami Tensei: Persona - flaim2 - 02-04-2013 02:45 AM

Now it work (v.0.6) on Android with very good speed, but cut-scene is not working (black screen instead of video)


RE: [v0.5] Shin Megami Tensei: Persona - ssshadow - 02-04-2013 08:27 PM

(02-04-2013 02:45 AM)flaim2 Wrote:  Now it work (v.0.6) on Android with very good speed, but cut-scene is not working (black screen instead of video)

I actually find the speed to be pretty bad in the 3D first person dungeons, at least on a Neuxus 7 which is still fairly fast.

Other issues is no sound at all, no transparency on 2D sprites, and a crash when loading/saving. Screenshot below show the game running, with a sprite issue in the upper left.

[Image: J0a1bWh.png]


RE: Shin Megami Tensei: Persona - b.sykes - 04-25-2013 03:44 PM

Full Playable in 0.7.6!
I'm using the version with sound and video and it's running very well!


RE: Shin Megami Tensei: Persona - sfageas - 04-25-2013 07:12 PM

Moved


RE: Shin Megami Tensei: Persona - Dr. Woodenstein - 04-26-2013 12:04 AM

Alright! Glad I'll get to play this one now. I've always wanted to get into this series. Big Grin

Except it's not working for me... It locks up right as the little girl comes out of the doorway. What settings are being used to play this game?


RE: Shin Megami Tensei: Persona - ssshadow - 04-26-2013 10:26 AM

(04-26-2013 12:04 AM)Dr. Woodenstein Wrote:  Alright! Glad I'll get to play this one now. I've always wanted to get into this series. Big Grin

Except it's not working for me... It locks up right as the little girl comes out of the doorway. What settings are being used to play this game?

If you want to get into the series just play Persona 3 or 4, the first one is considered by many to be pretty bad. The games are unrelated story wise, so you can start by playing 4 and not miss anything. In fact, Persona 1 (and 2) have almost nothing in common to 3 and 4, might as well be a different series altogether.

In any case, disable buffered rendering and hardware transform. Should work.


RE: Shin Megami Tensei: Persona - Dr. Woodenstein - 04-26-2013 12:58 PM

Strange changing those two settings still doesn't allow me to play...


RE: Shin Megami Tensei: Persona - Dr. Woodenstein - 04-27-2013 04:26 AM

Ok I have figured it out. All I had to do was disable media engine.


RE: Shin Megami Tensei: Persona - GabrieliosP - 04-30-2013 07:49 PM

(04-25-2013 03:44 PM)b.sykes Wrote:  Full Playable in 0.7.6!
I'm using the version with sound and video and it's running very well!

"With sound and video"? Which settings are you using?

I'm having the following problems:

- 2D sprites with no transparency (Agastya tree, Persona sprites and attack effects)
- No BGM. Voice files and sound effects still play
- Video cutscenes do not play. Instead I get a black screen (though the cutscenes still tecnically are playing. If you wait enough, the game will resume from the point after the cutscene)


RE: Shin Megami Tensei: Persona - luginub - 05-15-2013 01:16 AM

Is there a fix to the above problems yet?


RE: Shin Megami Tensei: Persona - Lukefonfabre - 05-16-2013 04:36 PM

isnt this game should change to "playable" now instead of "intro/menu" in compatibilty list?
cause i think its playable now..


RE: Shin Megami Tensei: Persona - Lukefonfabre - 05-17-2013 04:11 AM

I got flickering screen when in world map,anyone has this issue?


RE: Shin Megami Tensei: Persona - crystalbabeexox - 05-23-2013 04:17 PM

[Image: SWLQzGm.jpg]

Anybody know how to fix the sprites?


RE: Shin Megami Tensei: Persona - [Unknown] - 05-24-2013 12:12 AM

There's an open bug for this issue:

https://github.com/hrydgard/ppsspp/issues/1793

-[Unknown]