forums.PPSSPP.org
Emu crash when i use Buffered rendering - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: General Discussion and Announcements (/forumdisplay.php?fid=2)
+--- Thread: Emu crash when i use Buffered rendering (/showthread.php?tid=648)



Emu crash when i use Buffered rendering - Ren Kudou - 01-14-2013 01:02 AM

Hi. I tried to run Project Diva 2 Extend using latest version of ppsspp emulator (v0.5) and i make it run but i got black screen, however i could hear any sound from it. I think it's because i didn't use buffered rendering. When i try to use buffered rendering, and run the game, emu crashes with has stopped working error. Is it possible to make emu not crash when use buffered rendering, or it's still not working on emu?

so why every times i tried to play any games it shows only black screen? Tnx in advance.


sorry for bad English because my native language isn't English. Please be kind. Smile


RE: Emu crash when i use Buffered rendering - cloud1250000 - 01-14-2013 03:24 AM

lol this is happening only to you Wink

so please can you say as much about your computer and provide log?

information like, gpu, cpu, ram, how much ram was available, os and such thing. the much the better Wink


RE: Emu crash when i use Buffered rendering - Ren Kudou - 01-16-2013 02:29 AM

(01-14-2013 03:24 AM)cloud1250000 Wrote:  lol this is happening only to you Wink

so please can you say as much about your computer and provide log?

information like, gpu, cpu, ram, how much ram was available, os and such thing. the much the better Wink


yeah this is happening only to my laptop , but not for today.
now i don't have any black screen issue but still the emu is crashing when i use buffered rendering. I think it's because my laptop is quite old. Big Grin

here it is
Genuine Intel® CPU U4100 @ 1.30GHz 1.30GHz
3GB RAM
Mobile Intel® 4 Series Express Chipset Family
128VRAM
Windows 8 Enterprise


RE: Emu crash when i use Buffered rendering - Henrik - 01-16-2013 08:00 AM

128MB should be enough, I think the problem is just that your Intel GPU has terrible OpenGL drivers that don't support FBOs.

First, try to find the latest drivers for it. If that doesn't help, there isn't anything I can do. Possibly someone will write a Direct3D backend one day that might work better on your card.


RE: Emu crash when i use Buffered rendering - Ren Kudou - 01-16-2013 01:19 PM

(01-16-2013 08:00 AM)Henrik Wrote:  128MB should be enough, I think the problem is just that your Intel GPU has terrible OpenGL drivers that don't support FBOs.

First, try to find the latest drivers for it. If that doesn't help, there isn't anything I can do. Possibly someone will write a Direct3D backend one day that might work better on your card.



Yeah i guess you're right. My laptop is quite old so something like this might happen.
There isn't any update anymore for it. Sad
I hope so. Big Grin
Hmmm ... I just want to say, Thanks to you for making a great emu. Smile
I wish I can play a lot of PSP games on my android phone with a great speed and performance someday.
Because now, when i use JIT(dynarec) and load iso game, it crashes.

Xperia Mini Pro SK17i
1GHz Scorpion Processor
Qualcomm Snapdragon Adreno 205
512 RAM

Sorry for bad English Big Grin


RE: Emu crash when i use Buffered rendering - Vincentmrl - 01-18-2013 03:19 PM

Intel GPU drivers suck, but there are modded drivers that enable all the functions the graphics card can do, default ones make you use 1% of the graphics card, making you think the graphics card sucks, but it's not like this.
You can find the drivers with a quick google of your graphics card name + custom driver


RE: Emu crash when i use Buffered rendering - Stevec - 03-12-2014 08:55 PM

Hi Guys,
Just needing a little advice - i have been using so up to 9.7.2.239 and find that the emu crashes nearly everytime after about 5 -10 mins with previous builds aswell on buffererd rendering (cpu & gpu read buffers aswell) with a few games such as wipeout pulse,gran turismo ,hot wheels etc,ive got the lastest drivers installed which go up to 307.83 from nvidia - i also don't use post processing shader option but it doesnt seem to happen on non buffererd rendering is there a bug in the emulator or is it my graphics card been too old and may not support fbo's or is it my settings ? (help would be greatly appreciated)


RE: Emu crash when i use Buffered rendering - The Phoenix - 03-15-2014 02:50 AM

First off, i can't see why your getting crashes, as you don't have hardly any settings switched on that would cause crashing, IE Fast Memory ETC ETC.
Does this still happen using Software Rendering only or switching off the Dynarec (Jit) setting, found under SYSTEM / DEVELOPER TOOLS?
Is it because there is a memory leak in the emulator somewhere, which is using all your system ram (2 Gig), I have 3 Gig on my Windows 7 (x86) machine, maybe thats the reason its happening to you, but not me............ Somethings to think about, could be any of them reasons.......create a Info Log and upload it on here, then the developers will be able to compare the logs with there machines Logs.

The one thing that makes me think that its a old driver problem, is the fact you said its always done this, even though you had your graphics card tested & found no problems with it.
Problem is I reckon is that your drivers can't be updated any further, due to Nvidia not bothering to upgrade yours, due to the card being an older version, as do most companies, particularly Microsoft with there Windows operating systems, by releasing new versions, the older ones lose there support, as in XP is soon to lose support online for any updates.

So I am afraid that there is not a lot you can do, unless you purchase a better graphics card, if you use a desktop that is.

Or you never know the PPSSPP developers maybe able to find whats causing these crashes on your system, they may even find a bug fix for something else that may cure this problem as well, 2 birds with 1 stone, so to speak. Blush

Edit: I just remembered I used to have crashing issues with my setup, ended up being my Anti-Malware or Anti-Virus program, messing about with files in the assets folder, I told both programs to ignore the whole folder with the emulator in, after that, no more crashes............


RE: Emu crash when i use Buffered rendering - The Phoenix - 03-15-2014 08:43 AM

(03-15-2014 08:07 AM)Stevec Wrote:  Thx for looking at it for me phoenix ,it definately helps with a few things i can also try - it's been a bit tricky to work out - whether it's xp/hardware or drivers/emulator/or settings (just seems to be more frequent now which i don't think happened back in 9.6 or 9.1 builds) - i'm going back to previous versions to check if it's emulator related and test them with different settings ,all i know for sure with buffered rendering off all works well (no crashes) - i haven't had any luck with getting a log file as it freezes the whole computer which requires power off restart .
Really its that bad is it, the crashes on your computer.........Have you tried pressing the Windows Key in between the Ctrl & Alt keys, sometimes works, or pressing Ctrl, Alt & Delete at same time, I think brings up dialog box, I forget now, what happens on XP. Tongue - Start Task Manager, close it down manually. One way or another.
As for the Log, instead of running emulator by way of the standard way, double click on InfoLog.bat, that will create a log from the word go, called ppsspplog.txt.

Hope that helps Cool


RE: Emu crash when i use Buffered rendering - Stevec - 03-17-2014 09:18 AM

Hey Phoenix - I think i found the bufferd rendering crash out - i thought i'd post this so if someone else is having similar problems it might help - i had the rendering resolution set to auto (1:1) - found if i set it to 2xPSP instead it would'nt crash - so it might have been lack of memory or the grafix card not able to handle the higher resolution - i can now also use post processing shaders - fxaa which work without problems aswell. i found these settings work well.


RE: Emu crash when i use Buffered rendering - The Phoenix - 03-17-2014 11:11 AM

(03-17-2014 09:18 AM)Stevec Wrote:  Hey Phoenix - I think i found the bufferd rendering crash out - i thought i'd post this so if someone else is having similar problems it might help - i had the rendering resolution set to auto (1:1) - found if i set it to 2xPSP instead it would'nt crash - so it might have been lack of memory or the grafix card not able to handle the higher resolution - i can now also use post processing shaders - fxaa which work without problems aswell. i found these settings work well.
Now that is weird, are you sure you have that around the right way, you set to 2 X PSP is going to make rendering twice as hard, so put more strain on the graphics card, and so crash more I would of thought, not less.

What about 1 x PSP instead, does that result in same problem as before, crashes!!!! Huh


RE: Emu crash when i use Buffered rendering - Stevec - 03-17-2014 07:25 PM

I started setting to 1xPSP was fine - just looked blocky and dark - no crash, then went 2xPSP - looked better no crash - then went 3xPSP - f1 gp worked ok - but on same settings hot wheels would crash - so not sure why but the auto setting (1:1) was too much for my system. (I played for over half an hour on a couple of games no crashes - rechecked games that were crashing even with fxaa on the whole time and all running at 60fps 100% - changed back to auto 1:1 crash within 10mins or sooner -very weird!) Games look really smooth now! with fxaa on