The 3rd Birthday - Printable Version

+- (
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: The 3rd Birthday (/showthread.php?tid=613)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28

RE: The 3rd Birthday - FrozenDevilz - 09-30-2014 08:32 PM

(09-29-2014 09:24 AM)Harutora Wrote:  Hello everyone, does anyone knows how to set The 3rd Birthday in full HD using PPSSPP version for windows?

Set the Rendering Resolution in Setting's Performance section to more than 1x PSP

RE: The 3rd Birthday - Harutora - 10-01-2014 09:11 AM

(09-29-2014 09:24 AM)Harutora Wrote:  Hello everyone, does anyone knows how to set The 3rd Birthday in full HD using PPSSPP version for windows?

Nevermind, i know already.

RE: The 3rd Birthday - Eliass141 - 12-08-2014 01:31 AM

Hi, I'm having a problem in chapter 2 where there's a red orb teleporting reaper. Whenever it teleports, the emulator crashes - the picture freezes but the audio continues to play, but very slowly. I waited for a while cause I thought it was just lag, but I have to ctr+alt+del to get out, because I can't even pause the game from that point. I have a fairly good laptop with 1366x768 resolution and an amd a4-4300m apu. Has anyone else gotten that freeze? Any ways how I could fix it?

Region: USA
Format: ISO
PPSSPP version: v.
OS: Windows 8

I tried fiddling around with the settings, so here they are in case I have something to change:

RE: The 3rd Birthday - IOS - Zaknafein777 - 12-09-2014 08:07 PM

Hey Guys,

I'm having issues with a crash after the first video once you start a new game on my iPhone 6 plus. The game starts fine, the intro videos play great. I can select between new game and load game. Once new game is selected the video seems to play fine and the moment it seems to switch to actual game play it closes PPSSPP. Right now I have it in default settings but I have tried it using a myriad of different settings with the same result. Is anyone able to get this working on an IOS device? I will say I am using the Dev-Latest version as it seems to work best with my 6 plus.

I have been able to get both the god of wars running with decent FPS with buffered rendering so I think the device should be able to handle it from a hardware perspective. If anyone has an easy win on this I am all ears.
Well I had almost given up on getting 3rd Birthday working on IOS. I tried just about every possible combination of options but ppsspp would just crash every time it tried to switch to actual gameplay. I was finally able to get past the first main movie into gameplay by disabling JIT in the developer menu. While the intro movies ran fine, I did notice a longer load time with JIT disabled. But, the main result was I finally got into the game. I expected the gameplay to be much slower with JIT disabled but it actually seem to run fairly decent. I am testing this out more as we speak.

One thing I noticed was that once I was in the game I was able to reenable JIT from the developer tools (next idea is to create a save to see if I can load a game with JIT enabled). Not sure if this actually reenables it, or if its just set to run with JIT on the next load. Anyone have any input on the ramifications of disabling JIT and whether this work around might actually reenable JIT for better performance?

RE: The 3rd Birthday - Zaknafein777 - 12-12-2014 11:29 PM

So after much more testing on my iPhone 6 plus, I have found that once in the game you are able to reenable JIT for a considerable performance increase. The only issue is that seemingly randomly PPSSPP just dies. Its doesn't hang or lag. It just completely dies and closes itself. I'm going to mess around a little bit with the debug log to see if it tells me whats happening with JIT enabled. Any advice would be greatly appreciated.

RE: The 3rd Birthday - [Unknown] - 12-13-2014 06:49 PM

Do you have Xcode? If you could find out where it's crashing and what the disassembly nearby looks like, it could help a lot.

It might be another problem like the armv7s one. Try toggling fast memory.


RE: The 3rd Birthday - reguume - 12-13-2014 07:28 PM

help NOKIA x7-00 users!!

RE: The 3rd Birthday - Zaknafein777 - 12-14-2014 03:37 AM

(12-13-2014 06:49 PM)[Unknown] Wrote:  Do you have Xcode? If you could find out where it's crashing and what the disassembly nearby looks like, it could help a lot.

It might be another problem like the armv7s one. Try toggling fast memory.


Thanks for the reply. I am currently downloading it and will post it as soon as i do. I've opened up a couple topics in the IOS section because the same exact issue happens with another squenix game FF type 0. You can still do the same work around but it completely crashes at first instance of real game play with JIT enabled. But after it loads you can tick JIT back on.

RE: The 3rd Birthday - [Unknown] - 12-14-2014 04:47 AM

Well, if you can look at the disassembly near the crash and post a screenshot, that would help a lot. But sometimes you won't get a great trace. It still might give good info.

Otherwise, there are code changes you can make to test it. In Core/MIPS/ARM/ there are the following files:


Near the top of each of these files is two lines that look like this:

//#define CONDITIONAL_DISABLE { Comp_Generic(op); return; }

If you switch them (delete the // from the first one, and put a // before the second one), it will disable that section of the jit. You'll need to compile it after doing so, you can find instructions here:

You may need an iOS dev membership or an open source toolchain or something. I don't know much about that side of things, but I think it says what's needed on that wiki page at the top.

Anyway, if you switch the CONDITIONAL_DISABLEs in each file, you'll end up with something that is *basically* like jit disabled, but faster. It will probably not crash. If it doesn't, we know that the cause of the crash is in one of these sections of the jit.

If it still crashes, it means we've excluded the sections of the jit, which means it's the "base" of the jit, the mechanics. It might be another issue like the one we had on iOS with R9.

Hopefully, it won't be mechanics, and the change I described above will make it not crash (but slow.) In this case, there's more we can do. But, I'll explain that if you're up for it and after looking to see if maybe we can solve it just from the disassembly.


RE: The 3rd Birthday - brujo55 - 12-14-2014 02:57 PM

strange but all issues related here, i fixed for dissabling fastmem and multithread in my ip5S

RE: The 3rd Birthday - Zaknafein777 - 12-24-2014 06:01 AM

Hey Unknown,

The Holiday season has really taken all my free time and I haven't had a whole lot of time to mess with PPSSPP. I did see the IOS update to dev-latest today. After the update basically every game I was having an issue with is now playable without toggling JIT. It does seem to stutter a little bit on the initial load but it does not crash. Seem to be pegging 30 frames with no frame skip. The games I came across that crashed at actual first gameplay that now work include: 3rd Birthday, FF type zero, and God Eater Burst.

RE: The 3rd Birthday - [Unknown] - 12-24-2014 08:00 AM

Awesome. Yeah, I pushed two armjit fixes recently that should've been affecting Android just as much as iOS. Possibly it was those, but there have also been some other good updates recently that could've been related as well.

It's nice when things get accidentally fixed, saves the trouble of going and trying all those compiles.


RE: The 3rd Birthday - Adisparda - 01-05-2015 06:44 AM

(07-20-2013 05:03 PM)solarmystic Wrote:  
(07-20-2013 04:17 PM)tsuyanz21 Wrote:  1. PC Specs on my sig.
2. im using the 8.1 which i downloaded on the ppsspp site.
3. after my pc hangs, i waited but nothing happens and when i try to close the program it says
wait for emuthread timed out! Sad
please alert the developer to possible deadlock or infinite loop in emuthread!
4. i cant attach the savefile zip or even rar. it says
"The type of file that you attached is not allowed. Please remove the attachment or choose a different type."

Thanks for the response.

1. Try using the latest dev builds here and try again, to see whether it hangs your PC:-

2. You can use to upload your savefile for testing and share the link here.

3. Also use the same method to attach the log file please. We really need this as it should tell us when exactly it hung.

Procedure to generate a logfile for diagnostic purposes:-

1. Double click on the Log.bat file in the ppsspp folder.

2. PPSSPP will launch automatically

3. Load the game and savefile

4. Play until your PC hangs

5. Close the program

6. Head to your ppsspp folder (where you keep the emulator) and head to the User\Logs subfolder to find the ppsspp.log file.

7. Upload the file to a filehoster like, and share the link in your next post. Zip it up if it's too big into a rar/zip file.


i follow your instruction, because i cant play god eater 2 Sad, when the gameplay begin it always said wait for emuthread time out
and this is my ppsspplog, please...

RE: The 3rd Birthday - TheMechXYZ - 02-07-2015 10:26 PM

I played and beat The 3rd Birthday on Normal Mode. it used to have crashes earlier, but disabling multithread stopped all of that. Now i recently decided to play the game again on hard mode. Episode 00, which is the tutorial, plays fine with no problem i believe, but Episode 1, where you fight the big monster in the concert, it crashes immediately. As soon as i lock on it crashes the emulator. Happened on PPsspp 0.99, and still occurs in 1.0. Only happens in Hard mode so far for me. I played and beat normal with no problem, aside from some graphical errors which i could get past.

RE: The 3rd Birthday - [Unknown] - 02-08-2015 01:23 AM

Try resetting your settings to defaults. Make sure you're not using "read framebuffers to memory" as your rendering mode.