forums.PPSSPP.org
The 3rd Birthday - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: The 3rd Birthday (/showthread.php?tid=613)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28


RE: The 3rd Birthday - solarmystic - 07-15-2013 07:38 AM

(07-14-2013 09:56 PM)chukkyjr Wrote:  hmm in the CTI HQ the white lines are fixed, but in missions it appears again, i used these settings :

am i doing something wrong here? any advice?

That build (0.8.1) is old and does not support recently added functionality used to fix the issue in the 3rd Birthday.

Download the latest build here:-

http://buildbot.orphis.net/ppsspp/

Then, launch and close the emulator once to generate a ppsspp.ini file.

Open it, then change the following lines:-

FramebufferstoMem = True
FramebuffersCPUConvert = True

Save the changes you've made,

Play the game, those white lines should be gone everywhere now.


RE: The 3rd Birthday - chukkyjr - 07-15-2013 08:09 AM

ah yes i see, the white lines are fixed now, well the bug which makes the UI occasionally disappears still exist making sniping is kinda hard, but this works better than nothing


RE: The 3rd Birthday - Devina - 07-15-2013 01:06 PM

It's 7/15, and the build that broke the game with the graphic overlay glitches was the 4/28 build (when it was working perfectly and we didn't have all these overlay issues), as discussed in pages 8 and 9 of this thread. Like others pointed out, I believe it's related to these:

https://github.com/hrydgard/ppsspp/commit/v0.7.6-203-gfc69f38
https://github.com/oioitff/ppsspp/commit/a056e270f71fe43d6620f8807dfa25d0bf0ac85f

The entire reason for that workaround was for a God of War fix, right? It's been a while, so has God of War been fixed yet? I think it's definitely possible.


RE: The 3rd Birthday - RyviusRan - 07-16-2013 02:51 AM

(07-11-2013 11:09 AM)solarmystic Wrote:  If you want to claim that my advice made things worse for you, please provide some pictorial evidence before badmouthing the poster who was just trying to help others with a solution that he discovered.

Thank you.

It won't show in an image as it requires motion to show the problem.
Doing what you says does remove the overlay issue but it causes the screen to flash frequently and also causes the subtitles to flash and disappear right after it first appears on screen.

(07-15-2013 01:06 PM)Devina Wrote:  It's 7/15, and the build that broke the game with the graphic overlay glitches was the 4/28 build (when it was working perfectly and we didn't have all these overlay issues), as discussed in pages 8 and 9 of this thread. Like others pointed out, I believe it's related to these:

https://github.com/hrydgard/ppsspp/commit/v0.7.6-203-gfc69f38
https://github.com/oioitff/ppsspp/commit/a056e270f71fe43d6620f8807dfa25d0bf0ac85f

The entire reason for that workaround was for a God of War fix, right? It's been a while, so has God of War been fixed yet? I think it's definitely possible.

Do the earlier builds not have the subtitles flashing issue?
I can fixed the overlay issue myself without editing the lines in the ini file (which caused the whole screen to flash).
My main issue was after fixing the overlay issue it caused the subtitles and other displayed messages to flash and disappear quickly after appearing.


RE: The 3rd Birthday - chukkyjr - 07-16-2013 05:37 AM

^i can confirm the old build does fix everything (flash issue, and white lines) but i can't get BGM audio to work (not sure but i think that build doesnt have at3 yet) and also my usb controller isn't recognized at all by the old build, it is still playable using a keyboard though

well i prefer using the latest version though, the flashing seems to be a bit reduced, and fighting using tanks without the crosshair on hard is darn exciting lol

EDIT : with the latest build v0.8.1-589-ge370723 i have no white lines and flashing issues (so far)


how do i use spoiler here btw? wanted to post the ppsspp.ini but it is kinda too long

EDIT2 : scratch that, it works great on that build, no more UI flashes when selecting overdive target etc


RE: The 3rd Birthday - RyviusRan - 07-16-2013 03:49 PM

(07-16-2013 05:37 AM)chukkyjr Wrote:  ^i can confirm the old build does fix everything (flash issue, and white lines) but i can't get BGM audio to work (not sure but i think that build doesnt have at3 yet) and also my usb controller isn't recognized at all by the old build, it is still playable using a keyboard though

well i prefer using the latest version though, the flashing seems to be a bit reduced, and fighting using tanks without the crosshair on hard is darn exciting lol

EDIT : with the latest build v0.8.1-589-ge370723 i have no white lines and flashing issues (so far)


how do i use spoiler here btw? wanted to post the ppsspp.ini but it is kinda too long

EDIT2 : scratch that, it works great on that build, no more UI flashes when selecting overdive target etc

With the newest build I still get flashing even without adding the FramebuffersToMem = True.

It happens at the beginning of Episode 1 right after the cutscene.


What version of the newest build do you use?
Is it the 32bit or 64bit version?
Also can you give me your ini file?
Just upload it to mediafire or a site like it then post the link here.


RE: The 3rd Birthday - chukkyjr - 07-16-2013 04:08 PM

try this http://www.mediafire.com/?diggjp71dxt2usu

well there is still flashing, but it is reduced by like 90%, i can even see tanks crosshair now

edit : wrong, this one http://www.mediafire.com/?3b0is114abpchc2

on 64 bit, machine :

Vaio Eseries VPCEA16FG
i5-520M @ 2.4 GHz
Radeon HD 5650M 2 GB VRAM
Windows 7 Home Premium
8 GB RAM (..not that it matters much)

v0.8.1-589-ge370723 (pretty sure i wrote it alr)

edit : eh didn't notice only the left tank (catapult 22 ? ) have visible crosshair


RE: The 3rd Birthday - NowakSotto - 07-16-2013 07:00 PM

here continue flashing, using ur .ini :\ and the latest version for 64bit too

this problem is only in episode 1 ?
i cant read the texts yet ;\


RE: The 3rd Birthday - chukkyjr - 07-16-2013 07:55 PM

hmm i'm afraid it might be machine specific..

btw do everyone else meant the screen flash in CTI HQ? that also happens on my case, but the screen flash is reduced on missions (one notable moment is on the first reaper spawn, when entering the room the first reaper appear my rig will flash the UI like crazy on older build, it is toned down a lot now)


RE: The 3rd Birthday - tapcio - 07-16-2013 08:31 PM

(07-16-2013 07:55 PM)chukkyjr Wrote:  hmm i'm afraid it might be machine specific..

btw do everyone else meant the screen flash in CTI HQ? that also happens on my case, but the screen flash is reduced on missions (one notable moment is on the first reaper spawn, when entering the room the first reaper appear my rig will flash the UI like crazy on older build, it is toned down a lot now)

No machine, driver... AMD drivers have buggy OpenGL in most cases... Can you write your driver (Catalyst) version ?


RE: The 3rd Birthday - NowakSotto - 07-16-2013 10:04 PM

maybe if update the video driver can solve it too no ?


RE: The 3rd Birthday - chukkyjr - 07-17-2013 06:33 AM

(07-16-2013 08:31 PM)tapcio Wrote:  No machine, driver... AMD drivers have buggy OpenGL in most cases... Can you write your driver (Catalyst) version ?

ya i meant that, AMD Catalyst 13.1 WHQL mobile version (pretty sure it is outdated?)

off topic : well AMD drivers are indeed buggy for OpenGL in a lot of cases, e.g ePSXe can't run with OpenGL on my laptop, needs a tons of tweaks


RE: The 3rd Birthday - tapcio - 07-17-2013 09:28 AM

I use 13.6 Beta 2 for my HD6850 (desktop), and is flashing with latest PPSSPP with ini tweaks.

PS: ePSXe works fine for me for all 13.x drivers. I recommend using shark, I added ePSXe 1.8.0 support and re-designed it some time ago: http://www.ngemu.com/forums/showthread.php?t=15463


RE: The 3rd Birthday - RyviusRan - 07-17-2013 08:13 PM

I use an nvidia GPU and still get the flashing so it's not hardware specific.


RE: The 3rd Birthday - chukkyjr - 07-18-2013 07:56 AM

does it help if i make a data dump or something? how do i do it? it really is reduced on my case (notably on mission 0, 1 and 2).

E : like i said, it is reduced not gone