forums.PPSSPP.org
Bug in Non-buffer Render + Frameskip! :( - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Development (/forumdisplay.php?fid=3)
+--- Thread: Bug in Non-buffer Render + Frameskip! :( (/showthread.php?tid=5752)



Bug in Non-buffer Render + Frameskip! :( - ysangredevago - 08-21-2013 04:30 PM

I'm on the latest stable version (the v0.9.0)
and ah when playing some games before they ran stable (in the before last builds of v0.8.1)
Now when I activate Frameskip + Non-Buffered Render:
this is what happens:

[Image: XDlWMFE.png]

[Image: sjfG3Xs.png]

[Image: weNlv0E.png]

and if active (Render Buffered) the bug disappears, but way too low speed and also the graphics look pixelated ....
I hope it can be corrected in the next builds .. Smile
ah I forgot, my device is an Xperia Play, android Stock 2.3.4
Great Work also .. The new user interface is impeccable!

2º Post!!!
I wanted Report this problem to the developers,
I thought it was a problem only in some games,
But I've noticed that the problem occurs in all games I've tried (and that before me builds worked fine in v0.8.1)
1)When active frameskip + non-buffered render the bottom half of the screen displays graphics errors ...
2)When frameskip + disable non-buffered render, the picture looks good, but the game runs too slow.
3)When Render Active frameskip + buffered, the game runs at an average speed, but the image looks more pixelated.

The error is shown to me in the following games:
Dragon Ball Shin Budokai
Dragon Ball Shin Budokai 2
Rurouni Kenshin
Megaman Maveric Hunter X
Crash Tag Team Racing
Hellboy The Science of Evil
And surely the problem is not in these games, if not in general the emulator, since in the PC version of the same thing happens.

My device is an Xperia Play ..
I hope can be resolved in future reviciones since emulated speed is excellent with these settings:
Rendering Mode: Non-Buffered Rendering
Frame Rate Control:
Frameskip: +3
Force Max 60 FPS: Yes
Alternative Speed​​: 100%
Features:
Hardware Transformation: Yes
Vertex Cache: Yes
Mipmapping: No
Audio:
Atrac3 +: Yes
Emulation:
Fast Memory: Yes
Dynarec Jit: Yes
CPU Clock: 100 MHz
Everything Else (DEFAULT)


RE: Bug in Non-buffer Render + Frameskip! :( - mupralsh - 08-21-2013 11:31 PM

Looks like you solved your own problem there! Smile
Yes, some games demand different settings to run correctly, if you play this on a powerful PC i'm sure you'll get full speed so it also has something to do with the device specs Wink
I'll close this, if you have another issue for a specific game, you should post it on the game's thread instead of creating another, do a search next time! Wink

Closed.


Problem With Frameskip in All Games functioned That Before! - ysangredevago - 08-22-2013 12:43 AM

I wanted Report this problem to the developers,
I thought it was a problem only in some games,
But I've noticed that the problem occurs in all games I've tried (and that before me builds worked fine in v0.8.1)
1)When active frameskip + non-buffered render the bottom half of the screen displays graphics errors ...
2)When frameskip + disable non-buffered render, the picture looks good, but the game runs too slow.
3)When Render Active frameskip + buffered, the game runs at an average speed, but the image looks more pixelated.

The error is shown to me in the following games:
Dragon Ball Shin Budokai
Dragon Ball Shin Budokai 2
Rurouni Kenshin
Megaman Maveric Hunter X
Crash Tag Team Racing
Hellboy The Science of Evil

And surely the problem is not in these games, if not in general the emulator, since in the PC version of the same thing happens.

My device is an Xperia Play ..
I hope can be resolved in future reviciones since emulated speed is excellent with these settings:
Rendering Mode: Non-Buffered Rendering
Frame Rate Control:
Frameskip: +3
Force Max 60 FPS: Yes
Alternative Speed​​: 100%
Features:
Hardware Transformation: Yes
Vertex Cache: Yes
Mipmapping: No
Audio:
Atrac3 +: Yes
Emulation:
Fast Memory: Yes
Dynarec Jit: Yes
CPU Clock: 100 MHz
Everything Else (DEFAULT)


RE: Bug in Non-buffer Render + Frameskip! :( - cloud1250000 - 08-22-2013 02:25 AM

But there is a problem, why are you closing this thread o.o before the game was running great and now there is a bug using specific setting...


RE: Bug in Non-buffer Render + Frameskip! :( - mupralsh - 08-22-2013 02:41 AM

Because i simply think he/she should report it on the game's thread instead of creating a new topic since he seems only having this problem on that specific game Undecided


RE: Bug in Non-buffer Render + Frameskip! :( - ysangredevago - 08-22-2013 02:47 AM

(08-22-2013 02:41 AM)mupralsh Wrote:  Because i simply think he/she should report it on the game's thread instead of creating a new topic since he seems only having this problem on that specific game Undecided

true, did not understand because I closed this thread, this is a big problem, and that having to activate buffered render in several games (to work well) drastically low speed ..
(which did not happen in the old builds v0.8.1)
The problem also, I think this in Frameskip as to enable (Non-Beffered Render and Frameskip off, the picture looks good (no errors) but the speed drops too ..Sad
is a puzzle .. Tongue

PS: the problem is not only in dragon ball, look at my new thread:
http://forums.ppsspp.org/showthread.php?tid=5752

I think that is a problem in general, (and I'm a novice user in emulators) are very well what each configuration, so I think it is problem of the emulator, I would like to know what you think the great henrik, Smile
it's a shame to have this little (big) detail the last update, since the interface and everything else is excellent .. Smile

PS 2: by the way, I am "Boy"
Yeka = nickname boy)
SangreDeVago (Blood Of Vague) = Man.
hehe XD


RE: Problem With Frameskip in All Games functioned That Before! - mupralsh - 08-22-2013 02:55 AM

Whops i thought this is only happening on dragon ball, sorry, you should've made that other report earlier Smile
I merged your thread.


RE: Bug in Non-buffer Render + Frameskip! :( - ysangredevago - 08-22-2013 03:38 AM

(08-22-2013 02:55 AM)mupralsh Wrote:  Whops i thought this is only happening on dragon ball, sorry, you should've made that other report earlier Smile
I merged your thread.

a question!
the problem has already been reported to Henrik???
I think the should have a look, since he also has an Xperia Play, you could find the fault that is causing this .. Smile


RE: Bug in Non-buffer Render + Frameskip! :( - aki21 - 08-22-2013 04:38 AM

I think this thread should be open,since I have the same problem for dbz budokai,now non-buffered rendering really render thing uncorrectly,it not worse but still it's a bug that.occur recently,should report to github instead since it affect several other games too.

(08-22-2013 03:38 AM)ysangredevago Wrote:  
(08-22-2013 02:55 AM)mupralsh Wrote:  Whops i thought this is only happening on dragon ball, sorry, you should've made that other report earlier Smile
I merged your thread.

a question!
the problem has already been reported to Henrik???
I think the should have a look, since he also has an Xperia Play, you could find the fault that is causing this .. Smile

btw,did you enable antialising in buffered mode?that will slowdown your phone if you use buffered render at the same time,should enable buffered render without antialising,buffered render now not really slow,i think the speed now can achieve almost same as non buffered except you enable antialising+buffered render to improve graphic but will slow down emulation.this method can blast away the bug(except you.enable non buffered render again).