forums.PPSSPP.org
Tales of Destiny 2 - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Tales of Destiny 2 (/showthread.php?tid=4481)

Pages: 1 2 3


RE: Tales of Destiny 2 - [Unknown] - 03-20-2015 09:39 PM

It's going to be nearly impossible to help you without knowing what device and especially GPU you have.

If you have a Broadcom / VideoCore GPU, then you're basically screwed (sorry.) Apparently the drivers/GL support are so badly broken that it totally glitches out in this game. Recent changes may have made it glitch out differently:

https://github.com/hrydgard/ppsspp/issues/6232

I'm not sure which drivers this effects.

-[Unknown]


RE: Tales of Destiny 2 - player594 - 03-22-2015 06:57 AM

I'm on a Nexus 7 2012 edition with lollipop 5.1 installed. Latest git ver. has same resolution error plus sprites are green now.


RE: Tales of Destiny 2 - [Unknown] - 03-22-2015 04:22 PM

It works fine on a Nexus 5 with render resolution at 1x. I'm not sure exactly what it's doing that's making other render resolutions not work. I know it uses some strange methods of blending and stuff, they may depend on it being at the same resolution the PSP was.

-[Unknown]


RE: Tales of Destiny 2 - [Unknown] - 03-22-2015 07:30 PM

The black on higher render resolutions is caused by the viewport being outside the (implementation specific) range. So which resolutions work may depend on your video card and driver.

-[Unknown]


RE: Tales of Destiny 2 - [Unknown] - 03-23-2015 07:27 AM

And that black thing should be resolved now. But the green thing, I don't know. Might be caused by your settings. Does it happen on desktops, only on mobile? What devices, aside from the Tegra 3 (Nexus 7 2012 = Tegra 3)?

-[Unknown]


RE: Tales of Destiny 2 - player594 - 03-23-2015 08:12 PM

Resolution is right now, tnx. But its still green. Everything is default except PSP is 1x.
[Image: 2l3wc1.png]
[Image: r9g2lz.png]


RE: Tales of Destiny 2 - player594 - 04-07-2015 09:09 PM

Anyone else getting this issue?

I know there is a lot of revisions between this screenshot and latest but ver. but the color is right in this one. Don't know what changed.


RE: Tales of Destiny 2 - [Unknown] - 04-07-2015 11:12 PM

https://github.com/hrydgard/ppsspp/compare/v0.9.9.1-1481-g50f5809...v1.0.1-204-g3ef8c70

There were 485 changes between those two versions. That's a lot to look at, and since I can't reproduce the issue, I'll probably never find it. If I handed you a stack of 485 pages of text, and asked you to find a typo on just one line of one of those pages (that Word or etc. already had not found), would you be able to find it? Yeah, it's hard.

If you could test more versions and find the first version it started happening in, and the last version it did not happen again, it would make it a lot easier to find the typo.

But it looks like crazy blending problems to me so it might be a buggy driver, which may be harder to work around than just fixing a typo.

-[Unknown]


RE: Tales of Destiny 2 - player594 - 04-08-2015 07:10 AM

Where can I get a full list of compiled revs from bit hub. I use the orphis buildbot. It doesn't go back that far. I just happened to still have that build on my tablet.


RE: Tales of Destiny 2 - [Unknown] - 04-08-2015 07:09 PM

The full list is here:
http://buildbot.orphis.net/ppsspp/index.php?m=fulllist

It should go back at least 500 commits.

-[Unknown]


RE: Tales of Destiny 2 - player594 - 04-08-2015 09:44 PM

OK after going back and searching, I found the last version with correct colors. V1.0.1-152 g9db4c5f


RE: Tales of Destiny 2 - [Unknown] - 04-08-2015 10:50 PM

Okay, so it's probably the framebuffer fetch and therefore could very well be a buggy driver. Before this change we were using NV_shader_framebuffer_fetch, just not as often, so it's possible other things were broken too.

So, I guess we should just disable NV_shader_framebuffer_fetch on Tegra 3 devices. Wish I could tell more about what and why it's broken.

-[Unknown]


RE: Tales of Destiny 2 - player594 - 04-08-2015 11:52 PM

Anything I can do to help?


RE: Tales of Destiny 2 - [Unknown] - 04-09-2015 12:13 AM

Well, I've created a pull to blacklist Tegra 3:
https://github.com/hrydgard/native/pull/267

I'm thinking it might not be strictly ordered or something. What's strange is, I don't know of any green that's used on the title screen except the current selection - the textures don't have green, the framebuffer is never drawn green, etc. So I have no idea where the green is actually coming from.

-[Unknown]


RE: Tales of Destiny 2 - player594 - 04-09-2015 01:04 AM

Its throughout the game.