forums.PPSSPP.org
60fps, lags heavily anyway - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: General Discussion and Announcements (/forumdisplay.php?fid=2)
+--- Thread: 60fps, lags heavily anyway (/showthread.php?tid=3993)

Pages: 1 2


60fps, lags heavily anyway - PatrickP - 06-10-2013 10:10 PM

Hi!

My psp died a couple of days ago, so now I downloaded ppsspp on my computer instead. I've tried to follow the "PPSSPP options explained" thread for setting up the most performance.
My problem is even though my fps says 60fps almost all the time (drops to 58 sometimes) I still experience quite a lot of lag..
I've tried a lot of different settings now and the lagging just doesn't go away.

My cpu is an i3 dual core clocked at 2,26 Ghz, so it should be able to handle it i think? (and if it couldn't handle it the fps wouldn't say 60fps?)

Do you guys know what I can do to reduce the lagging?

I use ppsspp version 0.7.6 on a Windows computer.


RE: 60fps, lags heavily anyway - Henrik - 06-10-2013 10:14 PM

That computer should trivially handle most PSP games.

There are a few of games which have speed/timing emulation issues that look like lag.

What games specifically are you trying to play?


RE: 60fps, lags heavily anyway - jadentheman - 06-10-2013 10:29 PM

(06-10-2013 10:10 PM)PatrickP Wrote:  Hi!

My psp died a couple of days ago, so now I downloaded ppsspp on my computer instead. I've tried to follow the "PPSSPP options explained" thread for setting up the most performance.
My problem is even though my fps says 60fps almost all the time (drops to 58 sometimes) I still experience quite a lot of lag..
I've tried a lot of different settings now and the lagging just doesn't go away.

My cpu is an i3 dual core clocked at 2,26 Ghz, so it should be able to handle it i think? (and if it couldn't handle it the fps wouldn't say 60fps?)

Do you guys know what I can do to reduce the lagging?

I use ppsspp version 0.7.6 on a Windows computer.

My laptop does this too. Like the previous poster said it has a trivial impact on the CPU. My CPU is only used up to 26% on the emulator. I think the issue is because Intel integrated graphics is garbage so it doesn't emulate the graphics correctly and smoothly. If we had a dedicated GPU card or a DirectX option for ppsspp then I am positive performance would be matched to that on a real PSP.


RE: 60fps, lags heavily anyway - kenny43 - 06-10-2013 10:34 PM

That's indeed lack of GPU power, I wonder if using software mode would help up this kind of stuff? If I had a pc to try it on.


RE: 60fps, lags heavily anyway - The Phoenix - 06-10-2013 10:56 PM

(06-10-2013 10:10 PM)PatrickP Wrote:  Hi!

My psp died a couple of days ago, so now I downloaded ppsspp on my computer instead. I've tried to follow the "PPSSPP options explained" thread for setting up the most performance.
My problem is even though my fps says 60fps almost all the time (drops to 58 sometimes) I still experience quite a lot of lag..
I've tried a lot of different settings now and the lagging just doesn't go away.

My cpu is an i3 dual core clocked at 2,26 Ghz, so it should be able to handle it i think? (and if it couldn't handle it the fps wouldn't say 60fps?)

Do you guys know what I can do to reduce the lagging?

I use ppsspp version 0.7.6 on a Windows computer.

Try these settings that I use.........
[attachment=5514][attachment=5515][attachment=5516][attachment=5517]


RE: 60fps, lags heavily anyway - foxseatiger - 06-11-2013 12:27 AM

What game? Some game will not working because is not compatible yet.

I'm using core2duo playing PE3 portable with no hassle. No lag so ever because is compatible with the emulator.
My using ATI readon 45xx HD and 4gb ram. PPSSPP running on my PC with 60fps. I think it normal because this no lag. The in game graphic is more beautiful then PSP kudos to developer for making this awesome emulator.

...

PE3 also running on my Galaxy nexus but good as PC. Sometimes lag with 33FPS. I think because of my phone GPU not as good as my PC.


RE: 60fps, lags heavily anyway - Danyal Zia - 06-11-2013 05:48 AM

(06-10-2013 10:56 PM)The Phoenix Wrote:  
(06-10-2013 10:10 PM)PatrickP Wrote:  Hi!

My psp died a couple of days ago, so now I downloaded ppsspp on my computer instead. I've tried to follow the "PPSSPP options explained" thread for setting up the most performance.
My problem is even though my fps says 60fps almost all the time (drops to 58 sometimes) I still experience quite a lot of lag..
I've tried a lot of different settings now and the lagging just doesn't go away.

My cpu is an i3 dual core clocked at 2,26 Ghz, so it should be able to handle it i think? (and if it couldn't handle it the fps wouldn't say 60fps?)

Do you guys know what I can do to reduce the lagging?

I use ppsspp version 0.7.6 on a Windows computer.

Try these settings that I use.........

Enabling Vertex Cache makes emulator a lot laggy in ATI/AMD cards. I wonder if that isn't compatible with ATI chipsets yet! Also, sometimes disabling Hardware Transform speeds up the emulator a bit. I guess OpenGL driver of ATI sucks!


RE: 60fps, lags heavily anyway - Squall Leonhart - 06-11-2013 07:27 AM

how old is your display driver?

more importantly, how old is your display card.


RE: 60fps, lags heavily anyway - PatrickP - 06-11-2013 09:11 AM

(06-10-2013 10:14 PM)Henrik Wrote:  That computer should trivially handle most PSP games.

There are a few of games which have speed/timing emulation issues that look like lag.

What games specifically are you trying to play?

I've tried these:
Little Big planet (it says 60fps but lags quite a lot)
Kingdom Hearts Birth by Sleep (says between 55-60, lags quite a lot)
Dissidia Final Fantasy (says 60fps, lags quite a lot)
Digimon World Re:Digitize (says 60fps, lags heavily, feels like 10 fps)

Some games dont work, they seem to work at first (shows all the "Square Enix" stuff and lets me choose new game and so on) but then just stop working and just gives me a black screen. I've of course waited for about 10 minutes when this happens to make sure it's not just loading.

These games are:
Final fantasy tactics the war of the lions
Final fantasy VII


(06-10-2013 10:56 PM)The Phoenix Wrote:  Try these settings that I use.........

For some reason I don't have exactly all of those settings.. Are you using the same version as I do? (version 0.7.6)


RE: 60fps, lags heavily anyway - Ritori - 06-11-2013 09:18 AM

Realy? that lag my spec realy* weak that you are... it no soo lag for me i used AMD/ATI card it okay when i used
Vertex Cache :o
(why u dont use latest version?)
(0.7.6 realy outdate one)


RE: 60fps, lags heavily anyway - PatrickP - 06-11-2013 02:40 PM

(06-10-2013 10:34 PM)kenny43 Wrote:  That's indeed lack of GPU power, I wonder if using software mode would help up this kind of stuff? If I had a pc to try it on.

I don't think it's lack of GPU power, the GPU usage is between 25-75% depending on game. It lags on all games, even those with only 25% GPU usage.


(06-11-2013 07:27 AM)Squall Leonhart Wrote:  how old is your display driver?

more importantly, how old is your display card.

Well my GPU is an integrated that comes with the i3 350m processor. But it's not even working at 100%, so it shouldn't be the bottleneck, right?
(The GPU usage is between 25-75% depending on which game I play)


So I've now downloaded the newest revision of 0.7.6 (there is no such thing as 0.7.7 or better/newer right?), and now my controller doesn't work on all games. In Little Big Planet everything runs fine (a little bit of lag still though), but in "Digimon World Re:Digitize" the arrows just don't work at all. I can only use A/B/X/Y.
(The ppsspp build was downloaded from http://buildbot.orphis.net/ppsspp/)

So does anybody know what's wrong? Can it actually be the GPU, even though its usage isn't even close to 100% (I'm thinking of those games that only uses about 35-50%)?


EDIT: The fps meter still says 60fps on many games, but they lag anyway.


RE: 60fps, lags heavily anyway - XinXin - 06-11-2013 05:34 PM

Sounds to me like your CPU is fast enough to render the game but your GPU is too weak to display the frames.


RE: 60fps, lags heavily anyway - joekenton - 06-11-2013 11:46 PM

Simply put: An integrated GPU simply isn't fast enough to emulate more modern systems like the PSP. The solution if you're using desktop is to get a dedicated GPU, GTX560TI is a good card for the price. If you're using a laptop then you're out of luck.


RE: 60fps, lags heavily anyway - [Unknown] - 06-11-2013 11:46 PM

If your GPU is too slow, you shouldn't see 60 vps usually, but I guess it depends on the video card driver and its settings. At least for me, I have plenty of games that undertax my CPU, but my GPU can't handle more than 600 or 1200 vps (I use a "green edition" underclocked GeForce 9800 GT, but have a nice powerful Ivy Bridge i7.)

I would suggest you try a recent git build instead of 0.7.6. They're a bit lower down on the downloads page. They're less stable, but right now they're a lot improved over 0.7.6.

The latest git builds also have control customization under Settings -> Controls. Not sure if that will help your prolem with Digimon.

-[Unknown]


RE: 60fps, lags heavily anyway - PatrickP - 06-12-2013 06:57 PM

So I've finally found a good (and very simple) solution!
I just raised my fps limit to 90fps. Everything of course runs faster than it should, but at least there's no lag in most of the games Smile
My GPU was indeed the bottleneck in Kingdom Hearts because the fps stayed the same, but there was no problem at all getting up the fps to 90 in Digimon, Final Fantasy and Little Big Planet!

Thanks for all your help guys, I'm going to play Little Big Planet now Big Grin