forums.PPSSPP.org
[HELP] MHP3 Lobbie Problem - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Ad-Hoc Multiplayer (/forumdisplay.php?fid=34)
+--- Thread: [HELP] MHP3 Lobbie Problem (/showthread.php?tid=28036)



[HELP] MHP3 Lobbie Problem - Aurora866 - 09-25-2021 12:55 PM

First of all, I don't know if it's right to write here, but I'm writing because it's not solved.

If I access a room where no one is there first, it works without any problems.
(I can see people and play without problems.)
But when I access the lobby where someone is accessing, I can check the connection through the website and chat, but I can't see anyone.

Please give me a solution.

and I'm sorry that I'm not good at English.

(A problem has occurred since the router was changed, but it is not a router problem.(Asus router))
(For your information, I checked this problem accurately with my friend.)
(It was confirmed that the port was open.)

using version : ppsspp 1.11.3
using iso : Monster hunter 3RD (MHP3)
connect server : myneighborsushicat(dawn) / socom.cc
ppsspp setting :
- Software skinning Unchecked
- Fast Memory Unchecked
- Enable networking/WLAN checked
- (There is no problem with other settings.)
another setting :
- Exception and release of all firewalls
- Port forwarding (27312, 10000, 20001~20004)

The way i tried it :
- DMZ (failed)
- Another version of ppsspp 1.11.2, 1.9.3 (failed)
- Run Windows 7, 8 compatible mode (failed)
- Initialize and reset the router (failed)


RE: [HELP] MHP3 Lobbie Problem - AdamN - 10-03-2021 06:24 AM

Is this issue occurred after changing the router? That is strange.. have you tried enabling UPnP on your router instead of DMZ?

Is the other person you're trying to play with is someone you know and have played with before? because if it's a random person on the internet the issue could be on their end and not on your side.
Even if you can chat with them doesn't mean they have their ports forwarded, for example people who use 3G/4G/LTE mobile internet connection will have their ports blocked by their ISP most of the time.

Also, have you tried using the latest official dev build from here https://buildbot.orphis.net/ppsspp/ it have more multiplayer fixes than the stable 1.11.3 version

PS: you don't need to create multiple threads of the same issue in this forum


RE: [HELP] MHP3 Lobbie Problem - Aurora866 - 11-09-2021 02:23 PM

I quit the game without finding a solution, so I watched it now.
We've played together before, and as described above, if I go into the lobby first, I can play with anyone without any problem.
And now that I'm back on MHP3, I can't see anyone at all regardless of going in first. Sad

I want to play the game again now, but now I can't because I can't see anyone.

My reply is very late, but I would appreciate it if you could give me a solution yet.

(Considering that no one is seen at all now, it seems to be just a problem with the Asus router. It doesn't mean it's defective, but the router itself blocks the port. Like this.)

(In the past, even if the problem was tricky, I could see people if I went into the lobby first. But now no one can see it regardless of the order of access to the lobby.)

PS : The thread upload was slow, so I accidentally uploaded two, but I deleted one.


RE: [HELP] MHP3 Lobbie Problem - AdamN - 11-09-2021 04:04 PM

Please use the latest version 1.12.3 or newer, and don't use the 1.11.x version

Did you see any message on screen when entering the gathering hall? other than "Network initialized" that is

There is also a possibility that the issue might not be on your side but on the other players side.
Please ask everyone who played with you to follow this guide https://github.com/hrydgard/ppsspp/wiki/How-to-play-multiplayer-games-with-PPSSPP
Especially on the "How To Find Out If A Player Have Blocked Ports Or Not" part (which is the most important part) to make sure everyone have a working port-forwarding.

If your router have UPnP feature we recommend using it instead of manually doing port-forwarding, because if the Port Offset is being changed (we use 10000 as default now instead of 0) the ports that need to be forwarded will also changed, with UPnP it's done automatically.

Anyway, we always encourage users to use the latest version, but if the latest version didn't work...
Do you remember which version was working for you?
Have you tried to ask everyone to use the same PPSSPP version that was working for you? (because everyone playing together need to use the same PPSSPP version to make sure they're compatible)
Basically, if you remembered which version was working for you, but now that same version is no longer working, that means the issue is not on PPSSPP (because old PPSSPP are not changed)


RE: [HELP] MHP3 Lobbie Problem - Aurora866 - 11-10-2021 05:14 AM

I just used 1.12.3. As expected, it did not work, and even if UPnP is used and port offset 10000 is set, people still cannot be seen.
Also, the phrase "Network Initialized" was always displayed normally.
So I was sure the port was open, but eventually I couldn't see the people.
(For reference, all other port forwarding I am using is also operating normally.)

When I used the iptime router, I played multi-play with the same version as my friend. (1.11.X)

In the first place, any version worked well when using the iptime router. (the version that I remember is 1.9.3, 1.11.1 ~ 1.11.3)
However, after switching to the Asus router, I had to go into the lobby first to play normally. (1.9.3, 1.11.3)
I haven't changed anything, but now I can't see people at all regardless of the order they enter the lobby. (1.11.3, 1.12.3)

As you said, I think it's a router problem, not ppsspp, but I can't figure out the cause at all.

PS :
I don't know if there is a relationship, but "amultios" is normally multi-playable.
And Multi-play through vpn such as zerotier is also possible normally.
But I want to use a server like "socom.cc".

I'll write down the router I'm using just in case. (ASUS RT-AX56U)


RE: [HELP] MHP3 Lobbie Problem - AdamN - 11-10-2021 06:02 AM

When using VPN, port-forwarding is not needed (just like playing on LAN), this is probably why it worked, and Amultios have a built-in vpn/tunneling i think.


RE: [HELP] MHP3 Lobbie Problem - Aurora866 - 11-10-2021 10:57 AM

Hmm... Eventually, it's clear that the internet or router is a problem, but the port is open, too...
I haven't found the cause for a long time, so I won't play the game until I change the router haha...Sad

The problem has not been solved, but thank you for your help.

Please let me know if you have a solution later on! Smile

I solved the problem very absurdly just now.
The log indicated that all ports were open, but in reality only some ports were open.
Therefore, without setting the port as a range, it works normally if it is opened individually.

I still don't know why the dmz setting failed.
And i am angry at the Asus router setting. Sad

Anyway, thank you for your help, and I should enjoy multi-play!