forums.PPSSPP.org
PoPoLoCrois crash when select new game option - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: General Discussion and Announcements (/forumdisplay.php?fid=2)
+--- Thread: PoPoLoCrois crash when select new game option (/showthread.php?tid=26595)



PoPoLoCrois crash when select new game option - Capryloyl - 06-19-2020 02:04 PM

As title states, when I load the game, everything is fine and dandy. However, once I confirm "new game" on the title screen, it freezes, the screen goes black (controls still there), and then the emulator crashes and closes.

This is on the Android version of PPSSPP.
I have tried 1.6.3, 1.7.4, 1.8.0 and 1.9.4 all with the following settings:

GRAPHICS
backend: OpenGL
Mode: skip buffer
enable simulated block transfer
frameskipping (1)
1x psp rendering and display resolution.
Enabled hardware transform, software skinning, vertex cache.
(Have tried enabling and disabling lazy texture caching and slower effects)
Retain changed textures enabled
Low spline curves
upscale off
deposterize off
anisotropic filtering off

SYSTEM
fast memory on
I/O on thread on

I haven't been able to find anything to help on the forums, as no one has stated there being an issue on the title screen when choosing new game. It doesn't seem to be an issue with my rom either as I have downloaded a few more copies from different places to test. (UNDUBs, USA versions, etc) T_T
Send help...


RE: PoPoLoCrois crash when select new game option - [Unknown] - 06-21-2020 01:15 PM

I've definitely tested this one fairly recently on a recent git build without problems.

Can you try the latest git build from the downloads page? What Android device are you using?

Using skip buffer may prevent the video it plays early on from showing. Does anything change when using normal buffered rendering?

This should probably be in the game's topic, though.

-[Unknown]


RE: PoPoLoCrois crash when select new game option - Capryloyl - 06-15-2021 01:36 PM

Hey there,

I'm a whole one year late in replying, but I've come back with a different device, version 1.11.3 of PPSSPP and still the same issue.
Currently I'm using a Realme 6, and previously an Oppo AX7. It could be a mobile issue? Since all the posts I've seen about PoPoLoCrois are played on PC.
Taking your advice, I've switched to buffered rendering instead of skip buffer, but the only difference seems to be that while buffered rendering freezes at the title screen, it shows a black screen after waiting a minute or two, skipped buffer shows a black screen immediately.
The PoPoLoCrois History shows, so it seems the trigger for it freezing is when I select and enter New Game option, none of the other options has this issue.

Also I'm not entirely sure how to place this post under the PoPoLoCrois topic, does it go under Playable Games?

Graphics:
Backend: Vulcan
Mode: Buffered
Simulate Block transfer: On
Frame skipping: Off
Postprocessing shader: Off
Rendering resolution: 2x
Hardware transform: On
Software skinning: On


RE: PoPoLoCrois crash when select new game option - [Unknown] - 06-16-2021 02:45 AM

Yes, the first one here:
https://www.google.com/search?q=popolocrois%20site:forums.ppsspp.org

I'm using the US release, a clean copy from my UMD. Works fine on Android and Windows, using a recent git build. I recommend verifying your ripped copy's CRC.

Both the US and EU releases have been reported working by community members:
https://report.ppsspp.org/game/ULUS10018_1.03

-[Unknown]