forums.PPSSPP.org
[BUG] PPSSPP can't save settings on Android 9 - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Development (/forumdisplay.php?fid=3)
+--- Thread: [BUG] PPSSPP can't save settings on Android 9 (/showthread.php?tid=25610)



[BUG] PPSSPP can't save settings on Android 9 - olddos25 - 08-28-2019 07:59 PM

Hello everyone, this is my first message and I created this account just to report a PPSSPP bug. See, I just got a new cellphone with Android 9, and for some reason my settings aren't saved. Whenever I get out of the settings menu I get the following: "Failed to save settings! Check permissions, or try restarting the device" (and yes, the storage perm is granted, and I tried restarting the device)
We were supposed to have gotten this over with a long time ago, guys!
Can it be fixed on a later release?
In case you ask, my phone is a Xiaomi Redmi Note 7. Just sayin'.


RE: [BUG] PPSSPP can't save settings on Android 9 - Henrik - 08-29-2019 11:29 AM

I've heard of this happening and a reboot is supposed to help, but there's no good reason this should happen.. must be an OS bug in your device, since with the right permissions PPSSPP shouldn't have any issue writing its files.


RE: [BUG] PPSSPP can't save settings on Android 9 - olddos25 - 08-29-2019 05:22 PM

So you are just gonna brush it off like nothing happened? No developer does that, you know?


RE: [BUG] PPSSPP can't save settings on Android 9 - LunaMoo - 08-29-2019 11:07 PM

@olddos25 the thing is, your problem is yours alone.

People with same device(ie me) never had such problem and can't reproduce it. A problem doesn't matter if small or big definitely will not be fixed by anyone that doesn't even understand why it happens, doesn't matter if they're experienced project leader or a random person walking by.
PPSSPP is open source, you have full access to source code just like anyone else and this gives you a choice, trying to understand the problem and fix it yourself as the person with highest chance of fixing it aka the person that can reproduce the actual problem or cry as you do and not accomplish anything outside of getting some internet hate trying to be some social justice warrior that thinks he's the most important person in the world for mere existing without doing shit for others to actually care about his existence.

Problem like yours could be caused by rippoff SD card with fake space on it(which are VERY common nowadays) or something else that could be specific to your system, maybe a vendor specific changes or some local/regional weirdness, maybe even a third party app doing something really bad, either way nothing will change the fact that you're affected while others are not.


RE: [BUG] PPSSPP can't save settings on Android 9 - olddos25 - 08-30-2019 09:43 PM

Ik, sorry for that. Anyways,I fixed it by just moving the PSP directory to the internal storage and reassigning the Memory Stick path. If anyone has this problem (which I don't think is the case as LunaMoo mentioned), that's the fix.


RE: [BUG] PPSSPP can't save settings on Android 9 - [Unknown] - 09-02-2019 04:12 PM

Did you change your settings to put it on external storage, or did it default there?

-[Unknown]


RE: [BUG] PPSSPP can't save settings on Android 9 - olddos25 - 09-15-2019 01:30 AM

I think I changed the settings at one point to place it on the external storage cuz my internal space was running a bit dry on my previous phone. But now I got this. Just moved it to internal storage, changed the respective settings and didn't had a problem since.