forums.PPSSPP.org
Postprocessing shader not available in Direct 3D 9 backend - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: General Discussion and Announcements (/forumdisplay.php?fid=2)
+--- Thread: Postprocessing shader not available in Direct 3D 9 backend (/showthread.php?tid=24608)



Postprocessing shader not available in Direct 3D 9 backend - Syyn4 - 08-30-2018 01:18 AM

Hello everyone!

I have been playing with the PPSSPP emulator for a while and I had the Intel GPU built before and I was playing with Direct3D 9 since OpenGL did not work, then I installed an Nvidia GT 440 GPU, then I was able to play in addition to Direct3D 9, with Direct3D 11, OpenGL , except Vulkan ... The fact is that since I upgraded the Nvidia Drivers to version 391.35, now it appears in the emulator that I can no longer use Shaders with the Api Direct3D 9, with the other engines it can.

Does anyone know what this is due to or if there is a solution? Or is it for the driver update ???


RE: Postprocessing shader not available in Direct 3D 9 backend - AkiraJkr - 08-30-2018 03:53 PM

It has nothing to do with the driver update. Postprocessing shaders originally did not work, and to avoid confusing users, it is hidden/disabled for D3D9. No matter what you do, they won't work in D3D9. They never did. Use other backends.