forums.PPSSPP.org
Patapon 1 - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Patapon 1 (/showthread.php?tid=22803)

Pages: 1 2 3 4 5


Patapon 1 - sfageas - 03-20-2013 07:09 AM

Genre : Music/Rhythm Game
Region : EU
Format : CSO
Version : v0.7-174-g04d4022
Game ID : UCES00995
OS : Win
Compatability : Intro
Notes : Freezing on Intro


RE: Patapon - shaddam - 03-20-2013 07:08 PM

Try loading from a save, had to do that with no.2


RE: Patapon - sfageas - 03-20-2013 07:15 PM

i tried with 2 but dint try with this one Smile it was near playable


RE: Patapon - Incog - 04-12-2013 11:02 PM

OS: WinXP
Version: v0.7-619-gd586d7d
Status: Almost playable
Works at full speed without any slowdowns even on a low-end pc, but projectiles, some buildings and few stages are completely absent. Music and sounds work too.


RE: Patapon - GuilhermeGS2 - 04-13-2013 04:28 PM

moved


RE: Patapon - GuilhermeGS2 - 04-13-2013 07:14 PM

updated compatibility list


RE: Patapon - Incog - 04-14-2013 12:42 PM

v0.7.5-1-g3dacb27 fixed all the previous problems with invisible hats, projectiles and stages. Works perfectly.


RE: Patapon - Mashi - 04-14-2013 10:38 PM

Doesn't work perfectly for me. I have the newest ver (v0.7.5-14-g17a3b75) The game turns on, I can see a starting screen, I can start a new game and then i can read english subtitles (about almighty and fate of the Patapons). And when game is about to begin for real, the screen goes dark (I can see controls, but playing screen is dark and nothing happens after that).


RE: Patapon - [Unknown] - 04-14-2013 11:01 PM

Sorry, for the moment you have to use a savegame. But, I have a note on how to possibly fix it, just have to figure out how to make other games stay happy at the same time.

-[Unknown]


RE: Patapon - cip91 - 04-17-2013 08:18 AM

Now it works perfectly! I started a new game and I managed to complete the first mission and save, now it's really playable, thanks!


RE: Patapon - SneeakyAsian - 04-17-2013 08:57 PM

Wait, so does sounds work?


RE: Patapon - cip91 - 04-18-2013 11:03 AM

(04-17-2013 08:57 PM)SneeakyAsian Wrote:  Wait, so does sounds work?

Well I think that there is something strange: on linux patapon runs fine (perfect sounds, and even manages to save, as I said before) with the latest git builds (since I think 0.7.5~50). On android (with 0.7.5-80) it doesn't go past the intro after you press "New Game". It begins to show subs but then suddenly after "no treasure out of reach, and no land unconquerable" it stops and it remains black, and won't go any further.

EDIT: Lookin at the logcat, it seems that it says "End of video reached" too soon, here's the relevant part of the log:
Code:
[...]
E/NativeApp( 4711): 13:23:948 user_main    E[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1340 UNIMPL sceMpegAvcCsc(08fb38b0, 0931b1c0, 09fff4b0, 512, 09244400)
E/NativeApp( 4711): 13:23:983 user_main    E[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1340 UNIMPL sceMpegAvcCsc(08fb38b0, 0931afb0, 09fff4b0, 512, 091bc380)
E/NativeApp( 4711): 13:24:012 user_main    E[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1340 UNIMPL sceMpegAvcCsc(08fb38b0, 0931b060, 09fff4b0, 512, 09244400)
I/NativeApp( 4711): 13:24:028 Thread.cpp   N[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1134 End of video reached
E/NativeApp( 4711): 13:24:051 user_main    E[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1340 UNIMPL sceMpegAvcCsc(08fb38b0, 0931b110, 09fff4b0, 512, 091bc380)
I/NativeApp( 4711): 13:24:060 Thread.cpp   N[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1134 End of video reached
I/NativeApp( 4711): 13:24:078 Thread.cpp   N[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1134 End of video reached
E/NativeApp( 4711): 13:24:095 Thread.cpp   E[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1047 sub-zero number of packets put
I/NativeApp( 4711): 13:28:998 Thread.cpp   I[HLE]: jni/../../Core/HLE/sceKernelThread.cpp:1898 sceKernelExitThread(0)
E/NativeApp( 4711): 13:29:006 user_main    E[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1340 UNIMPL sceMpegAvcCsc(08fb38b0, 0931b1c0, 09fff4b0, 512, 09244400)
I/NativeApp( 4711): 13:29:010 Thread.cpp   I[HLE]: jni/../../Core/HLE/sceKernelThread.cpp:1898 sceKernelExitThread(0)
W/NativeApp( 4711): 13:29:010 Thread.cpp   W[HLE]: jni/../../Core/HLE/sceMpeg.cpp:1300 UNIMPL sceMpegFlushAllStream(08fb38b0)



RE: Patapon - Grezen - 04-24-2013 08:41 AM

i got the same problem too.. just freeze at the intro.


Patapon [Windows 8][0.7.6][Works but skips frames] - White_sama - 04-27-2013 03:36 PM

Title: Patapon
Genre: Musical RPG/Rythm
Region (US, EU, JP): EU
Format (ISO, CSO, EBOOT): CSO
Version: 0.7.6
Game ID if you have it (names like ULES..., stuff like that): UCUS98771 (Not sure)
OS! Windows 8
Compatability (Intro, Menus, Ingame, Playable, Perfect): Playable
Notes (If any): The game seems fine, but is rather unplayable, since it skips some frames (The sounds lags at those moments), making the combos impossible to make
Logs: Not sure of to get them, will provide if someone can tell me

Didn't try the other patapon, but to what i've seen, patapon 2 has the same problem and patapon 3 is still WIP


RE: Patapon - sfageas - 04-27-2013 03:49 PM

Merged