forums.PPSSPP.org
Growlanser: Wayfarer of Time - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Growlanser: Wayfarer of Time (/showthread.php?tid=2260)

Pages: 1 2 3 4 5 6 7


RE: Growlanser: Wayfarer of Time - [Unknown] - 06-09-2018 09:02 PM

Ah - it may be that your driver is forcing 60 fps vsync, which may prevent unthrottling from working.

I assume it makes no difference to change the vsync checkbox in settings?

You're probably just not able to unthrottle this game because it's a 60 fps game, in that case. Many PSP games are 30 fps, so if you're locked to 60 fps max, you'll only be able to get 200% at most.

If you open memstick/PSP/SYSTEM/ppsspp.ini, and search for "FrameSkipUnthrottle", does it say "FrameSkipUnthrottle = True"? If it says False, change it to True. You can't change it while PPSSPP is running, so close PPSSPP first.

-[Unknown]


RE: Growlanser: Wayfarer of Time - Toffee - 06-10-2018 02:28 AM

(06-09-2018 09:02 PM)[Unknown] Wrote:  Ah - it may be that your driver is forcing 60 fps vsync, which may prevent unthrottling from working.

I assume it makes no difference to change the vsync checkbox in settings?

You're probably just not able to unthrottle this game because it's a 60 fps game, in that case. Many PSP games are 30 fps, so if you're locked to 60 fps max, you'll only be able to get 200% at most.

If you open memstick/PSP/SYSTEM/ppsspp.ini, and search for "FrameSkipUnthrottle", does it say "FrameSkipUnthrottle = True"? If it says False, change it to True. You can't change it while PPSSPP is running, so close PPSSPP first.

-[Unknown]

Woah!

First off, yes, turning off vsync didn't change things; so then I tried your suggestion of modifying the .ini file and it worked!

Almost too well in fact!

Now it's getting speeds up to 800% so now it's so fast that I can't even play or make sense of what the game is doing properly.

Is there a way to restrict it down to a more manageable speed like 200%?

If not, I may just have to change it back since it's affecting other games as well.

Also, I have to thank you for all the advice you've given thus far. It's been a really great help.


RE: Growlanser: Wayfarer of Time - [Unknown] - 06-10-2018 03:22 AM

I personally use "alternate speed" for that purpose. You can set the limit of alternate speed %, and press a button to toggle between it and normal speed. You can even set it lower than 100%.

-[Unknown]


RE: Growlanser: Wayfarer of Time - Toffee - 06-10-2018 04:21 PM

(06-10-2018 03:22 AM)[Unknown] Wrote:  I personally use "alternate speed" for that purpose. You can set the limit of alternate speed %, and press a button to toggle between it and normal speed. You can even set it lower than 100%.

-[Unknown]

Hmmm... it seems alternate speed suffers from the same issue.

Games that run at 30 fps can go up to double fps and 200% speed. (And only up to 200% even if set at unlimited or 1000% or something)

Growlanser and Star Ocean stay the same even after toggling alternate speed on. The only way to speed them up seems to be turning on FrameSkipUnthrottle.


RE: Growlanser: Wayfarer of Time - [Unknown] - 06-10-2018 05:39 PM

Ah, for that - try setting Frameskip to something like 8, and check Auto Frameskip. In normal conditions, it shouldn't frameskip (auto will see you're running smoothly.) This should just allow it to frameskip when using alternate speed and vsync is forced.

-[Unknown]


RE: Growlanser: Wayfarer of Time - Toffee - 06-10-2018 07:18 PM

(06-10-2018 05:39 PM)[Unknown] Wrote:  Ah, for that - try setting Frameskip to something like 8, and check Auto Frameskip. In normal conditions, it shouldn't frameskip (auto will see you're running smoothly.) This should just allow it to frameskip when using alternate speed and vsync is forced.

-[Unknown]

Yes!

It finally works!

I had Frameskip set to 1 instead since 8 was so choppy, and I have to "refresh" the emulator by pausing and unpausing it to reset the Auto Frameskip so it'll be smooth when reverting back to normal speed. (which is just a quick press of the LTrigger so it's not a big deal)

Other than those, it feels exactly like unthrottling in the other games! Now I can fast forward through thrash random battles, and speed up walking/dungeon crawling! Which is gonna be SUPER helpful since I plan on doing at least 2 playthroughs of this game. (Original route, Modified route, and then maybe Bad End Route)

Thank you so much for your patience and help with this! I really would have been fine without it but thanks to you, I can enjoy this game even more.


RE: Growlanser: Wayfarer of Time - DaveTheMan - 07-18-2020 04:38 AM

I just Tried on the Most Recent Version Standalone and Retroarch Core and the Text Starts Normal than gets all messed up Quickly.

Screenshot's Showing what Happens:

https://ibb.co/Lg27w3f
https://ibb.co/HVKPpQz
https://ibb.co/9qp4NGd

How can I fix this?


RE: Growlanser: Wayfarer of Time - BanhCanh - 12-01-2020 02:09 PM

EDIT2 : Actually ignore this post, it seems like I had "install data on SD" enabled somehow, must have missclicked or something. I had a growing file in the SAVEDATA folder (around 300mb) and deleting it fixed that..

Hello, I have none of the issues previously mentionned. The fonts/texts one was fixed by following the recommendations posted in this thread.

But I noticed that (at least) on scene doesn't show correctly in game, it looks like incorrect texture are loaded or whatever (as you can see in the screenshots). I disabled both textures replacement and dump, resetted every settings to default and tried using the lastest version available as well as the lastest build v1.10.3-1272-gc0c2bfb29 ( 2020-12-01 09:20:13 ) on Windows 10 using all graphic backend available. I also did a quick test on the android version on a Mi8. All had same results.

https://imgur.com/a/nX4HUCb

The "correct" screenshot is not actually mine but one I found in a post earlier in this thread. https://forums.ppsspp.org/showthread.php?tid=2260&pid=114327#pid114327
It seems he had a different issue but I'm wondering if it's related...
I can try reproducing things on my PSP but I'm pretty sure it won't look like what I see in PPSSPP because well, I don't see the angel in it Tongue
EDIT : I loaded the same save, did the same thing, but on a real PSP it works perfectly (it shows the angel).

This is not gamebreaking and other than that it looks like it's perfectly playable so far..
I'm using NPEH00137, the european version. Converted to ISO.
Thanks