forums.PPSSPP.org
v1.3 OpenGL Completely broken - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: General Discussion and Announcements (/forumdisplay.php?fid=2)
+--- Thread: v1.3 OpenGL Completely broken (/showthread.php?tid=21233)



v1.3 OpenGL Completely broken - cammelspit - 09-29-2016 07:15 PM

Hi, I would just like to say that 1.3 seems like a good version. I have two problems and I cannot find anything on google that relates to what is happening to me so here goes.

1: I use PPSSPP on Windows 10, I had it set to use DX9 and it works fine except for the fact that the entire image is totally washed out. Like there is some kind of bloom effect on literally everything. Not one option makes any difference at all. Is there any way to fix this over bright issue?

2: So I decided to set it to OpenGL. This was a massive mistake. OpenGL is 100% borked. Once a game runs for longer than about 30 seconds massive graphical glitches happen. This carries on into Windows and I have to shutdown my PC, NOT restart, and wait a good 30 seconds before I can power it back on. Every time, every game I have tried. I have used OpenGL on older versions before and it worked fine but now, it is just not usable. Is there any way to keep this from happening?

3: I then tried Vulkan. I mean, Vulkan is experimental but it couldn't be worse than OpenGl right? Unfortunately, the entire screen turned to a garbled mess and the whole PC froze forcing me to do a hard reset. I just won't use Vulkan, no problem there but if it is that bad, probably should be relegated to a WIP PR and not be merged into the main branch where users might want to try it.

My Windows install is less than 72 hours old since I had an HD failure and had to get a new OS SSD.

Is there anything troubleshooting you guys would like me to do? My specs follow...

Core i5-6600K @~4.5Ghz | R9380 4G @~1010Mhz | Windows 10 Pro x64 | Samsung 850Pro SSD @512GB | GPU Driver v16.9.2 Also cleaned the drivers and tried 16.7.3 as well

Any help would be appreciated, Thanks in advance!


RE: v1.3 OpenGL Completely broken - [Unknown] - 09-29-2016 08:48 PM

Check if there are driver updates. Most likely you have an old and very buggy video card driver that needs to be updated.

-[Unknown]


RE: v1.3 OpenGL Completely broken - cammelspit - 09-29-2016 08:58 PM

(09-29-2016 08:48 PM)[Unknown] Wrote:  Check if there are driver updates. Most likely you have an old and very buggy video card driver that needs to be updated.

-[Unknown]

Windows install is less than 72 hours old and I was using the latest version, which is a hotfix release. I then uninstalled it, used the GPU driver cleaner and installed the last non-hotfix version and it behaved exactly the same. GPU drivers can safely be ruled out as well as chipset or other drivers since they are the latest release as of this last Monday.


RE: v1.3 OpenGL Completely broken - [Unknown] - 09-30-2016 12:11 AM

Well, if this happens:

Quote:Once a game runs for longer than about 30 seconds massive graphical glitches happen. This carries on into Windows and I have to shutdown my PC, NOT restart, and wait a good 30 seconds before I can power it back on.

Then you have to face that one of these things is malfunctioning:

1. Your GPU driver
2. Your operating system (Windows)
3. Your physical video card itself
4. Your physical motherboard, RAM, or CPU, etc.

It could just be a cooling problem. Maybe something is causing your video card to overheat and your fan / cooling system isn't working properly.

PPSSPP v1.3 is working for a lot of people with OpenGL, and a ton of different systems. While it's true that generally, Windows 10 video drivers are still very buggy, if the latest version is still doing that, I would suspect the hardware.

-[Unknown]


RE: v1.3 OpenGL Completely broken - TkSilver - 09-30-2016 12:37 AM

You can test your video card by un installing it and clearing out it's drivers and seeing if the integrated gpu on the 6600k also crashes

Though to be fair the very first thing I would test is removing your overclocks and see if it is a system stability issue.


Also download https://www.microsoft.com/en-us/download/details.aspx?id=35 the full directx 9 if you have not already this install of Windows 10 it makes a massive compatibility difference.


RE: v1.3 OpenGL Completely broken - cammelspit - 09-30-2016 03:10 AM

I will try it but I ran a burn in for 6 hours CPU and GPU at the same time right after installing so it is undoubtedly something specific to PPSSPP and more specifically something that has changed between the last time I used it 1.2.2 and now.

BTW, I tested 1.2.2 just now and it works perfectly without any issues of any kind in OpenGL so it is surely something that has changed since then that is the root cause. I went on ahead and enabled the server logging thing in the system settings. Direct3D still has the insane bloom lighting issue though so that has probably been a long standing issue. I used to always use OpenGL so that is probably why I never noticed.

Is there any kind of verbose logging or debug build of PPSSPP that I can run for you? Would a video be helpful to you in any way? Should I spend the time to bisect the revisions to find the exact change that caused this? Because it seems to me you don't believe me that I have already done all the troubleshooting that can be done to rule out my PC as being the problem and I won't take the time to do a bisection if no one is going to take it seriously. I don't mean to be an ass or anything but I am calling it as I see it. I have many years of experience with PCs and especially Windows so I always try to rule out my own hardware and software before I report anything. Seriously though, would a bisection be useful?

Alright, I just disabled my DGPU and the intel one worked. I then tried disabling the overclock and it worked. I then turned the overclock and the intel worked. Then I remembered something about AMD adding power saving features for the RX480. Now, I have a 380 BUT after doing some digging it seems the 300 series is also affected by the power management changes for the 400 series cards. On a lark, I just decided to give my GPU a little extra power, and that worked... So, it seems it is AMDs fault after all and to get a driver that worked out of the box, I would have had to go back literally months to find one from before the 480 released. As an FYI, My GPU is not overclocked, this is the stock from the factory speed for my GPU 1010Mhz but it is not the "standard" clock of an older model 380 so my guess is that the driver just wasn't giving it enough power thinking it should be clocked lower. I won't retract my previous post but I am willing to admit when my assumption of it being exclusively a PPSSPP problem was wrong. More power for the 300 series cards, this is what was needed here.

Thank you for at least taking the time to talk to me. I wouldn't have been so bound and determined to find the problem to 'prove' my hardware was ok if you hadn't. Maybe this should be something that should be made known to AMD 300 and 400 series users in case this ever happens to anyone else again?

Anyways, thanks again, now I think I am going to go play some games for a bit. Wink

I lied again... It takes longer to happen now but it is still happening. I will do some more troubleshooting and let you know. For now I will try and just keep playing on 1.2.2 and see how far I can get, IF it happens at all. Now this is really getting annoying... Sad


RE: v1.3 OpenGL Completely broken - cammelspit - 09-30-2016 04:20 AM

For what it is worth I have found two things.

1: The too bright thing is the hardware transform. I must have missed it when I was going through the options before but this makes PPSSPP playable with Direct3D.

2: It turns out it is one specific effect in GTSSAC that causes the problems for OpenGL. I am always ready to blame AMD for their utterly CRAP OpenGL support and I hope Vulkan support on PPSSPP is worked out sooner than later so I can finally ditch OpenGL and go to something properly supported on AMD cards.

3: 1.2.2 does still do it but I have to play all the way through to the third level to find the first occurrence of an effect that causes the OpenGL issue I mentioned. I am still not happy but I can at least, for the moment, play games on it. My brother has a 270X in his machine so I will make him test it out and see if his does it too, if it does then it is drivers and there isn't anything users can do.

I will update this post later on if I can find anything else out.