forums.PPSSPP.org
Xyanide: Resurrection - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Xyanide: Resurrection (/showthread.php?tid=1984)



Xyanide: Resurrection - sfageas - 03-24-2013 09:03 PM

Genre : 3D Space shooter
Region : EU
Format : ISO
Version : v0.7-244-g3f935fd
Game ID : ULES00634
OS : Win
Compatibility : Menus
Notes : This one is acting really weird,example: when i test a new build and load this one for first time it goes on menus but after a while it looks like its freezing but its not!It loads a frame every minute Smile i think its caused by the background video on menu(which doesnt display) The second time i load the game emulator crash after a couple of seconds

Log after second time load:
Code:
http://pastebin.com/izNX2720
and a debug pic with game on menu


RE: Xyanide: Resurrection - sfageas - 06-02-2013 03:56 AM

Console spam this


RE: Xyanide: Resurrection - sfageas - 07-03-2013 06:40 PM

Now crashing after new game,some invalid addresses

Log :
Code:
http://www.mediafire.com/?s19aacuumbi53mc



RE: Xyanide: Resurrection - sum2012 - 01-29-2014 09:31 AM

v0.9.6-683
Now freezee after video (scempg problem)
Attach info and scempeg debug log to notice log.
full of
DecodeThread I[ME]: HLE\sceMpeg.cpp:1174 Audio end reach. pts: 90000 dts: 270270


RE: Xyanide: Resurrection - [Unknown] - 01-29-2014 02:43 PM

In this case, the audio seems to end way early, and the game keeps trying to pull the audio using sceMpegGetAtracAu. Hmm... at this point the available size is 0.

What if you comment out the audio end reach stuff?

-[Unknown]


RE: Xyanide: Resurrection - sum2012 - 01-29-2014 10:50 PM

Yes,fixed - ppsspplogm-ok.zip

Change to this work too - ppsspplogm2-ok.zip
Make 2 games happy Smile
Code:
if (ctx->mediaengine->IsNoAudioData() || mpegRingbuffer.packetsFree + 4 >= mpegRingbuffer.packets) {
          mpegRingbuffer.packetsFree = mpegRingbuffer.packets;
          Memory::WriteStruct(ctx->mpegRingbufferAddr, &mpegRingbuffer);
      }



RE: Xyanide: Resurrection - GamerzHell9137 - 12-29-2014 11:08 AM

Game works fine in newer builds now. Can be moved to playable.


RE: Xyanide: Resurrection - vnctdj - 12-29-2014 10:45 PM

Moved Smile


RE: Xyanide: Resurrection - Rekrul - 05-31-2018 06:15 AM

Doesn't work in any version later than 1.2.2. It boots, you can start a new game, but it never goes past the level intro where you're flying down a tunnel.


RE: Xyanide: Resurrection - [Unknown] - 05-31-2018 10:04 PM

What's the first git build that stopped working and the last one that worked fine?

-[Unknown]


RE: Xyanide: Resurrection - Rekrul - 06-01-2018 01:52 AM

(05-31-2018 10:04 PM)[Unknown] Wrote:  What's the first git build that stopped working and the last one that worked fine?
Unfortunately I can't tell you that. The list of "all" builds only goes back as far as 1.3-553 and the only earlier git versions I have is 1.2.2-786. For what it's worth, it works in 1.2.2, but does not work in 1.2.2-786.

If you can point me to somewhere where I can download the earlier git versions, I'll be happy to test it further.


RE: Xyanide: Resurrection - [Unknown] - 06-01-2018 06:08 AM

Hmm. It doesn't look like they're still there. There's a lot of changes in that range, although some was IR which is probably unrelated.

https://github.com/hrydgard/ppsspp/compare/v1.2.2...v1.2.2-786-gfa3f219fd

Here's some builds that would help narrow it down a good bit:

v1.2.2-358-g5309d825c: https://drive.google.com/open?id=1YIRjvkbmeZN0b_j3Uw3XK20YGBX8VI88
v1.2.2-568-g63e730446: https://drive.google.com/open?id=1SXYTH4-VgpUUIt0i-vR7u45HDGo6RJ7E (if v1.2.2-358-g5309d825c works)
v1.2.2-176-gb0329e810: https://drive.google.com/open?id=1bllvQBvDuNPFccR4ZabUQoIEpQwEz1Ox (if v1.2.2-358-g5309d825c fails)

-[Unknown]


RE: Xyanide: Resurrection - Rekrul - 06-01-2018 10:11 AM

(06-01-2018 06:08 AM)[Unknown] Wrote:  Here's some builds that would help narrow it down a good bit:
I should have mentioned that I have an older system that's still 32-bit. Unfortunately I can't use the copies you uploaded. Sad


RE: Xyanide: Resurrection - [Unknown] - 06-02-2018 04:24 AM

We're narrowing it down a bit here with the 64-bit ones:
https://github.com/hrydgard/ppsspp/issues/8526#issuecomment-393859735

-[Unknown]