forums.PPSSPP.org
Final Fantasy IV : The complete collection - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Final Fantasy IV : The complete collection (/showthread.php?tid=1971)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37


RE: Final Fantasy IV : The complete collection - rascopeeko - 11-26-2013 12:04 AM

System: Ubuntu 13.10, AMD64, using libsdl1.2-dev 1.2.15-5ubuntu2
Versions tested (same behavior in both):
v0.9.5-213-g2fe898c (angelXwind build)
Nov 23rd Github master @ 132fe47c7d

I am getting a segfault at Mist village when Rydia first summons Titan. I've discovered that enabling Low Quality Spline/Bezier Curves fixes the issue (I saw TesselateBezierPatch() in the backtrace).

I am posting this here in hopes it will be useful to the developers or anyone else seeing this problem... I can provide save/state files if needed, but it seems to be pretty easy to reproduce.

Output was:

Quote:44:33:114 MyThread-Sou I[COMMON]: /home/rossc/git/ppsspp/Core/SaveState.cpp:376 Loading state from /home/rossc/.config/ppsspp/PSP/PPSSPP_STATE/NPJH50414_1.01_1.ppst
44:33:114 MyThread-Sou I[COMMON]: /home/rossc/git/ppsspp/Common/ChunkFile.cpp:163 ChunkReader: Loading /home/rossc/.config/ppsspp/PSP/PPSSPP_STATE/NPJH50414_1.01_1.ppst
44:33:271 MyThread-Sou I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:1472 Destroying FBO for 00088000 : 480 x 272 x 3
44:33:271 MyThread-Sou I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:1472 Destroying FBO for 04154000 : 256 x 256 x 0
44:33:271 MyThread-Sou I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:1472 Destroying FBO for 00000000 : 480 x 272 x 3
44:33:277 MyThread-Sou I[COMMON]: /home/rossc/git/ppsspp/Common/ChunkFile.h:600 ChunkReader: Done loading /home/rossc/.config/ppsspp/PSP/PPSSPP_STATE/NPJH50414_1.01_1.ppst
44:33:290 MyThread-Mai I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:752 Creating FBO for 00000000 : 480 x 272 x 3
44:33:303 MyThread-Mai I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:752 Creating FBO for 04154000 : 256 x 256 x 0
44:33:303 MyThread-Mai W[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:762 FBO sharing existing depthbuffer (unsupported), 04154000/00110000 and 00000000/00110000
44:33:359 idle0 I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:1472 Destroying FBO for 00000000 : 480 x 272 x 3
44:33:359 idle0 I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:1472 Destroying FBO for 04154000 : 256 x 256 x 0
44:33:369 MyThread-Mai I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:752 Creating FBO for 00088000 : 480 x 272 x 3
44:33:373 MyThread-Mai I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:752 Creating FBO for 04154000 : 256 x 256 x 0
44:33:373 MyThread-Mai W[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:762 FBO sharing existing depthbuffer (unsupported), 04154000/00110000 and 00088000/00110000
44:33:401 MyThread-Mai I[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:752 Creating FBO for 00000000 : 480 x 272 x 3
44:33:401 MyThread-Mai W[SCEGE]: /home/rossc/git/ppsspp/GPU/GLES/Framebuffer.cpp:762 FBO sharing existing depthbuffer (unsupported), 00000000/00110000 and 00088000/00110000
Segmentation fault (core dumped)

Coredump backtrace:

Quote:(gdb) backtrace
#0 __memcpy_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:2336
#1 0x0000000000973401 in CopyQuad(unsigned char*&, SimpleVertex const*, SimpleVertex const*, SimpleVertex const*, SimpleVertex const*) ()
#2 0x00000000009768f2 in TesselateBezierPatch(unsigned char*&, int&, int, int, BezierPatch const&, unsigned int) ()
#3 0x00000000009771b2 in TransformDrawEngine::SubmitBezier(void*, void*, int, int, GEPatchPrimType, unsigned int) ()
#4 0x000000000096096a in GLES_GPU::ExecuteOpInternal(unsigned int, unsigned int) ()
#5 0x00000000009601fd in GLES_GPU::FastRunLoop(DisplayList&) ()
#6 0x00000000009aa54e in GPUCommon::InterpretList(DisplayList&) ()
#7 0x00000000009aac5e in GPUCommon::ProcessDLQueueInternal() ()
#8 0x00000000009aaa45 in GPUCommon::ProcessEvent(GPUEvent) ()
#9 0x00000000009602cc in GLES_GPU::ProcessEvent(GPUEvent) ()
#10 0x00000000008d6dac in ThreadEventQueue<GPUInterface, GPUEvent, GPUEventType, (GPUEventType)0, (GPUEventType)8, (GPUEventType)7>::RunEventsUntil(unsigned long long) ()
#11 0x00000000008d6b5a in ThreadEventQueue<GPUInterface, GPUEvent, GPUEventType, (GPUEventType)0, (GPUEventType)8, (GPUEventType)7>::ScheduleEvent(GPUEvent) ()
#12 0x00000000009aab70 in GPUCommon::ProcessDLQueue() ()
#13 0x00000000009a9ba2 in GPUCommon::EnqueueList(unsigned int, unsigned int, int, PSPPointer<PspGeListArgs>, bool) ()
#14 0x000000000092f4bd in sceGeListEnQueue(unsigned int, unsigned int, int, unsigned int) ()
#15 0x00000000009308ce in void WrapU_UUIU<&(sceGeListEnQueue(unsigned int, unsigned int, int, unsigned int))>() ()
#16 0x000000000091ab8c in CallSyscallWithoutFlags(HLEFunction const*) ()
#17 0x0000000041f8d54b in ?? ()
#18 0x0000000000000000 in ?? ()

Cheers,
Ross


RE: Final Fantasy IV : The complete collection - MidniteAssassin - 11-26-2013 03:43 AM

I just tested that low quality option and it's not crashing the emulator when Alarm is used anymore. Only checked on 32bit Windows version.


RE: Final Fantasy IV : The complete collection - Acnologia - 11-26-2013 10:46 AM

I have a problem,when I enter the underworld i get stuck between the dwarfs and the airships,and in that moment the screen gets all messed up,shortly after that black screen and i cant continue...hope you guys have some kind of solution for this...thanks in advance


RE: Final Fantasy IV : The complete collection - Acnologia - 11-26-2013 06:16 PM

(11-20-2013 07:49 AM)DVendy Wrote:  
(11-19-2013 08:41 PM)Dragonslayer1 Wrote:  
(11-19-2013 07:38 AM)DVendy Wrote:  Yay, I've finally fixed it!!., . Big Grin
I used the previous build v0.9.1-1965-g027ba31 as solarmystic said.,
u can download it here.,
http://www.ppsspp.org/downloads.html#devbuilds

cheers., Big Grin Big Grin Big Grin

I can't seem to " Load my game" .. when I try to load the save file, it says: "Cannot load file." D: plz help

Here's what I do :
*let's say u r using version 0.9.5

-download the build v0.9.1-1965-g027ba31
-extract it somewhere
-play the game (FF IV) from 0.9.1 version
-Just play a new game
-exit
-Copy folder SAVEDATA from ..\ppsspp\memstick\PSP from your 0.9.5 version
-paste to 0.9.1 version (replace) in the same folder
-play 0.9.1 version, then u can load the game
-after crash, save the game just outside dwarf castle
-exit
-now move the SAVEDATA again from 0.9.1 to 0.9.5
-solved...
Big Grin
basically, we are using old version only to get past the freeze part., Big Grin

This doesn't work for me,cant load my save state...dammit,i wanted to play this gme so badly...


RE: Final Fantasy IV : The complete collection - rascopeeko - 11-28-2013 02:48 AM

(11-26-2013 06:16 PM)Acnologia Wrote:  This doesn't work for me,cant load my save state...dammit,i wanted to play this gme so badly...

I don't think the save STATE files are compatible between these versions... but game save data should be, are you copying over your SAVEDATA folder and trying to load game from within the FFIV game menu..?

You may need to go to load game, and say OK to create savedata, then you'll get an error that it can't load save data - this is fine, quit out of PPSSPP and then copy over the SAVEDATA folder as other people said... you should then be able to fire it back up load up your save... Smile

Good luck,
Ross


RE: Final Fantasy IV : The complete collection - rascopeeko - 11-28-2013 04:17 AM

For anyone else trying to get past the underworld FMV issue under Linux, I grabbed build v0.9.1-1437-g930621b (32bit), and was able to run that using wine 1.7.6 (installable on Ubuntu 13.10, see WineHQ).

Have fun!
Ross


RE: Final Fantasy IV : The complete collection - Dragonslayer1 - 11-28-2013 05:22 PM

(11-28-2013 02:48 AM)rascopeeko Wrote:  
(11-26-2013 06:16 PM)Acnologia Wrote:  This doesn't work for me,cant load my save state...dammit,i wanted to play this gme so badly...

I don't think the save STATE files are compatible between these versions... but game save data should be, are you copying over your SAVEDATA folder and trying to load game from within the FFIV game menu..?

You may need to go to load game, and say OK to create savedata, then you'll get an error that it can't load save data - this is fine, quit out of PPSSPP and then copy over the SAVEDATA folder as other people said... you should then be able to fire it back up load up your save... Smile

Good luck,
Ross

Ok, so my problem is that i cant save... when I try to I get the errorcode: 80110327 ... I've been using the save state all this time

(11-28-2013 05:22 PM)Dragonslayer1 Wrote:  
(11-28-2013 02:48 AM)rascopeeko Wrote:  
(11-26-2013 06:16 PM)Acnologia Wrote:  This doesn't work for me,cant load my save state...dammit,i wanted to play this gme so badly...

I don't think the save STATE files are compatible between these versions... but game save data should be, are you copying over your SAVEDATA folder and trying to load game from within the FFIV game menu..?

You may need to go to load game, and say OK to create savedata, then you'll get an error that it can't load save data - this is fine, quit out of PPSSPP and then copy over the SAVEDATA folder as other people said... you should then be able to fire it back up load up your save... Smile

Good luck,
Ross

Ok, so my problem is that i cant save... when I try to I get the errorcode: 80110327 ... I've been using the save state all this time

OK I GOT IT! To whoever had the same error as me! Just go with the flow, press X (o on psp) to get rid of the message, then another message come's up, saying it cant save. Than save anyway inthe game. When you go to your SAVEDATA folder you can see a new folder named: ULUS10560FFIV, this is now your save file, Copy that to the v0.9.1 emulator, watch the cutscene and save there again.

Thanks to all who helped <33


RE: Final Fantasy IV : The complete collection - DarkerSentience - 11-29-2013 02:05 AM

A few common issues that I've read about or experienced as I've played through FF4 Complete. I am currently using the 32 bit 9.5 version of ppsspp.

1. The Summon crash:
To anyone having the ppsspp crash take place when an enemy does a summon. I didn' start seeing that error until I went into the Tower of Babil in the Overworld. One enemy, the Sorcerer, will try to summon creatures if you kill his companion Ghost Knights. When he performed the summon, ppsspp would crash to desktop. To solve this, I turned on Low quality splines and bezier curves (speed up) and ppsspp stopped crashing when the Sorecerer performed a summon. Based upon this evidence, maybe enabling this option will help with other enemies that summon.

2. The Mist Dragon crash:
My copy of ppsspp would crash when I was fighting the Mist Dragon. The second the Mist Dragon tried to transform into mist, the program would CTD. To get around this issue, I turned off the following options. I set Mode to Non-buffered rendering. I also turned off Hardware transform. This seemed to do the trick and I've had no more problems of that nature.

3. Glitchy FMVs.
From the FMV where the Enterprise crashes, I started having problems where the FMV glitches out and the screen goes black. To solve this for now, I downloaded the last version of 9.1 off the website. I just copy the entire Memcard folder into the 9.1 directory and load my game. Let the game play through the FMV, save, and then copy the Memcard folder back to the 9.5 directory. Takes the guess work out of trying to make sure I've moved all the corresponding files.

Hope these suggestions help those who are having trouble.


RE: Final Fantasy IV : The complete collection - rascopeeko - 11-29-2013 02:08 AM

Ack, so after getting past the airship underworld FMV, had the same issue appear again when trying to exit the underworld after leaving the tower of babil... super frustrating.. spent an hour grinding levels and lost it all Sad

Have we opened an issue on github for this? I see issues:

3422
4617
4132
2863

All of which seem to just be minor graphical issues, which I am sure we can all live with... but this hang is a major problem, and reverting to a previous build to get past it isn't really a workaround...

If anyone knows of this being a known core issue (possibly affects other games and not just FFIV), let me know..


RE: Final Fantasy IV : The complete collection - Henrik - 11-29-2013 10:46 AM

Feel free to file an issue about this, you are right that it seems like a serious bug.


RE: Final Fantasy IV : The complete collection - rascopeeko - 12-01-2013 03:57 AM

(11-29-2013 10:46 AM)Henrik Wrote:  Feel free to file an issue about this, you are right that it seems like a serious bug.

4693

I just quickly want to say a huge thanks to you and the whole team Henrik, you guys truly are wizards and your hard work on PPSSPP is very much appreciated! Big Grin

Cheers,
Ross


RE: Final Fantasy IV : The complete collection - Acnologia - 12-01-2013 06:03 PM

(11-28-2013 05:22 PM)Dragonslayer1 Wrote:  
(11-28-2013 02:48 AM)rascopeeko Wrote:  
(11-26-2013 06:16 PM)Acnologia Wrote:  This doesn't work for me,cant load my save state...dammit,i wanted to play this gme so badly...

I don't think the save STATE files are compatible between these versions... but game save data should be, are you copying over your SAVEDATA folder and trying to load game from within the FFIV game menu..?

You may need to go to load game, and say OK to create savedata, then you'll get an error that it can't load save data - this is fine, quit out of PPSSPP and then copy over the SAVEDATA folder as other people said... you should then be able to fire it back up load up your save... Smile

Good luck,
Ross

Ok, so my problem is that i cant save... when I try to I get the errorcode: 80110327 ... I've been using the save state all this time

(11-28-2013 05:22 PM)Dragonslayer1 Wrote:  
(11-28-2013 02:48 AM)rascopeeko Wrote:  
(11-26-2013 06:16 PM)Acnologia Wrote:  This doesn't work for me,cant load my save state...dammit,i wanted to play this gme so badly...

I don't think the save STATE files are compatible between these versions... but game save data should be, are you copying over your SAVEDATA folder and trying to load game from within the FFIV game menu..?

You may need to go to load game, and say OK to create savedata, then you'll get an error that it can't load save data - this is fine, quit out of PPSSPP and then copy over the SAVEDATA folder as other people said... you should then be able to fire it back up load up your save... Smile

Good luck,
Ross

Ok, so my problem is that i cant save... when I try to I get the errorcode: 80110327 ... I've been using the save state all this time

OK I GOT IT! To whoever had the same error as me! Just go with the flow, press X (o on psp) to get rid of the message, then another message come's up, saying it cant save. Than save anyway inthe game. When you go to your SAVEDATA folder you can see a new folder named: ULUS10560FFIV, this is now your save file, Copy that to the v0.9.1 emulator, watch the cutscene and save there again.

Thanks to all who helped <33


Thank you guys,ingame load worked!!!


RE: Final Fantasy IV : The complete collection - TheDax - 12-08-2013 10:20 PM

Moved to In-game, since the game is having FMV hang issues.


RE: Final Fantasy IV : The complete collection - Infinity Gems - 12-16-2013 09:24 PM

Game is working so far pretty fluidly on my LG G2 android phone. Only two hiccups I've had where I had to go on my pc with the 9.1 version is going underground and the game freezing at the battle between the tanks and the red wings where you crash, and leaving underground and cid blowing himself up. At the Giant of Babil and things have come along smoothly. There are a few slowdowns, especially during some summons and bosses deteriorating.


RE: Final Fantasy IV : The complete collection - Pelador - 12-19-2013 02:20 AM

The game works great on my pc. My only issue is very minor. The sprites have green outlines when in towns and villages. I've clicked every box in the emulator settings and the only one that seems to remove it is the software rendering option. However that causes so much lag that the game is unplayable. Are their any other solutions I could try?

I have an i7 3770k, 8gb RAM and a Radeon HD 6870. I'm using a 64 bit operating system and the 64 bit emulator. Not that that should have much to do with a minor graphical issue I should think.