forums.PPSSPP.org
Final Fantasy IV : The complete collection - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Final Fantasy IV : The complete collection (/showthread.php?tid=1971)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37


RE: Final Fantasy IV : The complete collection - [Unknown] - 07-03-2013 07:07 AM

Unfortunately, JPCSP does not create saves properly for this game. The priority is compatibility with the PSP, not with JPCSP, especially since it can affect the game's ability to save and load properly.

Something that might work as a workaround: create a save (e.g. using PPSSPP) from scratch, and then replace the files EXCEPT any named PARAM.SFO, ICON0.PNG, ICON1.PNG, or SND0.AT3 with the files from the savedata you want to load. Then, try to load it with PPSSPP. I don't know if this will work, but it may. This will not create a save that can load on a real PSP, but once you save in PPSSPP (with the encrypt option enabled), it should load on a real PSP.

If you're having problems saving try renaming the SAVEDATA folder to SAVEDATA_backup. Also make sure that the SAVEDATA folder isn't somewhere that requires Administrator access to modify. Red flag: if you get any warnings when trying to rename it, it's a problem.

-[Unknown]


RE: Final Fantasy IV : The complete collection - StevieJ101 - 07-03-2013 10:28 AM

I'm not sure if anyone has had this problem, but I don't know how to fix it.

I'm doing this on PC and I'm using the latest version of ppsspp (v0.8.1-223-g4ab8b76) and when it starts up, it gets past the Square Enix screen, then it goes to a black screen with a blue crystal in the bottom right corner. I've waited for ages and nothing happends and I've tried different versions of ppsspp but I always just get to the same point.

Any help would be greatly appreciated! Smile


RE: Final Fantasy IV : The complete collection - Terezar - 07-03-2013 02:04 PM

(07-03-2013 10:28 AM)StevieJ101 Wrote:  I'm not sure if anyone has had this problem, but I don't know how to fix it.

I'm doing this on PC and I'm using the latest version of ppsspp (v0.8.1-223-g4ab8b76) and when it starts up, it gets past the Square Enix screen, then it goes to a black screen with a blue crystal in the bottom right corner. I've waited for ages and nothing happends and I've tried different versions of ppsspp but I always just get to the same point.

Any help would be greatly appreciated! Smile

I have found that some games do that if I have the buffered rendering setting turned off, so you might want to check that setting.


RE: Final Fantasy IV : The complete collection - StevieJ101 - 07-03-2013 04:10 PM

(07-03-2013 02:04 PM)Terezar Wrote:  
(07-03-2013 10:28 AM)StevieJ101 Wrote:  I'm not sure if anyone has had this problem, but I don't know how to fix it.

I'm doing this on PC and I'm using the latest version of ppsspp (v0.8.1-223-g4ab8b76) and when it starts up, it gets past the Square Enix screen, then it goes to a black screen with a blue crystal in the bottom right corner. I've waited for ages and nothing happends and I've tried different versions of ppsspp but I always just get to the same point.

Any help would be greatly appreciated! Smile

I have found that some games do that if I have the buffered rendering setting turned off, so you might want to check that setting.

Thanks for the suggestion, but I tried it and it still gets stuck at the same point. I've tried a few other combinations of turning options on and off but it always gets stuck at the black screen with the blue crystal, while loading the menu. I was wondering what iso you guys downloaded, because I've tried different emulators and they all get stuck at the same point, so could it possibly be the iso file? Thanks Smile


RE: Final Fantasy IV : The complete collection - Krainz - 07-03-2013 08:43 PM

Turn off the buffered rendering setting and then reset the game.

Tried to start a fresh new game in PPSSPP and save: [Image: 9e5wd6k.jpg]
[Image: UPA1l1X.jpg]


RE: Final Fantasy IV : The complete collection - [Unknown] - 07-03-2013 09:29 PM

Try the game on an actual PSP and you'll see it shows an error like that too. The emulator doesn't patch bugs in games, it emulates a PSP. That means bugs that happen on the PSP will (hopefully) occur in PPSSPP as well.

-[Unknown]


RE: Final Fantasy IV : The complete collection - chrisDLCTS - 07-03-2013 09:51 PM

using ATT galaxy s2, and having the text issue like some others have. text windows are completely blank. anything I can do to fix this???


RE: Final Fantasy IV : The complete collection - Krainz - 07-03-2013 10:55 PM

(07-03-2013 09:51 PM)chrisDLCTS Wrote:  using ATT galaxy s2, and having the text issue like some others have. text windows are completely blank. anything I can do to fix this???

Toggle buffered rendering.

(07-03-2013 09:29 PM)[Unknown] Wrote:  Try the game on an actual PSP and you'll see it shows an error like that too. The emulator doesn't patch bugs in games, it emulates a PSP. That means bugs that happen on the PSP will (hopefully) occur in PPSSPP as well.

-[Unknown]
So what's the solution? Play only on JPCSP?


RE: Final Fantasy IV : The complete collection - StevieJ101 - 07-03-2013 11:16 PM

(07-03-2013 04:10 PM)StevieJ101 Wrote:  
(07-03-2013 02:04 PM)Terezar Wrote:  
(07-03-2013 10:28 AM)StevieJ101 Wrote:  I'm not sure if anyone has had this problem, but I don't know how to fix it.

I'm doing this on PC and I'm using the latest version of ppsspp (v0.8.1-223-g4ab8b76) and when it starts up, it gets past the Square Enix screen, then it goes to a black screen with a blue crystal in the bottom right corner. I've waited for ages and nothing happends and I've tried different versions of ppsspp but I always just get to the same point.

Any help would be greatly appreciated! Smile

I have found that some games do that if I have the buffered rendering setting turned off, so you might want to check that setting.

Thanks for the suggestion, but I tried it and it still gets stuck at the same point. I've tried a few other combinations of turning options on and off but it always gets stuck at the black screen with the blue crystal, while loading the menu. I was wondering what iso you guys downloaded, because I've tried different emulators and they all get stuck at the same point, so could it possibly be the iso file? Thanks Smile

Nevermind, I downloaded a different iso file and it works now! Thanks for the help.


RE: Final Fantasy IV : The complete collection - chrisDLCTS - 07-04-2013 03:49 AM

yea buffered rendering didn't do anything. I'm running most current GIT build.


RE: Final Fantasy IV : The complete collection - [Unknown] - 07-04-2013 04:37 AM

(07-03-2013 10:55 PM)Krainz Wrote:  So what's the solution? Play only on JPCSP?

If you must use a JPCSP save, and what I described didn't help, yes. Otherwise, you will get an error message from the game (exactly as you do on the PSP) the first time you see the save/load screen, but saving will work. Loading a PSP or PPSSPP save will also work.

If that doesn't happen, most likely you have some issue with your file permissions or local software interfering with file access.

-[Unknown]


RE: Final Fantasy IV : The complete collection - chrisDLCTS - 07-04-2013 05:45 AM

sorry for the double post, but buffered rendering, whether on or off, does not fix the text widow issue on the most current GIT build for me. samsung galaxy s2. any tips would be helpful please


RE: Final Fantasy IV : The complete collection - the_randomizer - 07-04-2013 03:22 PM

So, the game has issues with native saves and we need to use save states?


RE: Final Fantasy IV : The complete collection - [Unknown] - 07-04-2013 06:07 PM

FWIW, here is the exact sequence of events. I've marked the ones that happen on an actual PSP for your information.

1. Game tells you it has an autosave feature. You'll have to bare with it, and press X to confirm this message.
** This is also required on an actual PSP with latest firmware.

3. Get somewhere you can save from a new game, and hit save in the menu. The game tells you there is no savedata and you need to create it. Bare with it. Just select Yes.
** This is also required on an actual PSP with latest firmware.

4. After selecting yes, you see an error code (80110327.) Again, bare with it, just press O.
** This is also required on an actual PSP with latest firmware.

5. The game tells you, "Save data failed to load." Press X. If it's too much for you, take a break, cool off. You're almost there.
** This is also required on an actual PSP with latest firmware.

6. Now you can select a slot and save. It will tell you "Save complete."
** This is also required on an actual PSP with latest firmware.

I realize seeing this many errors in the normal flow of a game is unusual. But it's the game, all of the above things happen on a PSP as you can see. If the emulator wasn't doing what the PSP does, even if it meant less errors, it would be a bug in the emulator. Maybe someone has written a romhack to change this if it bothers people so much.

I'm not sure how many other ways I can explain that these things all happen on the actual PSP. If you don't believe me, try the game on a PSP yourself. Make sure to delete the savedata first, since the above happens only the first time (which is also true of PPSSPP.)

If you see something other than the above, you either have a file permission issue (e.g., you've put the emulator in Program Files and the memory stick is only writable by administrator there), a bad or hacked rip, some bizarre platform specific issue, or possibly a problem with some specific region's edition of this game.

-[Unknown]


RE: Final Fantasy IV : The complete collection - StevieJ101 - 07-06-2013 03:45 PM

I was wondering if anyone has found a fix for the weird lighting effects when a 3D spell is used, for example Thunder? I've tried changing a few options, but nothing seems to help, Thanks.