forums.PPSSPP.org
Phantasy Star Portable - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Phantasy Star Portable (/showthread.php?tid=1622)

Pages: 1 2 3 4 5 6 7 8 9


Phantasy Star Portable - VIRGIN KLM - 03-05-2013 11:18 AM

Looks that the game finally works!

I'd call it playable but it has 2 pretty annoying bugs, one is that the speech text are missing and the second is that depending on the angle of your camera geometry pops in and out. Ah! Plus for some reason the game is double speed! XD

Images:
http://img17.imageshack.us/img17/2962/ppssppwindows2013030513.png
http://img341.imageshack.us/img341/2962/ppssppwindows2013030513.png
http://img201.imageshack.us/img201/2962/ppssppwindows2013030513.png
http://img18.imageshack.us/img18/2962/ppssppwindows2013030513.png

Also thanx to that game I noticed a general tiny bug of the emulator that I'll report it on a different topic since it will affect any game with onscreen keyboard input.


RE: Phantasy Star Portable - Arcangel - 03-05-2013 01:00 PM

The double speed also happen on Super Ghost and Goblins. I don't know why.

This game looks great too.


RE: Phantasy Star Portable - VIRGIN KLM - 03-05-2013 02:41 PM

I'm pretty possitive it has to do something with VPS and FPS cap sync. Like it thinks that the cap of FPS is 60fps and it catches up with it.


RE: Phantasy Star Portable - GuilhermeGS2 - 03-05-2013 04:14 PM

Phantasy Star Poryable 2 not work. I try on earlier, show only FPS and black screen.


RE: Phantasy Star Portable - RinkuFO - 03-08-2013 09:44 AM

mine was super slow, its only 2-3 FPS cuz of "Kernel: Bad Object Handle 289" all over and over, and im using v0.6-1050 currently.
im using Japanese version of Phantasy Star Portable. I am guessing this issue must be with the font. it also BSOD when disabling buffer rendering.

EDIT: but when i tried PSP2(JPN) works(when interpreter?) but when continuing the game from menu will give u error code. and the game is at full speed when disabled VBO and enabled Vertex Cache.


RE: Phantasy Star Portable - [Unknown] - 03-08-2013 03:09 PM

Sweet, a game only broken in jit. Thanks very much for reporting.

Also, Phantasy Star Portable 1 for me runs fine in jit without showing bad object handle. Do you know which version of the game you have (the game id, e.g. ULJM...)?

-[Unknown]


RE: Phantasy Star Portable - RinkuFO - 03-08-2013 03:36 PM

(03-08-2013 03:09 PM)[Unknown] Wrote:  Sweet, a game only broken in jit. Thanks very much for reporting.

Also, Phantasy Star Portable 1 for me runs fine in jit without showing bad object handle. Do you know which version of the game you have (the game id, e.g. ULJM...)?

-[Unknown]
Your Welcome..
ULJM05309(on the attachment), like i said recently im using the japanese version.


RE: Phantasy Star Portable - srdjan1995 - 03-08-2013 04:23 PM

(03-08-2013 03:36 PM)RinkuFO Wrote:  
(03-08-2013 03:09 PM)[Unknown] Wrote:  Sweet, a game only broken in jit. Thanks very much for reporting.

Also, Phantasy Star Portable 1 for me runs fine in jit without showing bad object handle. Do you know which version of the game you have (the game id, e.g. ULJM...)?

-[Unknown]
Your Welcome..
ULJM05309(on the attachment), like i said recently im using the japanese version.

For me USA version of Phantasy Star Portable 1 works with jit on latest git (1056) just fine. Only problem in game are some broken graphics, and missing dialog fonts. Everything else works just fine.


RE: Phantasy Star Portable - RinkuFO - 03-09-2013 12:41 AM

(03-08-2013 04:23 PM)srdjan1995 Wrote:  
(03-08-2013 03:36 PM)RinkuFO Wrote:  
(03-08-2013 03:09 PM)[Unknown] Wrote:  Sweet, a game only broken in jit. Thanks very much for reporting.

Also, Phantasy Star Portable 1 for me runs fine in jit without showing bad object handle. Do you know which version of the game you have (the game id, e.g. ULJM...)?

-[Unknown]
Your Welcome..
ULJM05309(on the attachment), like i said recently im using the japanese version.

For me USA version of Phantasy Star Portable 1 works with jit on latest git (1056) just fine. Only problem in game are some broken graphics, and missing dialog fonts. Everything else works just fine.
Have you tested the "Continue"?
because, i tested phantasy star portable series (2, infinity) and the Continue gives me only Error Code. i cant test the phantasy star portable 1 its cuz of extreme slow (2-3FPS) even in PC, due to a reason with japanese version.


RE: Phantasy Star Portable - srdjan1995 - 03-09-2013 09:08 AM

(03-09-2013 12:41 AM)RinkuFO Wrote:  
(03-08-2013 04:23 PM)srdjan1995 Wrote:  
(03-08-2013 03:36 PM)RinkuFO Wrote:  
(03-08-2013 03:09 PM)[Unknown] Wrote:  Sweet, a game only broken in jit. Thanks very much for reporting.

Also, Phantasy Star Portable 1 for me runs fine in jit without showing bad object handle. Do you know which version of the game you have (the game id, e.g. ULJM...)?

-[Unknown]
Your Welcome..
ULJM05309(on the attachment), like i said recently im using the japanese version.

For me USA version of Phantasy Star Portable 1 works with jit on latest git (1056) just fine. Only problem in game are some broken graphics, and missing dialog fonts. Everything else works just fine.
Have you tested the "Continue"?
because, i tested phantasy star portable series (2, infinity) and the Continue gives me only Error Code. i cant test the phantasy star portable 1 its cuz of extreme slow (2-3FPS) even in PC, due to a reason with japanese version.

I have tester regular Phantasy Star Portable USA version. And it's working 60 FPS for me on PC.


RE: Phantasy Star Portable - RinkuFO - 03-09-2013 01:13 PM

(03-09-2013 09:08 AM)srdjan1995 Wrote:  
(03-09-2013 12:41 AM)RinkuFO Wrote:  
(03-08-2013 04:23 PM)srdjan1995 Wrote:  
(03-08-2013 03:36 PM)RinkuFO Wrote:  
(03-08-2013 03:09 PM)[Unknown] Wrote:  Sweet, a game only broken in jit. Thanks very much for reporting.

Also, Phantasy Star Portable 1 for me runs fine in jit without showing bad object handle. Do you know which version of the game you have (the game id, e.g. ULJM...)?

-[Unknown]
Your Welcome..
ULJM05309(on the attachment), like i said recently im using the japanese version.

For me USA version of Phantasy Star Portable 1 works with jit on latest git (1056) just fine. Only problem in game are some broken graphics, and missing dialog fonts. Everything else works just fine.
Have you tested the "Continue"?
because, i tested phantasy star portable series (2, infinity) and the Continue gives me only Error Code. i cant test the phantasy star portable 1 its cuz of extreme slow (2-3FPS) even in PC, due to a reason with japanese version.

I have tester regular Phantasy Star Portable USA version. And it's working 60 FPS for me on PC.
i see, it must be japanese font problem i guess?
or maybe the system data of japanese version has like incompatible with ppsspp(?) and it will cause something like "Error Code"


RE: Phantasy Star Portable - [Unknown] - 03-09-2013 04:05 PM

Thanks - yes, sometimes the Japanese, European, American, etc. versions of the game contain different code or hit different bugs. It should be fixable.

Hoping to find the problem with the jit so this doesn't need to be run in uber slow mode.

-[Unknown]


RE: Phantasy Star Portable - [Unknown] - 03-11-2013 07:25 AM

Well, so far I have a savestate right before the issue occurs. The interpreter goes from 10224519962 to 10224831844 ticks and calls sceCtrlReadBufferPositive, but the jit doesn't.. and it never calls sceCtrlReadBufferPositive.

The jit is spending a lot of time at 08c9f280 on user_main, so kinda smells like a branching bug or something...

-[Unknown]


RE: Phantasy Star Portable - VIRGIN KLM - 03-11-2013 03:05 PM

There's that weird bug in both games (this and the sequel) that you are able to save a game but when you attempt to load it returns a 80110327 error, which means that the emulator doesn't even attempt to read ms0 contents for some reason.


RE: Phantasy Star Portable - Henrik - 03-11-2013 03:09 PM

[Unknown] fixed the bug so now you can run this with JIT enabled.

Yes, there are still some strange memstick save issues around...