forums.PPSSPP.org
3/2/13 armjit update...WOW! - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Development (/forumdisplay.php?fid=3)
+--- Thread: 3/2/13 armjit update...WOW! (/showthread.php?tid=1259)

Pages: 1 2


3/2/13 armjit update...WOW! - jose325i - 03-03-2013 01:00 AM

Just wanted to drop by and thank all the devs for their hard work. Today's armjit updates made a *huge* difference in speed! Ridge racer 2 fluctuates from 25 up to 50 fps now on my HTC one s!

Everyone post up your results!


RE: 3/2/13 armjit update...WOW! - cloud1250000 - 03-03-2013 04:33 AM

good speed boost on my xperia play too Wink around 5 to 10 fps Smile


RE: 3/2/13 armjit update...WOW! - m45t3r - 03-03-2013 05:47 AM

Yeah, it makes Project DIVA Extended almost playable on my Galaxy Nexus.


RE: 3/2/13 armjit update...WOW! - thedicemaster - 03-03-2013 11:18 AM

with the latest build you should try disabling buffered rendering.
on my galaxy note 2 i now consistently get about 60fps.

it did introduce a bug for me though: if i disable buffered rendering from the main settings screen ppsspp freezes, but it works fine if i enter the settings screen while a game is loaded.

you can't use frameskip though, it breaks the flicker-fix.


RE: 3/2/13 armjit update...WOW! - Henrik - 03-03-2013 11:31 AM

Fixed both those issues Smile

Hmm, not quite it seems. Works for Wipeout though.


RE: 3/2/13 armjit update...WOW! - thedicemaster - 03-03-2013 11:43 AM

frameskip still flickers in project diva whenever a frame is skipped, but i no longer have a need for it now that project diva runs at full speed.


RE: 3/2/13 armjit update...WOW! - kervu117 - 03-03-2013 12:39 PM

60 fps on ridgeracer 2, on S3, frameskip flickers and buffered rendering off drops frames by 10%, wipeout pulse is much faster than before with buffer off but crashes after a short while, buffer on still has big bloom effect, Grand turismo goes into menu but black screens when game starts, still the logs shows activity and shaders are loaded and frames are being rendered, overall a big improvement thanks Henrik and team Smile


RE: 3/2/13 armjit update...WOW! - GamerzHell9137 - 03-03-2013 03:03 PM

Better edit the title name to March 2nd or something like that, cause there are people from Europe who think its February 3rd.
Btw i can't find the armjit March 2nd, there is just armjit March 3rd.

And still, the load/save screen on Project Diva can't be seen nor the 44100 Hz Sound isn't fixed(Windows version)

Disk I/O usage bug isn't fixed either.


RE: 3/2/13 armjit update...WOW! - Henrik - 03-03-2013 04:04 PM

load-save screen works fine if you have assets/ from the last release


RE: 3/2/13 armjit update...WOW! - V6ser - 03-03-2013 04:48 PM

(03-03-2013 05:47 AM)m45t3r Wrote:  Yeah, it makes Project DIVA Extended almost playable on my Galaxy Nexus.

Use faux kernel(also franco but faux is better) and it'll become playable Wink


RE: 3/2/13 armjit update...WOW! - ssshadow - 03-03-2013 07:19 PM

Latest build has broken Persona 3 JIT almost completely, it gets stuck on the loading screen after loading a save, where the loading animation loops forever... Works with JIT turned off, but that is of course very slow.


RE: 3/2/13 armjit update...WOW! - [Unknown] - 03-03-2013 07:27 PM

Android right? When did it last work?

-[Unknown]


RE: 3/2/13 armjit update...WOW! - ssshadow - 03-03-2013 07:39 PM

(03-03-2013 07:27 PM)[Unknown] Wrote:  Android right? When did it last work?

-[Unknown]

Yes, Android. It does work on Windows. I tested the latest versions, and loading broke in v0.6-906-g650c02c. It did work in the version before that.

The logcat seems to just be a spam of E/NativeApp(30668): 33:26:176 jni/../../Core/HLE/sceGe.cpp:223 E[HLE]: UNIMPL sceGeContinue

Which it always kind of was, so the crash is possibly silent?


RE: 3/2/13 armjit update...WOW! - cloud1250000 - 03-03-2013 07:54 PM

try to start the game without armjit and then when running enable armjit?


RE: 3/2/13 armjit update...WOW! - ssshadow - 03-03-2013 07:56 PM

(03-03-2013 07:54 PM)cloud1250000 Wrote:  try to start the game without armjit and then when running enable armjit?

Has no effect, stays at 10 fps.