Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy Type-0
08-11-2014, 04:15 PM (This post was last modified: 08-11-2014 07:23 PM by gainsly.)
Post: #61
RE: Final Fantasy Type-0
(08-11-2014 03:01 PM)AdamN Wrote:  
(08-10-2014 02:26 PM)gainsly Wrote:  I tried playing multiplayer via hamachi/tunngle/coldbird with a friend and we couldn't connect at all. The best we could do was me (the host) being able to see the mission and when joining I would get the "There was a communication error." message. We were using the latest build, v0.9.9-68-g404766c.

However, I did see the Compatibility thread and saw

Final Fantasy Type-0 [Work] Before revision v0.9.8-1390 not after (Adhoc update killing this game, waiting new update fixed)

Will netplay end up working if we just use a v0.9.8.-1390 build or do we need an older version of AdHocServer as well?
Have you tried using ppsspp builds from this post ? -snipped link-
Yeah, I've tried using those builds. Is there anything special I need to do other than drag-and-drop them into a current build folder? I know those .exe's "break" when you don't have the other main system files.

Builds I've tried using include
v0.9.9-68-g404766c
v0.9.8-1390-g6cada10
v0.9.8-1389-gc5e5ebe
irubwwu9wf6lg9b/PPSSPPWindows64.zip build that you linked.

Terminology:
Host - Person who is hosting via AdHocServer and trying to invade a mission.
Client - Person who is connecting to the AdHocServer and starting a mission.

We tried 3 different methods of connecting 5 times on each build.
1. Host slowdowns emulator when inside the Request List room. Client does slowdown after mission has started.
2. Host slowdowns emulator after invasion message sent. Client does slowdown after invasion message is received.
3. No slowdown from either player.

We've had mixed results but nothing that allowed us to play. Using the current 0.9.9-68, the one you linked (placed in current build folder) and 0.9.8-1389, it would automatically go to the communication error message very quickly. Client would never receive the invasion message.

Using the v0.9.8-1390, the client would receive the invasion message but host would get stuck on "Waiting for response from host. Please wait a moment."* I waited over two minutes on each attempt and nothing came through. [* The game interprets the "client" to be the host because it is indeed the one starting this mission.]

Later tonight we're going to try v0.9.8-1154-g3da962f because I did find a video where someone claimed netplay did indeed work using that build. They didn't use slowdown in the video, so I am a little suspect of it actually working.

Is there any methodology that we should try using? Or is placing the build exes that you linked into a current build folder the incorrect way of using them? I'm really lost at how to get this game working. I do know that I can host with hamachi and it is indeed connectable because I've played over 20 hours of MHP3rd HD on 0.9.9-68 without failure but FFT0 has yet to work on any build.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Well, this certainly is weird. I guess I need to make clarifications.
The person I play MHP3HD is from FLorida, US. I'm from MarylanD, USA.
FL Client -> MD Host, game works fine. [MHP3HD]
The guy I am trying is from MarylanD as well.
MD Client -> MD Host, game doesn't work. [FFT-0]

However, I made my girlfriend try being a client for FFT-0.
MD Client -> MD Host, game works fine. [FFT-0]
We tested the 98-1154 build and then 99-68, both worked fine. No slow down was necessary on either build.
I tested my normal internet connection and 4g to her, our ping was around 80~160.

I guess first thing is to check the latency between the guy I had problems connecting to. Other than that, I'm unsure of what our problem could be.
Find all posts by this user
Quote this message in a reply
08-12-2014, 12:34 PM
Post: #62
RE: Final Fantasy Type-0
(08-11-2014 04:15 PM)gainsly Wrote:  
(08-11-2014 03:01 PM)AdamN Wrote:  
(08-10-2014 02:26 PM)gainsly Wrote:  I tried playing multiplayer via hamachi/tunngle/coldbird with a friend and we couldn't connect at all. The best we could do was me (the host) being able to see the mission and when joining I would get the "There was a communication error." message. We were using the latest build, v0.9.9-68-g404766c.

However, I did see the Compatibility thread and saw

Final Fantasy Type-0 [Work] Before revision v0.9.8-1390 not after (Adhoc update killing this game, waiting new update fixed)

Will netplay end up working if we just use a v0.9.8.-1390 build or do we need an older version of AdHocServer as well?
Have you tried using ppsspp builds from this post ? -snipped link-
Yeah, I've tried using those builds. Is there anything special I need to do other than drag-and-drop them into a current build folder? I know those .exe's "break" when you don't have the other main system files.

Builds I've tried using include
v0.9.9-68-g404766c
v0.9.8-1390-g6cada10
v0.9.8-1389-gc5e5ebe
irubwwu9wf6lg9b/PPSSPPWindows64.zip build that you linked.

Terminology:
Host - Person who is hosting via AdHocServer and trying to invade a mission.
Client - Person who is connecting to the AdHocServer and starting a mission.

We tried 3 different methods of connecting 5 times on each build.
1. Host slowdowns emulator when inside the Request List room. Client does slowdown after mission has started.
2. Host slowdowns emulator after invasion message sent. Client does slowdown after invasion message is received.
3. No slowdown from either player.

We've had mixed results but nothing that allowed us to play. Using the current 0.9.9-68, the one you linked (placed in current build folder) and 0.9.8-1389, it would automatically go to the communication error message very quickly. Client would never receive the invasion message.

Using the v0.9.8-1390, the client would receive the invasion message but host would get stuck on "Waiting for response from host. Please wait a moment."* I waited over two minutes on each attempt and nothing came through. [* The game interprets the "client" to be the host because it is indeed the one starting this mission.]

Later tonight we're going to try v0.9.8-1154-g3da962f because I did find a video where someone claimed netplay did indeed work using that build. They didn't use slowdown in the video, so I am a little suspect of it actually working.

Is there any methodology that we should try using? Or is placing the build exes that you linked into a current build folder the incorrect way of using them? I'm really lost at how to get this game working. I do know that I can host with hamachi and it is indeed connectable because I've played over 20 hours of MHP3rd HD on 0.9.9-68 without failure but FFT0 has yet to work on any build.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Well, this certainly is weird. I guess I need to make clarifications.
The person I play MHP3HD is from FLorida, US. I'm from MarylanD, USA.
FL Client -> MD Host, game works fine. [MHP3HD]
The guy I am trying is from MarylanD as well.
MD Client -> MD Host, game doesn't work. [FFT-0]

However, I made my girlfriend try being a client for FFT-0.
MD Client -> MD Host, game works fine. [FFT-0]
We tested the 98-1154 build and then 99-68, both worked fine. No slow down was necessary on either build.
I tested my normal internet connection and 4g to her, our ping was around 80~160.

I guess first thing is to check the latency between the guy I had problems connecting to. Other than that, I'm unsure of what our problem could be.
I never tried playing through the internet, but i never had any problem on LAN (doesn't even need to change the speed)

There are 3 possibility, big latency or lost packets, or the port already used by another program on one of the player (different games use different ports)

If the game can use the port without problem the next highest possibility is lost packets, as some games may not be able to handle too many lost packets (since adhoc multiplayer games wasn't designed for long distance communication)

My Modified PPSSPP (old version):
=========================
Win32: https://www.dropbox.com/s/iowb4kr00nzbs7k/PPSSPPWindows.zip?dl=0
Win64: https://www.dropbox.com/s/dujdrcnec3nryrq/PPSSPPWindows64.zip?dl=0
Find all posts by this user
Quote this message in a reply
12-30-2014, 05:13 AM
Post: #63
RE: Final Fantasy Type-0
Does Someone have hamachi or evolve for playing online?
Find all posts by this user
Quote this message in a reply
12-31-2014, 09:24 PM (This post was last modified: 12-31-2014 09:24 PM by nightmesh.)
Post: #64
RE: Final Fantasy Type-0
(12-30-2014 05:13 AM)JustForFun Wrote:  Does Someone have hamachi or evolve for playing online?

I use coldbird this game since it seems easier for me but I also have evolve if you'd like to give that a try.
Find all posts by this user
Quote this message in a reply
01-02-2015, 07:42 PM
Post: #65
RE: Final Fantasy Type-0
(12-31-2014 09:24 PM)nightmesh Wrote:  
(12-30-2014 05:13 AM)JustForFun Wrote:  Does Someone have hamachi or evolve for playing online?

I use coldbird this game since it seems easier for me but I also have evolve if you'd like to give that a try.
Do you have a download link for coldbird? I wanted to start the multiplayer but haven't had any luck with AdHoc Party or Evolve.
Find all posts by this user
Quote this message in a reply
01-02-2015, 08:10 PM (This post was last modified: 01-02-2015 08:20 PM by lumune.)
Post: #66
RE: Final Fantasy Type-0
(01-02-2015 07:42 PM)sammichofdestiny Wrote:  Do you have a download link for coldbird? I wanted to start the multiplayer but haven't had any luck with AdHoc Party or Evolve.

coldbird isn't a program, it's just a 24/7 server for playing JPCSP and PPSSPP emulators online.

You just need to change your emulator ip from localhost to coldbird.net and that's it.

Oh and you'll need to enable DMZ on your Router/Switch/Modem since coldbird requires it. If you don't, you won't be able to see anyone in the games, you will be "invisible".

They also have a server status page which is updated in real time:
http://pro.coldbird.net

You know what, i'll make a thread about it. I've spent quite some time last year trying to figure it out, like you, what exactly was coldbird in the first place.
Find all posts by this user
Quote this message in a reply
01-02-2015, 08:21 PM
Post: #67
RE: Final Fantasy Type-0
I don't use an emulator, but I was able to set everything up for my PSP. I just need to test it atm.
Find all posts by this user
Quote this message in a reply
01-03-2015, 01:47 AM
Post: #68
RE: Final Fantasy Type-0
(01-02-2015 08:10 PM)lumune Wrote:  
(01-02-2015 07:42 PM)sammichofdestiny Wrote:  Do you have a download link for coldbird? I wanted to start the multiplayer but haven't had any luck with AdHoc Party or Evolve.

coldbird isn't a program, it's just a 24/7 server for playing JPCSP and PPSSPP emulators online.

You just need to change your emulator ip from localhost to coldbird.net and that's it.

Oh and you'll need to enable DMZ on your Router/Switch/Modem since coldbird requires it. If you don't, you won't be able to see anyone in the games, you will be "invisible".

They also have a server status page which is updated in real time:
http://pro.coldbird.net

You know what, i'll make a thread about it. I've spent quite some time last year trying to figure it out, like you, what exactly was coldbird in the first place.
If you don't see dmz on your router try looking for something called IP passthrough. I've set mine to default server and use my pc as it. I have an att&t modem so I hope that helps anyone with the same problem out.
Find all posts by this user
Quote this message in a reply
06-26-2015, 01:33 PM
Post: #69
Final Fantasy Type 0 on Android with Ppsspp ver 1.0.1 or .9.9.1 built in adhoc
Hey guys! Can somebody teach me (in summary) the way to play Type 0 multiplayer from Android to Android?
I really really want to play this game with my brother. And does adhoc-ing on this game work anyway?
We did the procs given by nightmesh but i just cant see the request/mission on the list. Thanks for ur reply.
Find all posts by this user
Quote this message in a reply
06-26-2015, 01:37 PM
Post: #70
RE: Final Fantasy Type-0
Merged.

♦ Intel Core i7-6700HQ | 16 GB RAM | NVIDIA GeForce GTX 960M | Debian Testing
♦ Intel Core i7-2630QM | 4 GB RAM | NVIDIA GeForce GT 540M | Debian Testing
♦ PSP-3004 | 6.60 PRO-C2
Find all posts by this user
Quote this message in a reply
07-05-2015, 06:22 AM
Post: #71
RE: Final Fantasy Type-0
Hi everyone,
I want to know if this game still alive? I am using coldbird yet only one rare player I can see. And when I connect with him/her it shows Connection error. I can't test with other players since only one plays on coldbird.

Any suggestions?
Find all posts by this user
Quote this message in a reply
07-14-2015, 09:34 PM
Post: #72
RE: Final Fantasy Type-0
tested with two PCs and PPSSPP 0.9.9, in the same router. No need to alt speed because of the 0 ping.
Emu freezes when you try to summon an eidolon, then breaks you off (so, no eidolon for now, when online).

We got succeed in a screen mission, but its still to be tested whith an academy (story mode) mission and rts missions.

The key was to use the ip of the joining one, not the quest hoster. Which raises me doubts about the possibility of a third player
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: