Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
games running slow on my laptop (ppsspp 0.81)
07-09-2013, 02:58 AM (This post was last modified: 07-09-2013 03:01 AM by XZeroX.)
Post: #1
games running slow on my laptop (ppsspp 0.81)
This should explain everything about my laptop specs

[Image: clpu.png]

[Image: pjk1.png]

so I want to know if its because of my laptop specs or the ppsspp settings,and the games I tried are Gods Eater Burst and dragon ball z tenkaichi tag team and PES 2013 and they all run slow.
Find all posts by this user
Quote this message in a reply
07-09-2013, 03:12 AM
Post: #2
RE: games running slow on my laptop (ppsspp 0.81)
Put the laptop in "High Performance" in Control Panel > Power Options.

Other than that, 1.6GHz processors are kinda slow so don't expect full speed on all the games and make sure "Texture Scalling" is off.

[CPU]: Intel Core i7-4790K 4.0GHz
[GPU]: EVGA GeForce GTX 970 Superclocked ACX 2.0 4GB GDDR5
[PSU]: EVGA SuperNOVA G1 1000W (80 Plus Gold)
[RAM]: Corsair Vengeance 16GB (2x8GB) DDR3 1600MHz
[MOBO]: MSI Z97-GAMING 5
[PC CASE]: ENERMAX Ostrog GT (Red)
[CPU FAN]: Cooler Master: Hyper 212 EVO
Find all posts by this user
Quote this message in a reply
07-09-2013, 03:18 AM
Post: #3
RE: games running slow on my laptop (ppsspp 0.81)
Texture scalling is already off,and its on high perfomance.
Find all posts by this user
Quote this message in a reply
07-09-2013, 03:40 AM (This post was last modified: 07-09-2013 03:52 AM by solarmystic.)
Post: #4
RE: games running slow on my laptop (ppsspp 0.81)
Welcome to the forums.

A lower end AMD APU like the E-450 should be able to run PPSSPP some what decently, but you should also keep your expectations in check.

Some games will be fine, and others won't. PPSSPP currently only uses 1 core of your CPU so you're handicapped in that aspect, since the E-450 works best when multithreaded.

Gods Eater Burst and dragon ball z tenkaichi tag team are on the higher end of the requirements, so expect to see some slowdown.

If you're really desperate for some extra speed (remember, Speed and FPS are 2 different metrics for measurement in PPSSPP), you can do the following:-

1. Turn on Frameskipping and set it 1 or 3 (Odd numbers work best, Even numbers cause flickering in games)

2. Turn off Buffered Rendering (May break games that need it. A lot don't require it to work. Minor Speed boost)

3. Make sure 2xSSAA and any form of Texture Scaling is off. Anisotropic Texture filtering, however, is fine and nearly free on any modern PC.

4. Play at only 1x or 2x rendering resolution

5. Use the "Unlock CPU Clock" option in the System Settings menu, and set it to something lower (default:-222MHz), like 111MHz or even 60-80 MHz. People with lower end Android devices have reported some success in gaining more speed with that function. Warning: Lowering the CPU Clock too much will cause unpredictable behaviour within games like SPS and jerkiness. Experiment at your own risk. Also, there is a trade off between increased Speed, as you reduce the frequency, but lower internal FPS. Find a compromise you can be comfortable with.

6. Turn off all other background applications while playing games on PPSSPP

7. Update your AMD drivers. (this may not always be a good idea since newer AMD drivers have conflicts with the program as reported in the forum)

8. Ensure that Hardware Transform (massive speed boost) and Vertex Cache are ON. (They should on by default)

9. Also ensure that the emulator is running in JIT (Dynarec) mode.

I also recommend that you grab the latest 64bit version of the emulator from the buildbot and read the following thread that I've written since it covers some of the weaknesses that AMD/ATI platforms (which you are using and so am I) have on this emulator with certain games:-

http://forums.ppsspp.org/showthread.php?tid=4383

Enjoy your stay.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
07-09-2013, 05:41 PM
Post: #5
RE: games running slow on my laptop (ppsspp 0.81)
Thanks a lot for the awesome reply,but sadly DBZ still works slow,well atleast I can play Persona 3 Big Grin
Find all posts by this user
Quote this message in a reply
07-09-2013, 06:20 PM
Post: #6
RE: games running slow on my laptop (ppsspp 0.81)
Maybe is because the CPU clock, and the GPU is shared with CPU. It low a bit the performance. The emulator also have some problems with AMD GPUs.

Phones: Galaxy S10 Lite and Redmi Note 6 Pro

PC: Core i5 3470/8GB RAM/GTX 660 2GB/Windows 10 Pro x64
Find all posts by this user
Quote this message in a reply
07-09-2013, 06:34 PM
Post: #7
RE: games running slow on my laptop (ppsspp 0.81)
Ok try Amd Fusion.... It kills all background processes. I used this for PC games very helpfull.

S TO DA G
Find all posts by this user
Quote this message in a reply
07-09-2013, 08:23 PM
Post: #8
RE: games running slow on my laptop (ppsspp 0.81)
(07-09-2013 06:34 PM)stodag Wrote:  Ok try Amd Fusion.... It kills all background processes. I used this for PC games very helpfull.

Is this will work Smile?

I worse write english so take easy on me
(even my own language realy bad T_T)

Rig to test now :
Windows 8 64 bit (Laptop)
Intel® Core™ i3-3110M (2.4GHz, 3MB L3 Cache)
Nvidia GT720M 2GB
Find all posts by this user
Quote this message in a reply
07-09-2013, 09:06 PM
Post: #9
RE: games running slow on my laptop (ppsspp 0.81)
Not sure if it will work on ppsspp as its an emulator.. but it works for me with pc gamesSmile
Also type msconfig in start menu and enable other processor if you havnt already.. This will help some of the background processes to be shared.. Taking some pressur of the one cpu, leaving more for ppsspp. "msconfig" can also change auto start programs to free cpu..
Find all posts by this user
Quote this message in a reply
07-10-2013, 07:18 AM
Post: #10
RE: games running slow on my laptop (ppsspp 0.81)
(07-09-2013 09:06 PM)stodag Wrote:  Not sure if it will work on ppsspp as its an emulator.. but it works for me with pc gamesSmile
Also type msconfig in start menu and enable other processor if you havnt already.. This will help some of the background processes to be shared.. Taking some pressur of the one cpu, leaving more for ppsspp. "msconfig" can also change auto start programs to free cpu..

It don't make any different but i lost some system liked aero on window 7 (basicaly when i press active i don't how to make it default)

I worse write english so take easy on me
(even my own language realy bad T_T)

Rig to test now :
Windows 8 64 bit (Laptop)
Intel® Core™ i3-3110M (2.4GHz, 3MB L3 Cache)
Nvidia GT720M 2GB
Find all posts by this user
Quote this message in a reply
07-10-2013, 08:51 AM
Post: #11
RE: games running slow on my laptop (ppsspp 0.81)
Right click desktop/personalise/troubleshoot aero,
Or. click start/right click my computer/properties/Then click windows experiance index/ rerun assessment... may take a while.. you should now have aero turned on.

S TO DA G
Find all posts by this user
Quote this message in a reply
08-02-2013, 01:25 PM
Post: #12
RE: games running slow on my laptop (ppsspp 0.81)
Hello everyone! I had the same problems (and pretty much the same laptop). Following your advice I managed to gain decent speed. Only problem now is tha the game constantly flickers to black. What could be the problem? Thank you!
Find all posts by this user
Quote this message in a reply
08-02-2013, 06:30 PM
Post: #13
RE: games running slow on my laptop (ppsspp 0.81)
Ok, flickering solved: I disabled frameskipping. Silly. The actual game is still slow, but I guess I have to stick with that, haven't I? Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: