Post Reply 
 
Thread Rating:
  • 2 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Jak and Daxter - The Lost Frontier
05-19-2014, 11:21 AM
Post: #31
RE: Jak and Daxter - The Lost Frontier
(05-11-2014 12:41 PM)Nightquaker Wrote:  Game still crashes before the first cutscene on 0.9.8-598. Only got through it once out of 4 tries and still crashed shortly after. Tested with both US and european versions.

(04-07-2014 07:46 AM)bassop Wrote:  With 0.9.8 is fully playable, for saves issue set the psp 2000/3000 and voilà, problem solved!

What version of the game do you have?

official 0.9.8, windows 7 and Android (with more lag) fully playable, I do not remember the settings, do some testing, it must work if you have no problems
Find all posts by this user
Quote this message in a reply
06-04-2014, 02:28 AM (This post was last modified: 06-04-2014 02:36 AM by deividrod.)
Post: #32
RE: Jak and Daxter - The Lost Frontier
In my cellphone Samsung Galaxy S3 mini, Android 4.1.2, the game is problem on the image in main menu and enter of game. I tested latest builds of buildbot.

My configurations:
bufferid rendering on
simulate block transfer off
frameskipp: 01
rendering resulution: 1xPSP
texture filter: linear
Can anyone help me?
Sorry my bad english, I am a brazilian.

Images of problem:


Attached File(s) Thumbnail(s)
           
Find all posts by this user
Quote this message in a reply
06-05-2014, 12:04 PM (This post was last modified: 06-05-2014 12:50 PM by n1dminhd.)
Post: #33
RE: Jak and Daxter - The Lost Frontier
- Windows 7 32bit
- US
- Ver 0.96 : Playable
- Ver 0.97, 0.98, and latest builds of buildbot : In game
- Screen shot of Lastest builds :


Attached File(s) Thumbnail(s)
       
Find all posts by this user
Quote this message in a reply
06-05-2014, 04:37 PM (This post was last modified: 06-05-2014 05:24 PM by bassop.)
Post: #34
RE: Jak and Daxter - The Lost Frontier
(06-05-2014 12:04 PM)n1dminhd Wrote:  - Windows 7 32bit
- US
- Ver 0.96 : Playable
- Ver 0.97, 0.98, and latest builds of buildbot : In game
- Screen shot of Lastest builds :

tried 0.9.8 1030, everything ok, the game goes to great

(06-04-2014 02:28 AM)deividrod Wrote:  In my cellphone Samsung Galaxy S3 mini, Android 4.1.2, the game is problem on the image in main menu and enter of game. I tested latest builds of buildbot.

My configurations:
bufferid rendering on
simulate block transfer off
frameskipp: 01
rendering resulution: 1xPSP
texture filter: linear
Can anyone help me?
Sorry my bad english, I am a brazilian.

Images of problem:


to play decently, rendering 3x or 4x better.
impossible to make it run on mini s3

Remember fast memory off
Find all posts by this user
Quote this message in a reply
06-06-2014, 04:39 AM
Post: #35
RE: Jak and Daxter - The Lost Frontier
(06-05-2014 04:37 PM)bassop Wrote:  tried 0.9.8 1030, everything ok, the game goes to great

But, it does not have 32 bit version
Find all posts by this user
Quote this message in a reply
07-29-2014, 08:58 AM
Post: #36
RE: Jak and Daxter - The Lost Frontier
Crashes before intro on 0.9.9-2 64bit.

My specs:
Phenom X3 8450 ~2.3GHz
PowerColor HD6850 1GB
4 gigs of DDR2-800 RAM
~400GB HDD
Windows 8.0 x64
Find all posts by this user
Quote this message in a reply
08-03-2014, 02:26 PM
Post: #37
RE: Jak and Daxter - The Lost Frontier
Just tested on ppsspp v0.9.9-34 Win7 32-bit.

To prevent crash at very beginning just disable Dynarec (JIT). After goes in-game you can enable JIT again just fine.

Game will crash occasionally. Save often, either by savestate or from in-game menu (press start and choose save).


Attached File(s) Thumbnail(s)
       
Find all posts by this user
Quote this message in a reply
06-16-2015, 02:08 PM (This post was last modified: 06-18-2015 09:21 AM by Boondock Saint.)
Post: #38
RE: Jak and Daxter - The Lost Frontier
I just wanna let everybody know that if you have problems with crashing just turn io method to host and it works well on the latest build, but sometimes later in the game it still crashes from time to time, just save often so you can continue when it crashes.
Find all posts by this user
Quote this message in a reply
08-08-2016, 03:40 PM (This post was last modified: 08-27-2016 05:39 PM by gordonfreeman.)
Post: #39
RE: Jak and Daxter - The Lost Frontier
I've got a workaround and a possible root cause for this issue on Windows PPSSPP version 1.2.2 (switching to dynarec and changing IO method did not stop or bypass crashes for me):

EDIT: I completed the game with this fix so I can confirm it enables passing all crashes.

Root cause:
This seems to be related to loading state saves and how the game does not recognise the memory card after that (similar to how native autosaves fail in Phantasy Star Portable after loading a state save). Fortunately the workaround is fairly simple although need to be careful.

Workaround:
State Save often and in case the game freezes and then emulator crashes - this happens together - especially at the green doors loading other areas or at the plane take-off/landing zones:
1. Load your state, perform a native save (save from the game's menu)
2. Close the game and relaunch it from the emulator launcher
3. Load game from game's main menu then continue normally - DO NOT LOAD STATE UNTIL THE CRASH POINT IS PASSED (then perform another state save).

In case the native save restarts the level and you do not want to replay the whole level (e.g. Research station after ending enemy encounter just before the next segment), try this alternative:
1. Load state
2. Just perform a native save and continue without loading state until the next level segment is reached.
This does not always work, first method is guaranteed to work though based on my experience.

Of note, if after a load the game detects that memory card is unmounted and informs you via an on-screen notification then crash should not occur until your next native save re-enables native autosave. It is always a good idea to have native saves though.

I'll post a log next time I launch the game, probably this weekend, meanwhile this should allow everyone to play the game with minimal hassle. The emulator itself freezing up and requiring a force CTRL+ALT+DEL then task manager kill is really the most irritating part and for some reason it is taking a long time to startup sometimes but anyway, it is a fantastic emulator!
Find all posts by this user
Quote this message in a reply
08-13-2016, 03:06 PM (This post was last modified: 08-27-2016 05:37 PM by gordonfreeman.)
Post: #40
RE: Jak and Daxter - The Lost Frontier
As promised, here is a crash log:
pastebin.com/K2ritXGK

The instructions on how to produce a log in the options explained thread are out of date, I had to use the --log="FULL PATH" argument to get logs working.

I reached a point near the end of the game where the native save before crash point no longer seems to work [EDIT: Found a solution, just play the level from a native save, state saves worked as above after that], this crash is from there.

P.S. I posted this separately so the notification could show up, don't know if post editing makes it visible that new information has been added to the thread.
Find all posts by this user
Quote this message in a reply
08-28-2017, 11:07 PM
Post: #41
RE: Jak and Daxter - The Lost Frontier
The game plays no sound whatsoever and I've messed around all of the sound settings in game and in ppsspp.

Also it seems some effects cause a white screen like when the enemies push down the boulder or in the first flight mission, any time the big ship is on screen everything goes white except for its damaged smoking effect and the red enemy cursors.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: