Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mali 400 graphics missing in HW Transform
04-28-2013, 10:21 AM
Post: #46
RE: Mali 400 graphics missing in HW Transform
(04-28-2013 09:34 AM)sfageas Wrote:  i have 4.1.2 and i dont have a problem with siyah kernel so we need to gather some info
if anyone has a problem should post device and firmware info,rooted-unrooted etc
I bet people that are facing problems on complete stock (if memory serves gokhanmoral has the new drivers in his kernel)
Find all posts by this user
Quote this message in a reply
04-28-2013, 11:07 AM
Post: #47
RE: Mali 400 graphics missing in HW Transform
Well, mine GS3, that faces the problem, is the International, no overclock, is unrooted and runs the stock 4.1.2.
Find all posts by this user
Quote this message in a reply
04-28-2013, 11:30 AM
Post: #48
RE: Mali 400 graphics missing in HW Transform
Galaxy ace 2 unroot 2.3.6
Find all posts by this user
Quote this message in a reply
04-28-2013, 11:45 AM
Post: #49
RE: Mali 400 graphics missing in HW Transform
I'm also using siyahkernel but from what I know, using a stock sammy rom will trigger the old mali driver while using any AOSP based rom will trigger the newest one, from what GM said there are two mali drivers in the kernel. So sfageas should actually have the issue, no?

So I think that is more a stock rom thing, the kernel must have some optimization or element making the Mali GPU work better and avoid these problems, be it the driver or something else.

-Samsung galaxy S3 International version - Android 4.4.2
-Dual Core locked CPU, Clocked at 1Ghz-1.8Ghz
-Mali 400MP4 GPU Clocked from 160Mhz to 533Mhz
-1GB ram, boo..
Find all posts by this user
Quote this message in a reply
04-28-2013, 05:43 PM (This post was last modified: 04-28-2013 05:44 PM by alshaer96.)
Post: #50
RE: Mali 400 graphics missing in HW Transform
I think it is something with the stock kernel, I am using presus and no issues.
The people completely stock, can you write your Rom version for eg. XXemc3 xxemb3
Find all posts by this user
Quote this message in a reply
04-29-2013, 10:13 AM (This post was last modified: 04-29-2013 10:13 AM by skyfor.)
Post: #51
RE: Mali 400 graphics missing in HW Transform
damn!!im still facing graphics missing on latest revision Angry
im play def jam when play story mode on some places i got missing head,body....in hw transform.! Angry
Find all posts by this user
Quote this message in a reply
04-29-2013, 11:33 AM
Post: #52
RE: Mali 400 graphics missing in HW Transform
You have a Sony Xperia Sola, right skyfor? Please tell us which Android and kernel version you use. Maybe someone can suggest something to upgrade your drivers.
I dont know anything about the Sony phones, but there are no glitches with my Siyah 1.9.1 kernel.

Windows 7 x64: Intel Core i5 4570 @3.6 Ghz, ATI Radeon HD 7870
Android 4.4.2 (CM11): Samsung Galaxy S3 @ 4x1.6 Ghz CPU, 600Mhz GPU
Visit this user's website Find all posts by this user
Quote this message in a reply
04-29-2013, 03:00 PM
Post: #53
RE: Mali 400 graphics missing in HW Transform
Well, here my GS3 is with I9300UBELL1.
Find all posts by this user
Quote this message in a reply
04-29-2013, 05:33 PM (This post was last modified: 04-29-2013 05:35 PM by brujo55.)
Post: #54
RE: Mali 400 graphics missing in HW Transform
slim bean 4.2.2 no issues
Find all posts by this user
Quote this message in a reply
04-29-2013, 06:27 PM
Post: #55
RE: Mali 400 graphics missing in HW Transform
I got a solution for Heaven Stream and all other users of the international GS3 models. Just look at this blog post: http://rootgalaxys3iii.com/galaxy-s3-siy...s3-kernel/
This is for Jelly Bean 4.1.2 stock users and root access should not be required (I didnt need it). It contains new drivers for the Mali 400 gpu.
Read the post, think about it, and if you dont understand what it does; its likely you will brick your phone.
The easier way would be to wait until Samsung rolls out the Android 4.2.2 update.
And yes I know that not everyone knows what Im talking about here. This is on purpose.

Windows 7 x64: Intel Core i5 4570 @3.6 Ghz, ATI Radeon HD 7870
Android 4.4.2 (CM11): Samsung Galaxy S3 @ 4x1.6 Ghz CPU, 600Mhz GPU
Visit this user's website Find all posts by this user
Quote this message in a reply
04-29-2013, 08:10 PM
Post: #56
RE: Mali 400 graphics missing in HW Transform
If anybody wants to try you must read read read & read until you understand every word & step by step instruction,then it will be easy
However if you do one step wrong you will end up with a nice coffee pot Big Grin
Find all posts by this user
Quote this message in a reply
04-30-2013, 07:01 AM
Post: #57
RE: Mali 400 graphics missing in HW Transform
(04-29-2013 11:33 AM)kevke96 Wrote:  You have a Sony Xperia Sola, right skyfor? Please tell us which Android and kernel version you use. Maybe someone can suggest something to upgrade your drivers.
I dont know anything about the Sony phones, but there are no glitches with my Siyah 1.9.1 kernel.
yes my phone is sony xperia sola...yesterday im use ics and im still facing missing graphics...so im go back to gb but im still facing missing graphics,i dont know why... Sad
Find all posts by this user
Quote this message in a reply
04-30-2013, 01:23 PM
Post: #58
RE: Mali 400 graphics missing in HW Transform
The answer is quite simple. Gelly Bean has old Mali drivers that produce these glitches.
I hope someone who has experience with the Sony phones can help you with updating them.

Windows 7 x64: Intel Core i5 4570 @3.6 Ghz, ATI Radeon HD 7870
Android 4.4.2 (CM11): Samsung Galaxy S3 @ 4x1.6 Ghz CPU, 600Mhz GPU
Visit this user's website Find all posts by this user
Quote this message in a reply
04-30-2013, 03:01 PM
Post: #59
RE: Mali 400 graphics missing in HW Transform
Quite of understood it, but i have not a single experience with Odin, so i prefer to think realy well before making a decision. But anyway, thanks to Kevke96 for the solution.
Find all posts by this user
Quote this message in a reply
04-30-2013, 03:20 PM
Post: #60
RE: Mali 400 graphics missing in HW Transform
I have stock kernel, but I have root. I used the app Tegrak Overclock, I overclocked to 1.4Ghz. I not noted almost none diference, just more 2-3FPS on GoW. I have only really more speed when use Turbo Key on Intro of GoW Chains of Olympus, without overclock goes to 59FPS, with overclock goes to 67FPS.

Sorry my bad, bad english. Thanks.

Phone: Xiaomi Redmi Note 6 Pro 4/64GB

PC: Core i5 3470/8GB RAM/GTX 660 2GB/Windows 10 Pro x64
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: