Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(Win10) Intense lag playing video
11-04-2017, 03:54 PM
Post: #1
(Win10) Intense lag playing video
In Ace combat X, whatever your hardware or setting is, end up very choppy video playback at 33% speed.

Add this back to imgur link, sorry for that. This site block me using any form of image to be uploaded nor linked.
(I'm feeling so resentful about that, seriously for WHAT REASON?)


Upper one is problem I'm encountering. it's all chopped up, not even smooth slow motion - While below one is using Hi-res replaced textures and running in 8x PSP resolution without even full loading GPU.

Originally I had no problem viewing intro cutscene until Mission 14, but now this is giving me headache. I can't withstand that sound.

However, one weird thing is noticed here:


As you see, lagging is happening when decoding video, with intense delay on Kernel itself too.
So when I save state, leave that lagging for while and reloading state - That part plays so smoothly as they are using cache.

That means PPSSPP is having issue decoding video for some reason. So I gave PPSSPP high priority on Task manager. Even putting ISO file in RAM or SSD it is keep happening. CPU(i5 3570) is still not using more than 30%. All IO option yield no difference.

Now, what I have to do to fix it?
I just skipped that video for now but it's important stories. Sorry if I don't reply soon, I may not be able to use pc for around 2 weeks.
Find all posts by this user
Quote this message in a reply
11-06-2017, 01:08 AM
Post: #2
RE: (Win10) Intense lag playing video
First of all we keep 1 thread per game here, and this game already has it's thread in here, please use search before opening new discussions about specific game next time.;]

You're reading debug information wrong, there's nothing "intensely slow" there outside of maybe DL processing time, likely caused by using texture scaling, PPSSPP has some hardcore limitations to avoid scaling too much per frame, but unfortunately some games might still scale more than pc's can handle including stuff we would preferably not scale at all like video frames.

Soo ~ if you're using it or activated by accident, try to disable texture scaling completely, eventually if you have to use it switch to a lower multiplier and xBRZ algorithm, other algorithms are just awfuly slow.

The reason you can't post links is simple, it's one of few anti-bot features which keep this forum easier to maintain. Your first post has to be approved by moderator and no new users can link stuff until they get over 8 posts.
Some people might miss getting spam, but having to filter 20 pages filled with viagra ads can be pretty hard. - Custom PPSSPP Shaders! - simple CE scripts to help creating CWCheats, - CWCheat workarounds.
Find all posts by this user
Quote this message in a reply
11-11-2017, 08:33 AM
Post: #3
RE: (Win10) Intense lag playing video
Oh, your're one who made Custom Scaleable Shaders, I never expected you'd reply this Smile

After that happened, I disabled MFAA and reset internel resolution back to x5 from x8 but no effect. Texture scaling was not activated at all. Only thing I can think of is that something is blocking it's video decoder. Maybe I'd better remove replaced HD textures and ask there if it's still an issue.

p.s. While I'm trying to get used to forum system - which is quite rare in asia (AskUbuntu, Facepunch etc), it's pretty confusing when to create thread and when to bump in thread. If ppsspp use single thread per game, how do I locate needed information there? I'm pretty sure it'll be a flood of raining texts
Find all posts by this user
Quote this message in a reply
11-11-2017, 06:19 PM
Post: #4
RE: (Win10) Intense lag playing video
Generally you don't want to "bump" threads with generic questions/issues that are old because most of the time people involved are no longer interestedTongue, with game threads kept to track whole history of it's compatibility, it's fine to update even the oldest thread just to say that the game still works perfectly fine in latest version.:]

Not much would cause slowdowns in PPSSPP on powerful desktop so with this still being a problem maybe first try updating PPSSPP to latest version just to make sure it's not some random bug existing in older version.:]

Most hardcore performance problems could actually just be silly memory corruption, for example most games are unstable and bug out after running them for a very long time without restart, savestates are actually simulating this, so if you depend on savestates and never reload game from normal in-game save, it might eventually get random issues:].

Anyway if it's not that, to make it clear does all videos started to behave that way at some point, or the problem affects only some videos?

If it affects all videos, including game intro, maybe go to your PSP\SAVEDATA folder and rename your game savedata and try running the game from the start without any savedata just to see if it's affected by your in-game progress or not. If it is or it only happens at some late game video, you could upload your save with description how to reproduce the problem from there, if it isn't and the problem happens anyway, it could be something affecting it externally, maybe windows updated or some other third party app did. - Custom PPSSPP Shaders! - simple CE scripts to help creating CWCheats, - CWCheat workarounds.
Find all posts by this user
Quote this message in a reply
11-14-2017, 11:09 PM
Post: #5
RE: (Win10) Intense lag playing video
Oh, memory corruption.. I never thought that. And, yes, I only used savestate. But I do remember Vullan API(ppsspp was newiest version about 3 weeks ago) slow down video even from fresh startup.. But I guess that has nothing to do with direct X so let's ignore it.

Thinking back, until I play half-way thru and stuck in one stage - reloading and saving about tens of times while replacing HD textures at thensame time, without fresh starting the game.

So that explains it is likely to be memory corruption. Although after game clear, I did fresh start and still had issue. So I conclude it's replaced textures messing up something - but I can't check 'till tomorrow(When I take Korea SAT that day, studied for 7 years) so I'll update this later, Thanks for help! Wink

Have a nice da Smile
Find all posts by this user
Quote this message in a reply
11-15-2017, 05:32 AM
Post: #6
RE: (Win10) Intense lag playing video
Well, best luck with your exams!

Unfortunately I can't reproduce any video slowdown, even got this game for testing and the only thing which slows down intro video for me is saving new textures for texture replacement and also video recording that could cause slowdownTongue, but the first would probably stop producing new textures eventually and the latter until yesterday actually had a really bad memory leak that would probably quickly cause a crash.

Video in this game isn't even heavy, nothing weird happens, it's just a video, depending on backend and probably some other settings I get pretty easily from like 1500 to 3000 % with unthrottle, so I really suspect third party software or some windows 10 update affecting it in some bad way. - Custom PPSSPP Shaders! - simple CE scripts to help creating CWCheats, - CWCheat workarounds.
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump: