Post Reply 
 
Thread Rating:
  • 2 Votes - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PPSSPP for Pi
04-22-2013, 08:00 PM
Post: #31
RE: PPSSPP for Pi
Thank you MaXiMu! That seemed to work. PPSSPP now successfully builds!

It crashes when trying to run with SDL saying "segmantation fault/native/files/zip_read.cpp:253 E: missing filesystem for lang/en_US.ining/en_US.ini"

When trying to run cube.elf in headless mode it gives an error saying "Failed to map 256mb of memory space: Cannot allocate memory"

256mb happens to be all the ram the raspberry pi has. Does this mean the pi doesnt have enough ram to use ppsspp?
Find all posts by this user
Quote this message in a reply
04-22-2013, 10:04 PM
Post: #32
RE: PPSSPP for Pi
Ok so running PPSSPP from the pi's desktop interface provides different results.

Running in headless mode (even thought it warns about the lack of memory) does actually boot games. I cant see the gameplay but by using the -l option I can the log which shows the game is running, also the CPU usage shoots up which is another sign.

Running the SDL version just gives me a black screen.
Find all posts by this user
Quote this message in a reply
04-22-2013, 10:55 PM
Post: #33
RE: PPSSPP for Pi
It only needs to allocate 256MB of virtual memory and about 42MB of real memory. Uses file mapping.

Strange error about the languages. There is a lot of work on the git now about translations so it's probably related to this. It might be useful to just pull v0.7 head or something that is known to be stable.
Find all posts by this user
Quote this message in a reply
04-22-2013, 11:11 PM (This post was last modified: 04-22-2013 11:33 PM by BubblegumBalloon.)
Post: #34
RE: PPSSPP for Pi
Yeah thats probably a good idea. Do you know how I can clone an older version of the emulator?

For anybody who want to try out the build here it is. Keeping in mind that it only works in headless mode which means you cant see any gameplay. You can still check the log console though.

http://www.mediafire.com/?0uss2hsse2ac4hu
Find all posts by this user
Quote this message in a reply
04-23-2013, 09:19 AM
Post: #35
RE: PPSSPP for Pi
(04-22-2013 11:11 PM)BubblegumBalloon Wrote:  Yeah thats probably a good idea. Do you know how I can clone an older version of the emulator?

For anybody who want to try out the build here it is. Keeping in mind that it only works in headless mode which means you cant see any gameplay. You can still check the log console though.

http://www.mediafire.com/?0uss2hsse2ac4hu

Yeah they are tagged. So just checkout v0.7.
Find all posts by this user
Quote this message in a reply
04-23-2013, 10:24 AM
Post: #36
RE: PPSSPP for Pi
(04-22-2013 10:04 PM)BubblegumBalloon Wrote:  Ok so running PPSSPP from the pi's desktop interface provides different results.

Running in headless mode (even thought it warns about the lack of memory) does actually boot games. I cant see the gameplay but by using the -l option I can the log which shows the game is running, also the CPU usage shoots up which is another sign.

Running the SDL version just gives me a black screen.

Black screen?
Did you installed something like EGL X11 hack before?
Maybe you should also try to use libraries inside /opt/vc instead of the gles packages
Find all posts by this user
Quote this message in a reply
04-23-2013, 10:56 AM (This post was last modified: 04-23-2013 10:59 AM by BubblegumBalloon.)
Post: #37
RE: PPSSPP for Pi
(04-23-2013 10:24 AM)porkness Wrote:  Black screen?
Did you installed something like EGL X11 hack before?
Maybe you should also try to use libraries inside /opt/vc instead of the gles packages

Nope. I used a fresh Debian (Raspbian) install which is the recommended distro for the pi.

After that I did the following command exactly as they are listed below.

sudo apt-get install git-core
sudo apt-get install cmake
sudo apt-get install libsdl1.2-dev
Sudo apt-get install libgles2-mesa-dev
git clone git://github.com/hrydgard/ppsspp.git
cd ppsspp
git submodule update --init
cd ..
cmake -i ppsspp #enabled arm, disabled x86, built with release flags.
make
Find all posts by this user
Quote this message in a reply
08-14-2013, 08:43 PM (This post was last modified: 09-12-2013 06:36 PM by Sim_Piko.)
Post: #38
RE: PPSSPP for Pi
sorry for bumping old thread
I recently tried to compile v0.8.1-1341-g9637313 on Raspberry Pi.

Here's result:
Code:
[  9%] Building CXX object CMakeFiles/GPU.dir/GPU/GLES/DisplayListInterpreter.cpp.o
In file included from /home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/DisplayListInterpreter.cpp:26:0:
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/../GPUState.h: In member function ‘float GPUgstate::getViewportX1() const’:
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/../GPUState.h:336:74: error: ‘fabsf’ was not declared in this scope
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/../GPUState.h: In member function ‘float GPUgstate::getViewportY1() const’:
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/../GPUState.h:337:74: error: ‘fabsf’ was not declared in this scope
In file included from /home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/DisplayListInterpreter.h:26:0,
                 from /home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/DisplayListInterpreter.cpp:31:
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/TransformPipeline.h: At global scope:
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/TransformPipeline.h:67:7: error: expected identifier before ‘int’
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/TransformPipeline.h:67:14: error: expected unqualified-id before ‘{’ token
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/TransformPipeline.h: In constructor ‘VertexArrayInfo::VertexArrayInfo()’:
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/TransformPipeline.h:55:12: error: ‘VAI_NEW’ was not declared in this scope
In file included from /home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/DisplayListInterpreter.h:27:0,
                 from /home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/DisplayListInterpreter.cpp:31:
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/TextureCache.h: At global scope:
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/TextureCache.h:74:8: error: expected identifier before ‘int’
/home/pi/tmp/ppsspp-git/ppsspp/GPU/GLES/TextureCache.h:74:15: error: expected unqualified-id before ‘{’ token
make[2]: *** [CMakeFiles/GPU.dir/GPU/GLES/DisplayListInterpreter.cpp.o] Błąd 1
make[1]: *** [CMakeFiles/GPU.dir/all] Error 2
make: *** [all] Error 2
I used default libGLES2 (probably broken) from Raspbian repos.
I wanted to add "/opt/vc/include" and ""/opt/vc/lib" path for libGLES2, but don't know where to put them in cmake. :/
Find all posts by this user
Quote this message in a reply
09-02-2013, 05:07 PM
Post: #39
RE: PPSSPP for Pi
Hmm, maybe try:

#undef enum

Or something in those h files? Also, try changing fabsf() to abs().

-[Unknown]
Find all posts by this user
Quote this message in a reply
09-03-2013, 10:23 AM
Post: #40
RE: PPSSPP for Pi
fabsf should be in math.h, otherwise something is very wrong.
Find all posts by this user
Quote this message in a reply
09-12-2013, 06:37 PM (This post was last modified: 09-16-2013 08:58 PM by Sim_Piko.)
Post: #41
RE: PPSSPP for Pi
build v0.9.1-771-gaae6eb0
didn't touch the code yet
Code:
Building CXX object CMakeFiles/GPU.dir/GPU/GLES/GLES_GPU.cpp.o
In file included from /home/pi/tmp/ppsspp/GPU/GLES/GLES_GPU.h:28:0,
                 from /home/pi/tmp/ppsspp/GPU/GLES/GLES_GPU.cpp:32:
/home/pi/tmp/ppsspp/GPU/GLES/TransformPipeline.h:67:7: error: expected identifier before ‘int’
/home/pi/tmp/ppsspp/GPU/GLES/TransformPipeline.h:67:14: error: expected unqualified-id before ‘{’ token
/home/pi/tmp/ppsspp/GPU/GLES/TransformPipeline.h: In constructor ‘VertexArrayInfo::VertexArrayInfo()’:
/home/pi/tmp/ppsspp/GPU/GLES/TransformPipeline.h:55:12: error: ‘VAI_NEW’ was not declared in this scope
In file included from /home/pi/tmp/ppsspp/GPU/GLES/GLES_GPU.h:29:0,
                 from /home/pi/tmp/ppsspp/GPU/GLES/GLES_GPU.cpp:32:
/home/pi/tmp/ppsspp/GPU/GLES/TextureCache.h: At global scope:
/home/pi/tmp/ppsspp/GPU/GLES/TextureCache.h:74:8: error: expected identifier before ‘int’
/home/pi/tmp/ppsspp/GPU/GLES/TextureCache.h:74:15: error: expected unqualified-id before ‘{’ token
make[2]: *** [CMakeFiles/GPU.dir/GPU/GLES/GLES_GPU.cpp.o] Error 1
make[1]: *** [CMakeFiles/GPU.dir/all] Error 2
make: *** [all] Error 2
btw, Where should I put " #undef enum " line?

EDIT
gcc version 4.6.3 (Debian 4.6.3-14+rpi1) is one installed on my RPi
Is it too old to compile this with no errors?
Find all posts by this user
Quote this message in a reply
10-08-2013, 07:11 PM
Post: #42
RE: PPSSPP for Pi
Hey. Raspberri Pi recently has an update with OpenGLES 2.0 hardware support. Can someone test it now? Smile I'm curious if PPSSPP can work on Raspberry Smile
Find all posts by this user
Quote this message in a reply
10-21-2013, 03:12 PM (This post was last modified: 10-21-2013 03:41 PM by Sim_Piko.)
Post: #43
RE: PPSSPP for Pi
After seeing this changes I'm gonna try to compile it again. We'll see what gonna happen.
EDIT: Well, at least for me, nothing changed
Code:
Scanning dependencies of target GPU
[ 44%] Building CXX object CMakeFiles/GPU.dir/GPU/GLES/GLES_GPU.cpp.o
In file included from /home/pi/tmp/ppsspp/GPU/GLES/GLES_GPU.h:28:0,
                 from /home/pi/tmp/ppsspp/GPU/GLES/GLES_GPU.cpp:32:
/home/pi/tmp/ppsspp/GPU/GLES/TransformPipeline.h:68:7: error: expected identifier before ‘int’
/home/pi/tmp/ppsspp/GPU/GLES/TransformPipeline.h:68:14: error: expected unqualified-id before ‘{’ token
/home/pi/tmp/ppsspp/GPU/GLES/TransformPipeline.h: In constructor ‘VertexArrayInfo::VertexArrayInfo()’:
/home/pi/tmp/ppsspp/GPU/GLES/TransformPipeline.h:56:12: error: ‘VAI_NEW’ was not declared in this scope
In file included from /home/pi/tmp/ppsspp/GPU/GLES/GLES_GPU.h:29:0,
                 from /home/pi/tmp/ppsspp/GPU/GLES/GLES_GPU.cpp:32:
/home/pi/tmp/ppsspp/GPU/GLES/TextureCache.h: At global scope:
/home/pi/tmp/ppsspp/GPU/GLES/TextureCache.h:74:8: error: expected identifier before ‘int’
/home/pi/tmp/ppsspp/GPU/GLES/TextureCache.h:74:15: error: expected unqualified-id before ‘{’ token
make[2]: *** [CMakeFiles/GPU.dir/GPU/GLES/GLES_GPU.cpp.o] Error 1
make[1]: *** [CMakeFiles/GPU.dir/all] Error 2
make: *** [all] Error 2
ccmake conf:
Code:
ANDROID                          OFF
ARM                              ON
BLACKBERRY                       OFF
CMAKE_BUILD_TYPE                 Release
CMAKE_INSTALL_PREFIX             /usr/local
HEADLESS                         OFF
IOS                              OFF
MAEMO                            OFF
MIPS                             OFF
PANDORA                          OFF
SDLMAIN_LIBRARY                  /usr/lib/arm-linux-gnueabihf/libSDLmain.a
SDL_INCLUDE_DIR                  /usr/include/SDL
SDL_LIBRARY                      /usr/lib/arm-linux-gnueabihf/libSDLmain.a;/usr/lib/arm-linux-gnueabihf/libSDL.so;-lpthread
USE_FFMPEG                       ON
USING_GLES2                      ON
USING_QT_UI                      OFF
X86                              OFF
Find all posts by this user
Quote this message in a reply
12-01-2013, 07:37 PM (This post was last modified: 12-07-2013 11:24 AM by Sim_Piko.)
Post: #44
RE: PPSSPP for Pi
Alright, I think I've finally fixed that GLES_GPU related problem I had by adding this to cmake:
Code:
CMAKE_CXX_FLAGS = -I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -L/opt/vc/lib -lbz2 -lGLESv2 -lEGL -lm -lbcm_host
commenting out "gl3stub.c", "gl3stub.h" from CMakeLists.txt and "glDrawTextureNV" from "GPU/GLES/Framebuffer.cpp"

Now emulator can compile, but launching it leaves me with this error:
Code:
[email protected] ~/tmp/psp_com $ ./PPSSPPSDL
I: /home/pi/tmp/ppsspp/native/file/zip_read.cpp:304: I: Registered VFS for prefix : assets/
I: /home/pi/tmp/ppsspp/native/file/zip_read.cpp:304: I: Registered VFS for prefix : /home/pi/
I: /home/pi/tmp/ppsspp/UI/NativeApp.cpp:296: I: Logman: 0x2603f50
Pixels: 1280 x 1024
Virtual pixels: 1280 x 1024
I: /home/pi/tmp/ppsspp/native/gfx_es2/gl_state.cpp:129: I: GPU Vendor : (null)
Segmentation fault
[email protected] ~/tmp/psp_com $
Find all posts by this user
Quote this message in a reply
12-17-2013, 05:27 PM (This post was last modified: 12-17-2013 05:28 PM by Sim_Piko.)
Post: #45
RE: PPSSPP for Pi
I somehow managed to run gdb
Code:
[email protected] ~/tmp/psp_com $ gdb ./PPSSPPSDL
GNU gdb (GDB) 7.4.1-debian
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "arm-linux-gnueabihf".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/pi/tmp/psp_com/PPSSPPSDL...done.
(gdb) run
Starting program: /home/pi/tmp/psp_com/PPSSPPSDL
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".
warning: the debug information found in "/usr/lib/debug//usr/lib/arm-linux-gnueabihf/libstdc++.so.6.0.17" does not match "/usr/lib/arm-linux-gnueabihf/libstdc++.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug/usr/lib/arm-linux-gnueabihf/libstdc++.so.6.0.17" does not match "/usr/lib/arm-linux-gnueabihf/libstdc++.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//lib/arm-linux-gnueabihf/libgcc_s.so.1" does not match "/lib/arm-linux-gnueabihf/libgcc_s.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug/lib/arm-linux-gnueabihf/libgcc_s.so.1" does not match "/lib/arm-linux-gnueabihf/libgcc_s.so.1" (CRC mismatch).

D: /home/pi/tmp/ppsspp/native/file/zip_read.cpp:302: D: Registered VFS for prefix : /home/pi/tmp/psp_com/assets/
D: /home/pi/tmp/ppsspp/native/file/zip_read.cpp:302: D: Registered VFS for prefix : /home/pi/tmp/psp_com/
D: /home/pi/tmp/ppsspp/native/file/zip_read.cpp:302: D: Registered VFS for prefix : /home/pi/
16:08:609 Core/Config.cpp:403 I[LOAD]: Loading controller config: /home/pi/.config/ppsspp/PSP/SYSTEM/controls.ini
[New Thread 0xb5685320 (LWP 3551)]
Pixels: 960 x 544
Virtual pixels: 960 x 544
[New Thread 0xb4e85320 (LWP 3552)]
I: /home/pi/tmp/ppsspp/native/gfx_es2/gl_state.cpp:127: I: GPU Vendor : (null) ; GL version str: N/A

Program received signal SIGSEGV, Segmentation fault.
0xb6c3e4cc in strstr () from /lib/arm-linux-gnueabihf/libc.so.6
(gdb) where
#0  0xb6c3e4cc in strstr () from /lib/arm-linux-gnueabihf/libc.so.6
#1  0x0089a064 in CheckGLExtensions ()
    at /home/pi/tmp/ppsspp/native/gfx_es2/gl_state.cpp:198
#2  0x0030adf4 in NativeInitGraphics ()
    at /home/pi/tmp/ppsspp/UI/NativeApp.cpp:405
#3  0x0087e9e8 in main (argc=1, argv=0xbefff634)
    at /home/pi/tmp/ppsspp/native/base/PCMain.cpp:483
(gdb)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: