Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tales of the World Radiant Mythology 3
05-21-2013, 04:50 AM (This post was last modified: 05-21-2013 06:42 AM by nightmesh.)
Post: #16
RE: Tales of Radiant Mythology 3
It's letting you get way in game now on the lasted build. It's playable to an extent but it does have a few problems.

You can't see your party in the party menu but that's not a big deal since you can see everyone on the exploring/battle fields. I think this is the same bug that wont let you see your character during creation.

The game eternally loads at random. Usually while exploring. I've noticed I get this when monsters that randomly generate don't appear in the area at all. When you move to the next screen you can't progress past the loading screen.

You can't control your character during battle. JPCSP had the same problem. No idea how they fixed it. For now your gonna have to set him/her to auto battle and hope for the best.

Also the game freezes completely if it has to play a single A3+. That might just be for a few people like me that might not have registered files correctly.


Attached File(s)
.zip  ppsspp.zip (Size: 19.29 KB / Downloads: 201)
Find all posts by this user
Quote this message in a reply
05-22-2013, 06:36 AM (This post was last modified: 05-22-2013 06:37 AM by RPG Advocate.)
Post: #17
RE: Tales of Radiant Mythology 3
Quote:Also the game freezes completely if it has to play a single A3+. That might just be for a few people like me that might not have registered files correctly.

This problem is actually under investigation. You wouldn't happen to be using a 64-bit version of Windows, would you?

So far, it seems everyone who has the Atrac3+ freezing issue is on x64.
Find all posts by this user
Quote this message in a reply
05-22-2013, 05:51 PM (This post was last modified: 05-22-2013 07:32 PM by nightmesh.)
Post: #18
RE: Tales of Radiant Mythology 3
Yah it's 64 but I'm using the 32 bit PPSSPP. I'll see if emucr has 64bit build for the latest automated build.

Edit:They do but it still crashes.
Find all posts by this user
Quote this message in a reply
05-24-2013, 04:48 PM
Post: #19
RE: Tales of Radiant Mythology 3
You can control your player character during battle in the newest build.
Find all posts by this user
Quote this message in a reply
05-30-2013, 05:07 AM
Post: #20
RE: Tales of Radiant Mythology 3
(05-24-2013 04:48 PM)nightmesh Wrote:  You can control your player character during battle in the newest build.

Sorry to bother you sir, but I found 2 new bugs on this game..

First, about the Optical Field (the save point in game) sound effect, which is always played into infinite sound loop when you touch it. The more you touch it, the sound effect will play more stronger (but still infinite sound loop). I found this bug on orphis build v.0.7.6 - 881 until 905.. The normal sound effect without looping happens from build 876..

Second, about the save data. Like what you said earlier, this game still encounter random bugs like when exploring, can't get past loading screen.. I've encounter that several times, but the last time it make serious critical hit to my save data Huh
When i'm trying to load save data again (after restart), my PPSSPP stopped working. I tried it to another build, from the newest to the oldest but it still not solved. But when i try to load my same savedata in JPCSP, it works normally. Huh

I wonder, could this be a new bug? I've tried any game, but the savedata still works normally, except for this one. Can you please do something about this? I will be waiting.. Thanks in advance and sorry for my bad english Smile

*Play Tales of The World Radiant Mythology 3 using Windows 7 32-bit, PPSSPP orphis build v0.7.6-876-g40877cf*
Find all posts by this user
Quote this message in a reply
05-30-2013, 09:07 PM (This post was last modified: 05-30-2013 09:43 PM by nightmesh.)
Post: #21
RE: Tales of Radiant Mythology 3
I believe I've run into the sound bug your talking about in the lasted build. It'll keep playing the sound infintinly until the game crashes. I'll try and recreat the bug so I make a log later. Also could you post a log from trying to load the save data?

Edit:Log added.


Attached File(s)
.zip  ppsspp.zip (Size: 18.34 KB / Downloads: 200)
Find all posts by this user
Quote this message in a reply
05-30-2013, 10:32 PM
Post: #22
RE: Tales of Radiant Mythology 3
(05-30-2013 09:07 PM)nightmesh Wrote:  I believe I've run into the sound bug your talking about in the lasted build. It'll keep playing the sound infintinly until the game crashes. I'll try and recreat the bug so I make a log later. Also could you post a log from trying to load the save data?

Edit:Log added.

About the savedata, I think I know the problem sir.. When I try to load the game into another build, I accidently saving the game when the "Encrypt Save" option was on. I don't know in which build, but I think that's the problem so I can't load my data anymore (I played the game without Encrypt Save from the very start). Sorry for my mistake before Smile

But about the sound bug, it still happen until the newest build (935). In my opinion, maybe the bug is related somehow to VAG? Or maybe from low level attrac decoder.. But I'm still not sure what it is.. Anyway, please fix this soon. I hope the best for dev team. Thanks sir Smile
Find all posts by this user
Quote this message in a reply
05-31-2013, 12:58 AM
Post: #23
RE: Tales of Radiant Mythology 3
Is there anything logged at approximately the same time as the sound doesn't stop?

-[Unknown]
Find all posts by this user
Quote this message in a reply
05-31-2013, 02:42 AM
Post: #24
RE: Tales of Radiant Mythology 3
(05-31-2013 12:58 AM)[Unknown] Wrote:  Is there anything logged at approximately the same time as the sound doesn't stop?

-[Unknown]

It constantly starts "StreamDataReader" threads and immediately exits them. All the threads appear to be retrieving data from the same memory address (argPtr=09981AC0).
Find all posts by this user
Quote this message in a reply
05-31-2013, 02:59 AM
Post: #25
RE: Tales of Radiant Mythology 3
I believe this is it. Made sure to make that sound and only that one before exiting.
Quote:50:20:400 user_main I[HLE]: HLE\sceFont.cpp:835 sceFontGetCharGlyphImage(99c1194, 44, 9958830)
50:27:968 cSoundMusic I[HLE]: HLE\sceKernelThread.cpp:1883 368=sceKernelCreateThread(name=StreamDataReader, entry=08aa80e8, prio=14, stacksize=4096)
50:27:968 cSoundMusic I[HLE]: HLE\sceKernelThread.cpp:1926 sceKernelStartThread(thread=368, argSize=16, argPtr=09981ac0)
50:27:969 StreamDataRe I[HLE]: HLE\sceKernelThread.cpp:2030 sceKernelExitThread(1)
50:28:100 cSoundMusic I[HLE]: HLE\sceAtrac.cpp:461 sceAtracAddStreamData(5, 00020000)
Find all posts by this user
Quote this message in a reply
05-31-2013, 03:35 AM
Post: #26
RE: Tales of Radiant Mythology 3
Okay, that thread is definitely not happy if it's looping and exiting with a failure status (in programming, non-zero thread/process exit codes typically mean failure.)

Unfortunately will probably need a debug build to see what syscalls are in between the start of the thread and the exit. One of them is probably the trouble (or else the data being fed to it.)

Suspect io or atrac.

-[Unknown]
Find all posts by this user
Quote this message in a reply
06-10-2013, 09:09 AM
Post: #27
RE: Tales of Radiant Mythology 3
One of the recent updates caused a weird behavior change. When I load a save from the first save point, the looping sound effect doesn't loop immediately, but the return value for the StreamDataReader thread is still 1.

Then, after the mandatory battle, the sound starts looping again.

My guess is that the sound is being muted somehow, but the problem isn't actually fixed.
Find all posts by this user
Quote this message in a reply
06-10-2013, 02:24 PM
Post: #28
RE: Tales of Radiant Mythology 3
It's hard to say if the 1 is correct or not.

From what I could debug, other games at least (I don't have this one) are often muting the sound effect, like for example Twin Brave's demo. Then they just leave it and don't care, it keeps playing muted.

It shouldn't start looping again later, though, that's strange...

-[Unknown]
Find all posts by this user
Quote this message in a reply
06-15-2013, 03:48 AM (This post was last modified: 06-24-2013 04:21 AM by Tsukuyomi.)
Post: #29
RE: Tales of Radiant Mythology 3
Hopefully someone find a fix for those bugs ingame
Cause this is the only game aside from vesperia itself
That flynn is playable (I don't have a x360 or a ps3)
Edit: its fully playable in v0.8 now, except that after a battle the sound for casting a spell stays for a while, slowing down my vps (or its probably my phone?Samsung galaxy s advance)
And some random crashes but aside of these everything is all right
Find all posts by this user
Quote this message in a reply
06-24-2013, 12:55 PM (This post was last modified: 06-24-2013 12:57 PM by Jokuma15.)
Post: #30
Tales of the World: Radiant Mythology 3
Software/Game tested: Tales of the World: Radiant Mythology 3
File format(ISO/CSO/EBOOT): ISO
Version: Pre-v0.9 (v0.8-27)
OS: Android
Compatibility level(nothing/intro/menus/ingame/playable): Ingame
Other info: Crashes after the after a light passes by the girl.

Code:
06-24 09:40:03.199 I/ActivityManager(1350): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.ppsspp.ppsspp/.PpssppActivity } from pid 1503
06-24 09:40:03.229 V/HtcAppUsageStats(1350): (launch app, package): (PPSSPP, org.ppsspp.ppsspp)
06-24 09:40:03.239 I/ActivityManager(1350): Start proc org.ppsspp.ppsspp for activity org.ppsspp.ppsspp/.PpssppActivity: pid=3939 uid=10107 gids={1015, 3003}
06-24 09:40:03.519 D/dalvikvm(3939): Trying to load lib /data/data/org.ppsspp.ppsspp/lib/libppsspp_jni.so 0x4051e658
06-24 09:40:03.650 D/dalvikvm(3939): Added shared lib /data/data/org.ppsspp.ppsspp/lib/libppsspp_jni.so 0x4051e658
06-24 09:40:03.650 D/dalvikvm(3939): No JNI_OnLoad found in /data/data/org.ppsspp.ppsspp/lib/libppsspp_jni.so 0x4051e658, skipping init
06-24 09:40:03.690 I/NativeApp(3939): NativeApp::Init: APK path: /data/app/org.ppsspp.ppsspp-1.apk
06-24 09:40:03.700 I/NativeApp(3939): Registered VFS for prefix : /data/data/org.ppsspp.ppsspp/files/
06-24 09:40:03.760 I/ActivityManager(1350): Displayed org.ppsspp.ppsspp/.PpssppActivity: +526ms
06-24 09:40:17.063 I/NativeApp(3939): 40:17:067 jni/../../Core/Config.cpp:255 I[LOAD]: Config saved: /data/data/org.ppsspp.ppsspp/files//ppsspp.ini
06-24 09:40:17.063 I/NativeApp(3939): 40:17:067 jni/../../Core/System.cpp:70 I[HLE]: PPSSPP v0.8-27-gfaa6cd8
06-24 09:40:17.093 I/NativeApp(3939): Attempting to load atrac3plus decoder from /data/data/org.ppsspp.ppsspp/files/libat3plusdecoder.so
06-24 09:40:17.123 I/NativeApp(3939): Successfully loaded atrac3plus decoder from /data/data/org.ppsspp.ppsspp/files/libat3plusdecoder.so
06-24 09:40:17.183 I/NativeApp(3939): 40:17:187 jni/../../Common/FileUtil.cpp:204 I[COMMON]: CreateFullPath: path /mnt/sdcard/PSP/PPSSPP_STATE
06-24 09:40:17.183 I/NativeApp(3939): 40:17:188 jni/../../Common/FileUtil.cpp:208 I[COMMON]: CreateFullPath: path exists /mnt/sdcard/PSP/PPSSPP_STATE
06-24 09:41:33.687 I/DEBUG   (2690): pid: 3939, tid: 3949  >>> org.ppsspp.ppsspp <<<
06-24 09:41:33.807 I/DEBUG   (2690):          #00  pc 0000e6bc  /data/data/org.ppsspp.ppsspp/files/libat3plusdecoder.so
06-24 09:41:33.807 I/DEBUG   (2690):          #01  lr 80d0e865  /data/data/org.ppsspp.ppsspp/files/libat3plusdecoder.so
06-24 09:41:33.817 I/DEBUG   (2690):     45caa5e0  80d21528  /data/data/org.ppsspp.ppsspp/files/libat3plusdecoder.so
06-24 09:41:33.817 I/DEBUG   (2690):     45caa5e4  80d21528  /data/data/org.ppsspp.ppsspp/files/libat3plusdecoder.so
06-24 09:41:33.817 I/DEBUG   (2690):     45caa5e8  80d217dc  /data/data/org.ppsspp.ppsspp/files/libat3plusdecoder.so
06-24 09:41:33.817 I/DEBUG   (2690):     45caa5ec  80d2174c  /data/data/org.ppsspp.ppsspp/files/libat3plusdecoder.so
06-24 09:41:34.398 E/InputDispatcher(1350): channel '40d53ea8 org.ppsspp.ppsspp/org.ppsspp.ppsspp.PpssppActivity (server)' ~ Consumer closed input channel or an error occurred.  events=0x8
06-24 09:41:34.408 E/InputDispatcher(1350): channel '40d53ea8 org.ppsspp.ppsspp/org.ppsspp.ppsspp.PpssppActivity (server)' ~ Channel is unrecoverably broken and will be disposed!
06-24 09:41:34.528 I/WindowManager(1350): WIN DEATH: Window{40d53ea8 org.ppsspp.ppsspp/org.ppsspp.ppsspp.PpssppActivity paused=false}
06-24 09:41:34.528 I/ActivityManager(1350): Process org.ppsspp.ppsspp (pid 3939) has died.

Though I don't do this much, it's only because I'm sort of inexperienced with logs. I hope this is useful, please tell me if I'm doing this right. If it is, I'll do more of these!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: