Post Reply 
Thread Rating:
  • 5 Votes - 4.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Star Ocean: Second Evolution
01-24-2016, 12:47 AM
Post: #151
RE: Star Ocean: Second Evolution
Did you tried the latest beta?
Like I said,there was a bug related to this before(after 1.1.1)but it was fixed since v1.1.1-559-g09851c8(I think)

Using PPSSPP on Windows 7 x64 SP1
i7 4771 3.5Ghz,GTX750TI,16GB RAM

Batch iso <=> cso converter
Save Game\States Manager
Find all posts by this user
Quote this message in a reply
01-24-2016, 09:55 PM
Post: #152
RE: Star Ocean: Second Evolution
FWIW, both of those use the "Hall" reverb effect. Could be that it's off.

I hear some light fuzz/static or something during the bgm, but as far as the menu accept sound - that's hard to tell. PPSSPP was doing zero reverb before, and in many places it has obviously improved the sound to enable reverb. But it's definitely different. I can see that the waveforms are different, and I can slightly hear a difference in the two... but I will never be able to be sure which the actual PSP is playing.

I'm a little confused, though. You said the problem started between v1.1.1-109-g42c7993 and v1.1.1-119-g5ebb5d5 (which means it was AFTER v1.1.1), but the comparison you gave was between v1.0.1 and v1.1.1?

Anyway, if you can tell for sure, are you sure the new sound is different from what a real PSP plays? One thing I can be pretty sure about: the pre-reverb sound is definitely not the same as the PSP. Because the PSP is applying reverb. So our reverb might be wrong, but the previous sound was wrong also.

Find all posts by this user
Quote this message in a reply
03-23-2016, 04:43 PM (This post was last modified: 03-23-2016 06:45 PM by Murmurs.)
Post: #153
RE: Star Ocean: Second Evolution
So, I had an issue similar to lucasthenukus and the prescribed fix does indeed work.

The game would black screen after the cutsceen where Claude wakes up in the forest and it switches back to the normal map. Switching to Direct3D9 from OpenGL corrects this error.

However, for me at least, it introduces a new one. When using Direct3D9 the world map and battle maps will not fully render. They will just be pink blocks that will sometimes cut in to the actual terrain when moving around. If I switch to No Buffered Rendering, this corrects the issue and the world map and battle map will render properly. Other maps, however, will not. With No Buffered Rendering on, cities and caves are just a black screen. So I either can actually move around cities with Buffered Rendering or I can move around the world map and battles with No Buffered Rendering.

I've attempted to switch the back in back to OpenGL, and everything renders fine with Buffered Rendering on, however the game will occasionally crash when transitioning between screen. I honestly do not know what other settings might help, I've tried numerous different combinations to no avail.

I am running PPSSPP ver 1.2.2. My OS is Windows 10. My graphics card is AMD Radeon R9 380. I have 16 GB of RAM. I have checked that I have the latest drivers from AMD.

Edit: Interesting. I disabled Raptr from AMD and I believe everything is sorted now. Running Direct3D9 and Buffered Rendering, all maps load properly so far and no crashes.
Find all posts by this user
Quote this message in a reply
04-14-2017, 11:29 PM
Post: #154
RE: Star Ocean: Second Evolution
Been playing this for the past week now and only yesterday noticed some problems regarding my item menu- specifically my weapons category. Today I opened the game with the log console running on the side so I could figure out the underlying problem and post it here.

What basically happens is that when I try to access the Weapons category in my Items menu, the screen goes black and the game freezes, in which an error shows up. [See Log Console.png]

I have to exit the game to relaunch it after that to play.

The game also freezes when in the sell or creation menu, when I come across a strange item. [See invisible item.png]

The name of the item is invisible, and the sell price is in the negatives. If I put my cursor over it, the game will also freeze, and I have to quit. I don't know how to get rid of it or what it is, nor at what point it got in my inventory. I'm fine as long as I don't try to touch it, but it's scary going through my inventory while in a dungeon and accidentally scrolling down over the thing.

I had this on a previous version of the emulator and tried using the most recent, with no change. I realize this thread has gone awhile without any replies, but is anyone out there that can give me some help, please?

Attached File(s) Thumbnail(s)
Find all posts by this user
Quote this message in a reply
04-15-2017, 05:51 PM
Post: #155
RE: Star Ocean: Second Evolution
Well, this means the game is crashing. Have you used any cheats?

Can you try the save on a real PSP, or upload the save so someone else can try? If you are using save states, try saving in game and loading the game - save states save even bugs.

Most likely something went wrong in your inventory, possibly due to a cheat code, and now that item is broken. If it happens on a real PSP, then it's emulating properly, and probably the best solution is save data hacking or a cheat code to remove the item.

Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump: