Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Compatibility
03-29-2015, 01:45 PM (This post was last modified: 03-30-2015 05:42 PM by vnctdj.)
Post: #1
[Solved] Compatibility
Hey,
My computer runs Intel HD Graphics 4000, yet while trying to run PPSSPP it shows the error message of OpenGL 2.0 non-compliance.
Any help will be appreciated. Thank you.
Find all posts by this user
Quote this message in a reply
03-29-2015, 03:00 PM
Post: #2
RE: Compatability
Download the GPU drivers for your operating system from the intel site https://downloadcenter.intel.com/search?...el+hd+4000
Find all posts by this user
Quote this message in a reply
03-29-2015, 07:22 PM
Post: #3
RE: Compatability
Apparently, the driver software is up to date.
Find all posts by this user
Quote this message in a reply
03-29-2015, 07:35 PM (This post was last modified: 03-29-2015 07:35 PM by GuenosNoLife.)
Post: #4
RE: Compatability
Enable D3D on PPSSPP, don't use OpenGL Wink
If you don't have pop-up for change engine, go to : \memstick\PSP\SYSTEM\ppsspp.ini & search "GPUBackend = 0" change 0 to 1
And open PPSSPP

Smile

Primary Computer: [CPU] i5 2500, [CG] GTX 560 Ti, 8 GB RAM, W7 x64
Second Laptop: [CPU] Intel Atom N270, 1 GB RAM, WinXP SP3
Phone: ZenFone 2 ZE550ML
Find all posts by this user
Quote this message in a reply
03-30-2015, 04:00 AM
Post: #5
RE: Compatability
The SYSTEM folder is empty. :/
Find all posts by this user
Quote this message in a reply
03-30-2015, 05:49 AM
Post: #6
RE: Compatibility
Attached to this post is a ppsspp.ini (inside the zip archive of course) with the backend changed to D3D and all the other setting being default ones.

Just put that ppsspp.ini into your empty system folder.


Attached File(s)
.zip  inifile.zip (Size: 1.81 KB / Downloads: 97)
Find all posts by this user
Quote this message in a reply
03-30-2015, 06:28 AM
Post: #7
RE: Compatibility
I really appreciate everyone's help and all but it's the same story everytime. :/


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
03-30-2015, 07:00 AM
Post: #8
RE: Compatibility
@Hanie 0.9.8 is pretty ancient you should update, no clue if it had any issues with intel graphics and ogl, but it certainly didn't had dx support which might work better on problematic/buggy graphic drivers on windows.
Download latest version from here ~ either 1.0.1 or any newer one from buildbot and even if ogl will not work, new version should automatically switch to DX or give you an option for it.

http://forums.ppsspp.org/showthread.php?tid=6594 - Custom PPSSPP Shaders!
http://forums.ppsspp.org/showthread.php?tid=3590&pid=117172#pid117172 - simple CE scripts to help creating CWCheats,
https://github.com/LunaMoo/PPSSPP_workarounds - CWCheat workarounds.
Find all posts by this user
Quote this message in a reply
03-30-2015, 08:14 AM
Post: #9
RE: Compatibility
Thanks a lot. Smile
It works now.
Find all posts by this user
Quote this message in a reply
03-30-2015, 08:17 AM
Post: #10
RE: Compatibility
Thanks i will try now.
Find all posts by this user
Quote this message in a reply
03-30-2015, 05:42 PM
Post: #11
RE: [Solved] Compatibility
Thread's title edited.

♦ Intel Core i7-6700HQ | 16 GB RAM | NVIDIA GeForce GTX 960M | Debian Testing
♦ Intel Core i7-2630QM | 4 GB RAM | NVIDIA GeForce GT 540M | Debian Testing
♦ PSP-3004 | 6.60 PRO-C2
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: