Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sonic Rivals 2
02-21-2013, 02:50 AM
Post: #1
Sonic Rivals 2
Starts off full speed going through menus. Everything shows. Perfect. I haven't checked other game modes, but I selected free play, chose my character and all that jazz. When the level started though, All I saw were black and blue lines, with the countdown at the top before the race starts, and the progress meter at the bottom. After checking different settings, switching off buffered rendering will fix the black stripes issue., but the character and level itself are still invisible. (Unless you're jumping, then you can see the character.) For now at least it doesn't display enough graphics to be playable.
Find all posts by this user
Quote this message in a reply
03-13-2013, 05:32 AM (This post was last modified: 03-13-2013 05:39 AM by Tezuka.)
Post: #2
RE: Sonic Rivals 2
It does the same things for me too Sad, will they be able to Fix this?

[Image: 3W9bRks.png]

Welcome to my PSP Live streams:

http://www.twitch.tv/knightraider
Find all posts by this user
Quote this message in a reply
06-05-2013, 07:16 AM
Post: #3
RE: Sonic Rivals 2
Same thing happens with the first Sonic Rivals as the games are nearly identical.
Find all posts by this user
Quote this message in a reply
06-24-2013, 01:41 AM
Post: #4
RE: Sonic Rivals 2
v0.8 -6 still has this issue, black lines and game rendered upside down.

Taking buffered rendering off produces just a black screen.
Same issue as Death Jr II
Find all posts by this user
Quote this message in a reply
06-26-2013, 09:19 PM
Post: #5
RE: Sonic Rivals 2
I still have the same issue where it shows you upside down, Would love to play this game again, as my brother has the psp in repairs atm.

Welcome to my PSP Live streams:

http://www.twitch.tv/knightraider
Find all posts by this user
Quote this message in a reply
07-01-2013, 05:01 AM
Post: #6
Wink Upside down screen and black bars!
Hi, I'm really new on here, not tried PSP emulation before as I didn't even know it could be done... pleased to see it seems to be coming on fine.

But anyway, I wondered if anyone could help me please?

The emulator boots up perfectly- I have been trying to run Sonic Rivals 2 but with limited success. The sound and menus all work perfectly. However, when you access the gameplay some strange effects are observed. The game plays upside down! Still to the right, but upside down- there are four black lines across the screen also, evenly distanced which cover around a third of the screen...
The foreground UI- rings, lives, etc. are all the right way up though. The game appears to be running very nicely in the background- the graphics are perfect- It's just obviously having lines through the screen and an upside down playing field ruins the experience somewhat. Does anyone know how to fix this?

Many thanks for any help. Cool
Find all posts by this user
Quote this message in a reply
07-01-2013, 10:29 AM (This post was last modified: 07-01-2013 10:30 AM by vnctdj.)
Post: #7
RE: Upside down screen and black bars!
(07-01-2013 05:01 AM)Vyperii Wrote:  Hi, I'm really new on here, not tried PSP emulation before as I didn't even know it could be done... pleased to see it seems to be coming on fine.

But anyway, I wondered if anyone could help me please?

The emulator boots up perfectly- I have been trying to run Sonic Rivals 2 but with limited success. The sound and menus all work perfectly. However, when you access the gameplay some strange effects are observed. The game plays upside down! Still to the right, but upside down- there are four black lines across the screen also, evenly distanced which cover around a third of the screen...
The foreground UI- rings, lives, etc. are all the right way up though. The game appears to be running very nicely in the background- the graphics are perfect- It's just obviously having lines through the screen and an upside down playing field ruins the experience somewhat. Does anyone know how to fix this?

Many thanks for any help. Cool

Given that the issue you mentioned is related to this game in particular, you should have posted in the game's thread Wink

I move your post in it.

♦ Intel Core i7-6700HQ | 16 GB RAM | NVIDIA GeForce GTX 960M | Debian Testing --- Windows 7 Professional SP1 x64
♦ Intel Core i7-2630QM | 4 GB RAM | NVIDIA GeForce GT 540M | Debian Testing
♦ PSP-3004 | 6.60 PRO-C2
Find all posts by this user
Quote this message in a reply
07-01-2013, 01:18 PM
Post: #8
RE: Sonic Rivals 2
Sorry... and thanks... So I guess other people are having this issue... Any updates on fixing it?


(07-01-2013 10:29 AM)vnctdj Wrote:  
(07-01-2013 05:01 AM)Vyperii Wrote:  Hi, I'm really new on here, not tried PSP emulation before as I didn't even know it could be done... pleased to see it seems to be coming on fine.

But anyway, I wondered if anyone could help me please?

The emulator boots up perfectly- I have been trying to run Sonic Rivals 2 but with limited success. The sound and menus all work perfectly. However, when you access the gameplay some strange effects are observed. The game plays upside down! Still to the right, but upside down- there are four black lines across the screen also, evenly distanced which cover around a third of the screen...
The foreground UI- rings, lives, etc. are all the right way up though. The game appears to be running very nicely in the background- the graphics are perfect- It's just obviously having lines through the screen and an upside down playing field ruins the experience somewhat. Does anyone know how to fix this?

Many thanks for any help. Cool

Given that the issue you mentioned is related to this game in particular, you should have posted in the game's thread Wink

I move your post in it.
Find all posts by this user
Quote this message in a reply
09-03-2013, 07:14 PM
Post: #9
RE: Sonic Rivals 2
This game needs to be tested again with the newest version.
Find all posts by this user
Quote this message in a reply
09-04-2013, 09:37 AM
Post: #10
RE: Sonic Rivals 2
In the latest build I cant seem to get any visuals whatsoever.
Find all posts by this user
Quote this message in a reply
09-04-2013, 02:33 PM
Post: #11
RE: Sonic Rivals 2
you can see intro, menu, etc but not with gameplay with non-buffered render:[Image: owkx.jpg]

but you can see anything with buffer render turned on (idk but this seems a bit bright):
[Image: 6z9q.jpg]

note: if you turned on buffer render mid game you'll get blackscreen

my english is poor , sorry
Find all posts by this user
Quote this message in a reply
12-14-2013, 11:37 PM
Post: #12
RE: Sonic Rivals 2
Any fix yet?

Catch me if you can't catch me if you can't Cats are nice.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-15-2013, 09:39 PM
Post: #13
RE: Sonic Rivals 2
(12-14-2013 11:37 PM)Obi55 Wrote:  Any fix yet?

You can enable buffer render as mentioned in the post above yours, but you have to handle the increased brightness.
Find all posts by this user
Quote this message in a reply
12-16-2013, 02:41 AM
Post: #14
RE: Sonic Rivals 2
I know about that, but its pretty hard to handle.

Catch me if you can't catch me if you can't Cats are nice.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-16-2013, 04:05 AM (This post was last modified: 12-16-2013 04:06 AM by [Unknown].)
Post: #15
RE: Sonic Rivals 2
If you use Debug -> GE Debugger, and hit step draw, is the brightness ever correct?

Also, if you use the software renderer (it will be jaw droppingly slow) is it correct there? Or is it also wrong there (which would mean we don't even know why)?

-[Unknown]
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: