Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird Rainbow Screen?
03-11-2014, 09:55 PM
Post: #1
Weird Rainbow Screen?
I have tried multiple versions of the PPSSPP emulator and multiple games on it and when I load the game up I get this:

[Image: rainbowscreen_zpsd8b6043f.jpg]

Any idea what the problem is?
Find all posts by this user
Quote this message in a reply
03-11-2014, 11:51 PM
Post: #2
RE: Weird Rainbow Screen?
Hello Link00452, and welcome to the forums.

As is customary for issue resolution, please provide us with the following details:-

1. Most importantly, your system information (Launch PPSSPP --> Settings --> System --> Developer Tools --> System Information)

2. PPSSPP versions you've used.

3. The games you've tried. (I see Yu-gi-oh GX Tag Force 2 in the screenshot, any others you've tried will also be very helpful)

Thanks for your time.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
03-12-2014, 01:16 AM
Post: #3
RE: Weird Rainbow Screen?
(03-11-2014 11:51 PM)solarmystic Wrote:  Hello Link00452, and welcome to the forums.

As is customary for issue resolution, please provide us with the following details:-

1. Most importantly, your system information (Launch PPSSPP --> Settings --> System --> Developer Tools --> System Information)

2. PPSSPP versions you've used.

3. The games you've tried. (I see Yu-gi-oh GX Tag Force 2 in the screenshot, any others you've tried will also be very helpful)

Thanks for your time.

1.

System info:

Name: Microsoft windows 7 service pack 1 (x64)
Lang/Region: en_US

CPU Information:

Name: AMD Phenom™ ll X4 805 Processor
Threads: 16(4 per core, 4 cores)

GPU Information:

Vendor: ATI tech inc.
Model: ATI radeon HD 3200 graphics (microsoft corporation WDDM 1.1)

OpenGL: 3.1.8787 BETA
GLSL: 1.30

2. v0.9.7.2-239-gea6fb93, v0.9.7.2-238-gadadf11, v0.9.7.2-237-g6b709a6

3. Yugioh GX tag force 2 and Final Fantasy 4

What happens is it starts as that weird rainbow screen, and then the beginning cutscene rolls without problem, then on the title screen it goes back to that rainbow screen.
Find all posts by this user
Quote this message in a reply
03-12-2014, 01:37 AM (This post was last modified: 03-12-2014 01:43 AM by solarmystic.)
Post: #4
RE: Weird Rainbow Screen?
Thanks for your response.

From the data you've presented, the most likely culprit would be your ATI drivers which are severely outdated, having been released in July 2009.

Update to these 11.11a drivers and try again, I'm pretty sure that's all you need to get PPSSPP up and running properly on your otherwise very capable system:-

http://drivers.softpedia.com/progDownloa...41318.html

I can vouch for the efficacy of those drivers personally, having used them myself without issues on my own ATI card for PPSSPP.

Ideally, this should be the end result after the driver upgrade:-

[Image: i0j0DYjPx4Lxj.png]

Related github issue:-

https://github.com/hrydgard/ppsspp/issues/4932

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
03-12-2014, 11:02 PM
Post: #5
RE: Weird Rainbow Screen?
Thanks it worked!
Find all posts by this user
Quote this message in a reply
03-13-2014, 12:04 AM
Post: #6
RE: Weird Rainbow Screen?
(03-12-2014 11:02 PM)Link00452 Wrote:  Thanks it worked!

You're most welcome, thanks for reporting back.

PPSSPP Modern Testbed:-
Intel Core i5 4690K @ 4.0 GHz
NVIDIA Geforce GTX 760 2GB GDDR5 VRAM @ 1138/6500 Mhz
16 GB DDR3 RAM @ 1600 MHz
Windows 7 x64 SP1

PPSSPP Ancient Testing Rig:-
Intel Core 2 Duo T9550 @ 2.8GHz
ATI Mobility Radeon 4670 1GB GDDR3 VRAM @ 843/882 MHz
8 GB DDR3 RAM @ 1066 MHz
Windows 7 x64 SP1
Find all posts by this user
Quote this message in a reply
06-06-2014, 02:20 PM
Post: #7
Weird Screen,
I am experiencing what other ppl seem to experience when i try and play a game on PPSSPP my screen turns all colorful type thermal design. what do i need to do to fix this??
Find all posts by this user
Quote this message in a reply
06-06-2014, 03:07 PM
Post: #8
RE: Weird Rainbow Screen?
(06-06-2014 02:20 PM)veronicadark Wrote:  I am experiencing what other ppl seem to experience when i try and play a game on PPSSPP my screen turns all colorful type thermal design. what do i need to do to fix this??

The solution that worked for Link00452 is updating his graphics drivers.
Maybe try that! Big Grin

WATCH MY MHFU GAMEPLAY VIDS AT: https://www.youtube.com/user/TheBarbanium
Have I been helpful to you in any way, nya?
You can click that "+" button ▼ to raise my reputation, meow!
Find all posts by this user
Quote this message in a reply
06-06-2014, 03:09 PM
Post: #9
RE: Weird Rainbow Screen?
(06-06-2014 02:20 PM)veronicadark Wrote:  I am experiencing what other ppl seem to experience when i try and play a game on PPSSPP my screen turns all colorful type thermal design. what do i need to do to fix this??

http://forums.ppsspp.org/showthread.php?tid=11273

3.8ghz i7 5930K, 16GB DDR4 RAM, 4GB Nvidia GTX 970, Asus X99 PRO, Windows 7 (SP1) x64
How to ask useful questions: http://support.microsoft.com/kb/555375
I'm not Dark_Alex, nor do I claim to be. Our nicknames are merely coincidence.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: