Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Black screen on boot after closing (+input bug)
07-14-2020, 09:04 PM (This post was last modified: 07-14-2020 09:56 PM by Smerg.)
Post: #1
Black screen on boot after closing (+input bug)
I have encountered an exceeding bizarre bug with PPSSPP.
The first time I run it on every startup, it's perfect. Golden. I run it at 6x render resolution downsampled to 3x with no framedrops.
But, for whatever reason, once I close it and try to start it up again, sometimes it turns into this.
[Image: z0SYQ7R.png]
Black screen, and clicking anything on the toolbar does nothing. Trying to load an ISO brings up no menu. Trying to change video settings from the toolbar doesn't even change the settings.
The only way I've found to fix this is, for some reason, restarting my computer.
If there's some sort of log I can provide to help clarify, please do tell.

Edit: It appears, for whatever reason, despite being on an SSD, it was just taking really, really long to start up. I have no idea why.

I suppose this is as good a time as any to bring up another weird bug: Exiting PPSSPP sometimes kills my mouse input. My laptop won't respond to mouse and controller inputs - in fact, it doesn't appear to register them as being there at all. The closest thing to a solution is enabling "Leave touchpad on when a mouse is connected", which makes me think there's some rogue HID service that gets very, very confused when PPSSPP is exited with my mouse/controller unplugged after being started up with them plugged in - I believe that plugged/unplugged discrepancy is what causes it. Again, the only solution I've found is restarting my computer.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Black screen on boot after closing (+input bug) - Smerg - 07-14-2020 09:04 PM

Forum Jump: