forums.PPSSPP.org
Ragnarok Tactics - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: Playable Games (/forumdisplay.php?fid=13)
+---- Thread: Ragnarok Tactics (/showthread.php?tid=661)

Pages: 1 2 3 4


RE: Ragnarok Tactics - rpglord - 06-02-2013 05:24 PM

This game crashes with with lots of errors, and disabling media engine does not seem to work - game still plays opening cinematics ( not in game cutscene ) and all music


RE: Ragnarok Tactics - ncognito - 07-05-2013 09:56 AM

Seems i have some sound, and sound effects.. biggest problem is the missing text, and when characters move or enemys attack, they stretch..


RE: Ragnarok Tactics - odakunz - 07-08-2013 02:29 AM

I have this weird thing where when a character is selected in the battle field, there will be options to move/atk/sit/etc, then when I choose move, usually the screen will show blue square path to move to, but sometimes there are no path showed and no reaction for any key pressed, literally get stuck. But the screen doesn't seems to freeze though, because the lower left character queue icon still blinks as if the game still active.

I have tried different ISOs and different builds, it solve the problem temporally through that battle field, but sometimes it happen again in another battle.

Anyone have this kind of bug ? Is it considered game related bug or emu bug ?

Update:
I think I found the reason it stuck, looking into the ppsspp log, something about out of memory and thread does not exist

06:48:910 AT3Thread0 E[HLE]: Util\BlockAllocator.cpp:131 Block Allocator failed to allocate 65536 (00010000) bytes of contiguous memory
06:48:910 AT3Thread0 E[HLE]: HLE\sceKernelThread.cpp:318 Failed to allocate stack for thread
06:48:910 AT3Thread0 E[HLE]: HLE\sceKernelThread.cpp:1883 sceKernelCreateThread(name=add_st_data): out of memory, 00010000 stack requested
06:48:910 AT3Thread0 E[HLE]: c:\buildagent\work\acf56f986e98e7c9\core\hle\sceKernel.h:446 Kernel: Bad object handle -2147352176 (80020190)
06:48:910 AT3Thread0 E[HLE]: HLE\sceKernelThread.cpp:1919 80020198=sceKernelStartThread(thread=-2147352176, argSize=16, argPtr=08bfd3b4): thread does not exist!
06:48:925 user_main E[HLE]: c:\buildagent\work\acf56f986e98e7c9\core\hle\sceKernel.h:446 Kernel: Bad object handle -2147352176 (80020190)
06:48:925 user_main E[HLE]: HLE\sceKernelThread.cpp:1281 sceKernelReferThreadRunStatus Error 80020198
06:49:330 user_main E[CPU]: Mips\MIPSInt.cpp:194 BREAK!

It looks like ppsspp try to allocate 10000 bytes for a thread, but it fail because of out of memory, so it break !
Any idea how to solve this ?


RE: Ragnarok Tactics - jarick - 07-24-2013 04:36 AM

same problem with my GNII, some text missing, is there a way to fix it? kindly PM me thxs


RE: Ragnarok Tactics - vanmido - 07-30-2013 09:48 AM

Text missing, but audio is working fine.


RE: Ragnarok Tactics - gianxpaulo - 08-12-2013 03:16 PM

yeah I just downloaded this iso, everything works fine for me except for the missing text


RE: Ragnarok Tactics - Gurlok - 08-12-2013 06:44 PM

(08-12-2013 03:16 PM)gianxpaulo Wrote:  yeah I just downloaded this iso, everything works fine for me except for the missing text

Read the rules. No piracy talk allowed here.


RE: Ragnarok Tactics - RPG Advocate - 08-12-2013 08:20 PM

Quote:Read the rules. No piracy talk allowed here.

He's actually OK on this one. The rules say:

Quote:Don´t ask for warez/where to download games!
Don´t post links to download games. Dump them with your psp. If you don´t own them then go and buy them.

As long as you don't post or ask for download links, you're within the rules.


RE: Ragnarok Tactics - Gurlok - 08-12-2013 11:32 PM

Honestly I have to say that it's some kind of contradiction, it sounds silly to me that we are unable to make request/post copyrighted material while being able to freely talk about downloaded games. Well, in the end I just want to prevent further attention from sony.


RE: Ragnarok Tactics - Henrik - 08-13-2013 08:37 AM

Don't download ISOs, and don't talk about doing it in these forums. I guess the rules need some clarification, we need them to stay safe.


RE: Ragnarok Tactics - gianxpaulo - 08-14-2013 06:31 AM

sorry bro that was kind of my first post on this forum, was kinda keen to see if there was a fix for the missing text is all

my bad


RE: Ragnarok Tactics - mr.chya - 08-29-2013 07:17 PM

Hey I just tried this with the latest Dev build 0.9.1-271 for windows x64 and the missing text seems to be fixed. I will continue to test (AKA actually play past character creation and intro) for other issues later. The screenshots stop about where I did.


RE: Ragnarok Tactics - gr4y777 - 08-31-2013 06:57 PM

The ppsspp latest build seem to had already fixed the missing text problem. Even though there are some minor glitch here and there, it still in tolerance. However I'm having a problem for the CWcheat, I cannot activated the cheat codes, even though the cheat codes work in my friend's psp. I thought that the CWcheats in the latest build ppsspp is not working, but I tried another game and it's work.

Any other people have the same problem or is it just me? Or, maybe is there any setting that I need to fix? Can anyone help in solving this problem? Thank you.


RE: Ragnarok Tactics - Drinkie - 09-11-2013 08:32 PM

V0.9.1 Windows 7 64 Bit the text in the boxes doesn't show up at all on the character creation screen and when the character's/NPC's talk thus making it impossible to actually understand what is being said


RE: Ragnarok Tactics - mr.chya - 09-11-2013 08:35 PM

This was fixed in newer dev versions, just get the newest available one from here: http://buildbot.orphis.net/ppsspp/